refactor chrome archives so less is loaded at startup

RESOLVED WONTFIX

Status

SeaMonkey
UI Design
RESOLVED WONTFIX
17 years ago
9 years ago

People

(Reporter: dveditz, Assigned: jag (Peter Annema))

Tracking

({memory-footprint, perf})

Trunk
memory-footprint, perf

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ts])

(Reporter)

Description

17 years ago
We need to refactor our chrome archives so we don't carry around the unnecessary
bloat of nsZipItems pointing at files we're unlikely to use.

Overlay items are the worst, since a single overlayed menu item causes an entire
archive to open (mail, for instance). We should also consider splitting the
monolithic skin and localization archives.

Don't want to go hog wild though, because each additional file we open does have
its costs.
(Reporter)

Updated

17 years ago
QA Contact: sairuh → jrgm
Target Milestone: --- → mozilla0.9.8

Updated

17 years ago
Blocks: 7251
(Reporter)

Updated

17 years ago
Keywords: footprint, perf
(Reporter)

Updated

17 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9

Comment 1

17 years ago
only nsbeta1+ bugs can have milestones, resetting to ---
Target Milestone: mozilla0.9.9 → ---
(Reporter)

Updated

17 years ago
Target Milestone: --- → mozilla0.9.9
(Reporter)

Updated

17 years ago
Status: NEW → ASSIGNED
(Reporter)

Updated

17 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 2

17 years ago
Moving Netscape owned 0.9.9 and 1.0 bugs that don't have an nsbeta1, nsbeta1+,
topembed, topembed+, Mozilla0.9.9+ or Mozilla1.0+ keyword.  Please send any
questions or feedback about this to adt@netscape.com.  You can search for
"Moving bugs not scheduled for a project" to quickly delete this bugmail.
Target Milestone: mozilla1.0 → mozilla1.2

Updated

15 years ago
OS: Windows 2000 → All

Comment 3

14 years ago
Should this one just be closed?

Comment 4

14 years ago
(In reply to comment #0)
> We need to refactor our chrome archives so we don't carry around the 
> unnecessary bloat of nsZipItems pointing at files we're unlikely to use.

dveditz, is this still necessary, now that we no longer compress our
jar-archives? I remember that this saved a lot of the archive size (see bug 118455).

> Overlay items are the worst, since a single overlayed menu item causes an 
> entire archive to open (mail, for instance). We should also consider splitting
> the monolithic skin and localization archives.

If you think, that we should still do this, do you have some kind of a list of
files which you would want to splitt off into new jars? Then I could tackle this
bug.
Product: Core → Mozilla Application Suite
(Reporter)

Updated

11 years ago
Assignee: dveditz → nobody
Status: ASSIGNED → NEW
Assignee: nobody → jag
QA Contact: jrgmorrison
Target Milestone: mozilla1.2alpha → ---

Comment 5

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
does Taras' jar work resolve this?
Ever confirmed: false
Whiteboard: [ts]

Comment 7

9 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

9 years ago
I think this isn't an issue unless one ships jar files with huge amounts of files in them. I think even that's better addressed by something like bug 511754
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX

Updated

9 years ago
QA Contact: ui-design
You need to log in before you can comment on or make changes to this bug.