rename project in WebIDE does not work

VERIFIED FIXED in Firefox 40

Status

DevTools
WebIDE
VERIFIED FIXED
3 years ago
a month ago

People

(Reporter: abdelrhman, Assigned: abdelrhman)

Tracking

39 Branch
Firefox 40
x86_64
All

Firefox Tracking Flags

(firefox40 verified)

Details

(Whiteboard: [bugday-20150708])

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Steps to reproduce:
1. Open WebIDE.
2. Create new packaged app and use the Hello world template.
3. Right-click on project name in left and choose Rename.
4. Rename it to "test".
Actual result: The project name does not change.
(Assignee)

Comment 1

3 years ago
I think we need to hide rename from context menu for the root
for two reasons:
1. conflicts with current code in rename.js when getting its parent.
2. Does not rename the project name, It's renaming the root path.

Project can be renamed through |manifest.webapp|
like description and launch_path can be edited there.
Assignee: nobody → a.ahmed1026
Status: NEW → ASSIGNED
Flags: needinfo?(jryans)
I think it makes sense to hide it, yes.

I will be out next week, so it may take me some time to respond.
Flags: needinfo?(jryans)
(Assignee)

Comment 3

3 years ago
Created attachment 8570802 [details] [diff] [review]
rev 1 - hide rename for root
Attachment #8570802 - Flags: review?(jryans)
Comment on attachment 8570802 [details] [diff] [review]
rev 1 - hide rename for root

Review of attachment 8570802 [details] [diff] [review]:
-----------------------------------------------------------------

Great, this looks good to me.  Sorry about the delay!
Attachment #8570802 - Flags: review?(jryans) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
Ah, thanks for following up here!

But the sheriffs who land our patches will want a try run before landing it.  Let me do that now.
Keywords: checkin-needed
(Assignee)

Comment 6

3 years ago
(In reply to J. Ryan Stinnett [:jryans] from comment #5)
> But the sheriffs who land our patches will want a try run before landing it.
> Let me do that now.

Thanks :)
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/0a899ed1487b
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/0a899ed1487b
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox40: --- → fixed
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 40
I found the bug on Firefox nightly windows 32 bit-

Build ID 	20150226030225
User Agent 	Mozilla/5.0 (Windows NT 6.3; rv:39.0) Gecko/20100101 Firefox/39.0


And this looks fixed on :

Build ID 	20150708030204
User Agent 	Mozilla/5.0 (Windows NT 6.3; rv:42.0) Gecko/20100101 Firefox/42.0

[bugday-20150708]

Updated

3 years ago
QA Whiteboard: [bugday-20150708]
Whiteboard: [bugday-20150708]

Comment 11

3 years ago
What I have understand is, App rename feature is hidden. 

Successfully reproduce the bug on Firefox 39 (20150630154324).

The fix works for me on Firefox 40.0 (Build ID: 20150706172413, User Agent Mozilla/5.0 (X11; Linux i686; rv:40.0) Gecko/20100101 Firefox/40.0) 

Based on the Comment 10 and my verification I am marking the bug as verified.
Status: RESOLVED → VERIFIED
status-firefox40: fixed → verified

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.