Last Comment Bug 1137455 - Error: TypeError: this.mDeferred is null in gdataRequest.jsm
: Error: TypeError: this.mDeferred is null in gdataRequest.jsm
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Provider: GData (show other bugs)
: Lightning 4.0.0.1
: All All
-- normal (vote)
: 4.1
Assigned To: Geoff Lankow (:darktrojan)
:
:
Mentors:
: 1144606 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-26 13:37 PST by Kent James (:rkent)
Modified: 2015-03-27 12:58 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
error.log (21.78 KB, text/plain)
2015-03-03 04:02 PST, Geoff Lankow (:darktrojan)
no flags Details
1137455-1.diff (3.20 KB, patch)
2015-03-07 00:11 PST, Geoff Lankow (:darktrojan)
philipp: review+
Details | Diff | Splinter Review

Description User image Kent James (:rkent) 2015-02-26 13:37:17 PST
Error console, repeated many times:

Error: TypeError: this.mDeferred is null
Source File: resource://gdata-provider/modules/gdataRequest.jsm
Line: 244
Comment 1 User image Philipp Kewisch [:Fallen] 2015-02-26 13:48:38 PST
Any other errors, maybe the one from bug 1101175 ? With calendar.debug.log and calendar.debug.log.verbose enabled, what messages immediately preceed that error?
Comment 2 User image Geoff Lankow (:darktrojan) 2015-03-01 16:27:45 PST
I get this too, although not very often. There's one instance on my console now, with no other messages in the 6 minutes before it.

I also noticed that the non-all-day events on my Google calendar are now missing. If I restart Thunderbird, the all-day events will disappear too.
Comment 3 User image Geoff Lankow (:darktrojan) 2015-03-03 04:02:37 PST
Created attachment 8571913 [details]
error.log

This bug happened to me again (might be something different from my previous comment), and I managed to get the log from this calendar refresh and the two before it. That might help figure out why 401s are occurring in the first place.

(The error in the last line occurred 7 times, it just doesn't show up like that when I cut and paste.)
Comment 4 User image Geoff Lankow (:darktrojan) 2015-03-03 04:14:30 PST
> 00:41:25.699 [calGoogleSession] Token will expire in 0 seconds, refreshing

Perhaps we shouldn't try to reuse a token the very second it expires.
Comment 5 User image Geoff Lankow (:darktrojan) 2015-03-07 00:11:37 PST
Created attachment 8574259 [details] [diff] [review]
1137455-1.diff

Fairly certain that here's the problem. Request fails, authError. Re-auth. Request succeeds, succeed() resolves the promise. Next function in promise chain from original request calls succeed() again.
Comment 6 User image Philipp Kewisch [:Fallen] 2015-03-25 03:45:28 PDT
Comment on attachment 8574259 [details] [diff] [review]
1137455-1.diff

Review of attachment 8574259 [details] [diff] [review]:
-----------------------------------------------------------------

Indeed, this might actually fix it. Can you set a commit message and set checkin-needed? I'll see that this gets to be part of 1.0.5
Comment 7 User image Geoff Lankow (:darktrojan) 2015-03-25 19:54:16 PDT
https://hg.mozilla.org/comm-central/rev/43811e5e942c

(oops, forgot the reviewer in the commit message)
Comment 8 User image [:MakeMyDay] 2015-03-27 12:58:41 PDT
*** Bug 1144606 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.