[RTL][Search] The dropdown arrow is on the wrong side next to the search provider

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: KTucker, Assigned: gmarty)

Tracking

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe], )

Attachments

(2 attachments)

Posted image IMG_0802.JPG
Description:
The user will notice that the dropdown arrow next to the search provider is on the right side.

Repro Steps:
1) Update a Flame to 20150226010233
2) Change the language to Arabic.
3) Type something in the search bar so the "search provider" option appears.
4) Observe the location of the dropdown arrow next to the "search provider" name.

Actual:
The dropdown arrow appears to the right of the search provider.

Expected:
The dropdown arrow should be to the left of the search provider.
 
Environmental Variables:
Device: Flame 3.0(Full Flash)(KK)(319mb)
Build ID: 20150226010233
Gaia: 7894b929f1b0394f3c997f72a6482bc7813e758d
Gecko: dd6353d61993
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 5/5 100%
See attached: screenshot
Blocks: search-rtl
No longer depends on: 1137435
This issue also occurs on the Flame 2.2

The search provider dropdown arrow is on the right. 

Environmental Variables:
Device: Flame 2.2(Full Flash)(KK)(319mb)
BuildID: 20150226002503
Gaia: bf24aa57fa7760260ab05d1f53242c8d8ae59e83
Gecko: 363123044e61
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [rtl-impact][QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [systemsfe]
blocking-b2g: --- → 2.2?
Priority: -- → P2
QA Whiteboard: [rtl-impact][QAnalyst-Triage?] → [rtl-impact][QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
blocking-b2g: 2.2? → 2.2+
Assignee: nobody → gmarty
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15445/
Flags: in-moztrap+
Assignee

Comment 4

4 years ago
Comment on attachment 8572562 [details] [review]
[gaia] gmarty:Bug-1137547-RTL-Dropdown-arrow-on-search > mozilla-b2g:master

Kevin, can you have a look at this patch?
Attachment #8572562 - Flags: review?(kgrandon)
Comment on attachment 8572562 [details] [review]
[gaia] gmarty:Bug-1137547-RTL-Dropdown-arrow-on-search > mozilla-b2g:master

Left a comment on github. Can you address and re-flag me?
Flags: needinfo?(gmarty)
Attachment #8572562 - Flags: review?(kgrandon)

Updated

4 years ago
Status: NEW → ASSIGNED
Assignee

Comment 6

4 years ago
Comment on attachment 8572562 [details] [review]
[gaia] gmarty:Bug-1137547-RTL-Dropdown-arrow-on-search > mozilla-b2g:master

Because of Bug 1139925, we can't get rid of the `direction: rtl` CSS rule and cannot style properly using -moz-padding-(start|end). So we have to use regular `padding` for now.
Flags: needinfo?(gmarty)
Attachment #8572562 - Flags: review?(kgrandon)
Comment on attachment 8572562 [details] [review]
[gaia] gmarty:Bug-1137547-RTL-Dropdown-arrow-on-search > mozilla-b2g:master

That makes me sad, okay though. Thanks for the investigation.
Attachment #8572562 - Flags: review?(kgrandon) → review+
Assignee

Comment 8

4 years ago
Landed in https://github.com/mozilla-b2g/gaia/commit/7a4c47deb6ae3fee7e2851725381e3516daddd72
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Assignee

Comment 9

4 years ago
Comment on attachment 8572562 [details] [review]
[gaia] gmarty:Bug-1137547-RTL-Dropdown-arrow-on-search > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): RTL
[User impact] if declined: The drop down arrow on search providers on search is misplaced in RTL
[Testing completed]: Manual testing
[Risk to taking this patch] (and alternatives if risky): Ultra low, CSS only change
[String changes made]: None
Attachment #8572562 - Flags: approval-gaia-v2.2?(bbajaj)
Hey Guillaume, just so you know this is causing bug 1140525 I don't know if we should uplift this to 2.2 or not. The drop down arrow looks jagged when moved to the left.
Flags: needinfo?(gmarty)
Blocks: 1140525
Assignee

Comment 11

4 years ago
It looks like it is a platform bug. I think we should still uplift it because it's not dramatically bad. Hopefully we can uplift the platform fix too.
Let's wait for a few days until we know what causes it.
Flags: needinfo?(gmarty)
Attachment #8572562 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This issue is verified fixed on the latest Nightly Flame 3.0 and 2.2 builds.

Actual Results: The dropdown arrow is now on the left instead of the right.

Environmental Variables:
Device: Flame 3.0 KK (Full Flash) (319 MB)
BuildID: 20150312010235
Gaia: 0c4e8b0b330757e261b031b7e7f326ef419c9808
Gecko: 5334d2bead3e
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 KK (Full Flash) (319 MB)
BuildID: 20150312002501
Gaia: 572d60e0a440ee4af50bc6b6adad8876eadbdb4d
Gecko: 244e6ba3c20e
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact][QAnalyst-Triage+] → [rtl-impact][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [rtl-impact][QAnalyst-Triage?] → [rtl-impact][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.