[RTL][Contacts] The string "No Contacts Found" is left-aligned and needs more spacing between lines

VERIFIED FIXED in 2.2 S8 (20mar)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ychung, Assigned: arcturus)

Tracking

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Posted image NoContactsFound.png
Description:
When there is no search result from the contact list, the string "No Contacts Found" appears left-aligned.

Repro Steps:
1) Update a Flame to 20150226010233.
2) Set the device language in Arabic under Settings > Language.
3) Open Contacts app.
4) Select "+" icon, and create a new contact with first name "abc" and last name "def".'
5) On the main contacts screen, tap the search field.
6) Type "x".
7) Observe the string "No Contacts Found".

Actual:
The "No Contacts Found" string is left-aligned, and the first and the second line overlaps without enough spacing in between.

Expected:
The "No Contacts Found" string is right-aligned, and there is enough spacing between the lines.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150226010233
Gaia: 7894b929f1b0394f3c997f72a6482bc7813e758d
Gecko: dd6353d61993
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 5/5
See attached: screenshot
(Reporter)

Comment 1

4 years ago
This issue also reproduces on Flame 2.2.

Result: The "No Contacts Found" string is left-aligned, and the first and the second line overlaps without enough spacing in between.
 
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150226002503
Gaia: bf24aa57fa7760260ab05d1f53242c8d8ae59e83
Gecko: 363123044e61
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
Component: Gaia::System::Browser Chrome → Gaia::Contacts
[Blocking Requested - why for this release]: Issue impacting RTL users.
blocking-b2g: --- → 2.2?
triage: critical and must be fixed
blocking-b2g: 2.2? → 2.2+
Priority: -- → P2
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Assignee: nobody → francisco
Status: NEW → ASSIGNED
Target Milestone: --- → 2.2 S7 (6mar)
Attachment #8571332 - Flags: review?(sergi.mansilla)
Comment on attachment 8571332 [details] [review]
[gaia] arcturus:bug-1137549 > mozilla-b2g:master

Changing r? to Fernando since Sergi seems to be busy.
Attachment #8571332 - Flags: review?(sergi.mansilla) → review?(ferjmoreno)
Attachment #8571332 - Flags: review?(ferjmoreno) → review+
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8571332 [details] [review]
[gaia] arcturus:bug-1137549 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
RTL
[User impact] if declined:
Bad user experience
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
Low
[String changes made]:
None
Attachment #8571332 - Flags: approval-gaia-v2.2?
Attachment #8571332 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed in the lates Nightly Flame 3.0 and 2.2 builds.

Actual Results: The "No contacts found" text is correctly right aligned and does not overlap with itself

Environmental Variables:
Device: Flame 3.0
BuildID: 20150311110236
Gaia: 2b87ee8e7e2ec30a9851b6b59a899006a98767ab
Gecko: bc6aeea72290
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150311002522
Gaia: 3f032238a52f08e4c2f68a47ad065a96eb22d470
Gecko: 004fa1cb1dd4
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.