[FFOS2.0][Woodduck][HOMO][Orange AMEA] No sound heared during make of an outgoing call

RESOLVED DUPLICATE of bug 1145040

Status

Firefox OS
Gaia
P2
normal
RESOLVED DUPLICATE of bug 1145040
3 years ago
3 years ago

People

(Reporter: sync-1, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments)

9.54 MB, application/x-rar-compressed
Details
8.82 MB, application/x-rar-compressed
Details
7.63 MB, application/octet-stream
Details
2.67 MB, application/x-zip-compressed
Details
545.89 KB, application/octet-stream
Details
7.48 MB, application/x-zip-compressed
Details
5.45 MB, video/mp4
Details
(Reporter)

Description

3 years ago
Created an attachment (id=1153849)
 ADB log
 
 DEFECT DESCRIPTION:
 
 I have done the test on SW H1N+ME, and when i make an outgoing call using the
 Slot1 no sound is heard to inform the user that the distant phone start
 ringing, but when i make an outgoing call using the Slot2 i can hear the sound.
 
 PS:this issue has been reported to MTK
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

3 years ago
Created attachment 8570265 [details]
video part1
(Reporter)

Comment 2

3 years ago
Created attachment 8570266 [details]
video part2
(Reporter)

Comment 3

3 years ago
Created attachment 8570271 [details]
MTK log
(Reporter)

Comment 4

3 years ago
Created attachment 8570272 [details]
MTK logs on SD card
(Reporter)

Comment 5

3 years ago
Created attachment 8570273 [details]
MTK log part2
(Reporter)

Comment 6

3 years ago
Created attachment 8570274 [details]
MTK Logs
Norry, qawanted to test on latest build and do branch check.
Flags: needinfo?(fan.luo)
Keywords: qawanted
Created attachment 8570346 [details]
Woodduck_video.mp4

Hi Peipei,
  We have no Orange card and we are not sure if it only happens on Orange network environment, so we try it on CU network and behavior is correct and expected.

Step:
1. Update a device to Latest build
2. Insert a CU/CM card to Slot1
3. Make an outgoing call

Actual Result:
Device will play waiting tone to inform the user that the distant phone start ringing.

Fail rate:0/5
See attachment:Woodduck_video.mp4

Woodduck 2.0m version:
Build ID               20150227050313
Gaia Revision          a1b5959728c8bc2a82354e197bb161922d419866
Gaia Date              2015-02-13 09:00:02
Gecko Revision         d9b299dc1087f23c83321b4dccc92e0f52309e8e
Gecko Version          32.0
Device Name            jrdhz72_w_ff
Firmware(Release)      4.4.2
Firmware(Incremental)  1424984723
Firmware Date          Fri Feb 27 05:05:41 CST 2015

Flame 2.0 version:
Build ID               20150226000206
Gaia Revision          366aaa19ac474dc58b79d62a91cff41756ae9dfe
Gaia Date              2015-02-22 20:25:01
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/cfaa08622d8d
Gecko Version          32.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150226.032904
Firmware Date          Thu Feb 26 03:29:15 EST 2015
Bootloader             L1TC000118D0

Flame 2.1 version:
Build ID               20150226001720
Gaia Revision          5d3479fdd438412adee4452720856b6b771fe5cd
Gaia Date              2015-02-25 18:20:09
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/0390c73a827b
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150226.035206
Firmware Date          Thu Feb 26 03:52:17 EST 2015
Bootloader             L1TC000118D0

Flame 2.2 version:
Build ID               20150226002503
Gaia Revision          bf24aa57fa7760260ab05d1f53242c8d8ae59e83
Gaia Date              2015-02-26 01:52:36
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/363123044e61
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150226.040038
Firmware Date          Thu Feb 26 04:00:49 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 version:
Build ID               20150226010233
Gaia Revision          7894b929f1b0394f3c997f72a6482bc7813e758d
Gaia Date              2015-02-25 20:50:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dd6353d61993
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150226.043500
Firmware Date          Thu Feb 26 04:35:10 EST 2015
Bootloader             L1TC000118D0
Flags: needinfo?(fan.luo) → needinfo?(pcheng)
Keywords: qawanted
Hi reporter, 
do you know whether this issue is operator specific? We could not reproduce it on mozilla build using China Unicom or China Mobile sim card.

Could you please help test using another operator sim card?
Flags: needinfo?(pcheng) → needinfo?(sync-1)
Could you please also try following mozilla build to see if it is reproducible?

Link:  http://pan.baidu.com/s/1ntBOIX7
Password:  m5s3
decompress pwd:  erT14moz

Comment 11

3 years ago
(In reply to Peipei Cheng from comment #9)
> Hi reporter, 
> do you know whether this issue is operator specific? We could not reproduce
> it on mozilla build using China Unicom or China Mobile sim card.
> 
> Could you please help test using another operator sim card?

The operator is Orange customer witch is in Europe. so I also can't reproduce
on my side.
(Reporter)

Comment 12

3 years ago
(In reply to comment #3)
 > Comment from Mozilla:Hi reporter, 
 > do you know whether this issue is operator specific? We could not reproduce it
 > on mozilla build using China Unicom or China Mobile sim card.
 > 
 > Could you please help test using another operator sim card?
 > 
 
 the operator is Orange customer witch is in Europe. so I also can't reproduce on my side.

Comment 13

3 years ago
I wonder which part does this issue involved. It seems relate to the sim-slot handling. 
The Orange reporter use other phone to do compare test: 
same sim card and same place, the other phone is behavior well but our phone is come across this issue.

Comment 14

3 years ago
Hi Shawn,
Could you please help to check the issue?thanks!
Flags: needinfo?(sku)

Updated

3 years ago
Blocks: 1054172

Comment 15

3 years ago
Hi Reporter,
 Can we still repo. this issue?

After checking the log attached in comment 4, audio mode are all correct for all three calls.
(ie: IN_CALL -> NORMAL.)


Please kindly let me know if any way to repo. this problem!!



// Log snippet
02-06 08:37:57.557   167   167 I Gecko   : TelephonyService: Put audio system into PHONE_STATE_IN_CALL: 2, result is: 2
02-06 08:37:57.558   167   167 I Gecko   : TelephonyService: handleCallStateChange: {"state":2,"callIndex":1,"toa":145,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"+33615649685","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isEmergency":false,"isOutgoing":true,"isConference":false}
02-06 08:38:11.672   167   167 I Gecko   : TelephonyService: handleCallStateChange: {"state":3,"callIndex":1,"toa":145,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"+33615649685","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isEmergency":false,"isOutgoing":true,"isConference":false}
02-06 08:38:32.495   167   167 I Gecko   : TelephonyService: handleCallStateChange: {"state":0,"callIndex":1,"toa":145,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"+33615649685","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isEmergency":false,"isOutgoing":true,"isConference":false,"started":1423208312489}
02-06 08:39:19.921   167   167 I Gecko   : TelephonyService: Put audio system into PHONE_STATE_NORMAL: 0, result is: 3
02-06 08:39:19.922   167   167 I Gecko   : TelephonyService: handleCallDisconnected: {"state":0,"callIndex":1,"toa":145,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"+33615649685","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isEmergency":false,"isOutgoing":true,"isConference":false,"started":1423208312489,"hangUpLocal":true,"failCause":"NormalCallClearingError"}
02-06 08:39:20.213   167   167 I Gecko   : TelephonyService: Put audio system into PHONE_STATE_NORMAL: 0, result is: 0
---
02-06 08:39:47.698   167   167 I Gecko   : TelephonyService: Put audio system into PHONE_STATE_IN_CALL: 2, result is: 2
02-06 08:39:47.699   167   167 I Gecko   : TelephonyService: handleCallStateChange: {"state":2,"callIndex":1,"toa":145,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"+33615649685","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isEmergency":false,"isOutgoing":true,"isConference":false}
02-06 08:39:52.243   167   167 I Gecko   : TelephonyService: handleCallStateChange: {"state":3,"callIndex":1,"toa":145,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"+33615649685","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isEmergency":false,"isOutgoing":true,"isConference":false}
02-06 08:40:13.049   167   167 I Gecko   : TelephonyService: handleCallStateChange: {"state":0,"callIndex":1,"toa":145,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"+33615649685","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isEmergency":false,"isOutgoing":true,"isConference":false,"started":1423208413043}
02-06 08:40:29.791   167   167 I Gecko   : TelephonyService: Put audio system into PHONE_STATE_NORMAL: 0, result is: 3
02-06 08:40:29.793   167   167 I Gecko   : TelephonyService: handleCallDisconnected: {"state":0,"callIndex":1,"toa":145,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"+33615649685","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isEmergency":false,"isOutgoing":true,"isConference":false,"started":1423208413043,"hangUpLocal":true,"failCause":"NormalCallClearingError"}
02-06 08:40:30.223   167   167 I Gecko   : TelephonyService: Put audio system into PHONE_STATE_NORMAL: 0, result is: 0
---
02-06 08:47:52.368   167   167 I Gecko   : TelephonyService: Put audio system into PHONE_STATE_IN_CALL: 2, result is: 2
02-06 08:47:52.371   167   167 I Gecko   : TelephonyService: handleCallStateChange: {"state":2,"callIndex":1,"toa":145,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"+33615649685","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isEmergency":false,"isOutgoing":true,"isConference":false}
02-06 08:47:56.920   167   167 I Gecko   : TelephonyService: handleCallStateChange: {"state":3,"callIndex":1,"toa":145,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"+33615649685","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isEmergency":false,"isOutgoing":true,"isConference":false}
02-06 08:48:04.582   167   167 I Gecko   : TelephonyService: Put audio system into PHONE_STATE_NORMAL: 0, result is: 0
02-06 08:48:04.583   167   167 I Gecko   : TelephonyService: handleCallDisconnected: {"state":3,"callIndex":1,"toa":145,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"+33615649685","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isEmergency":false,"isOutgoing":true,"isConference":false,"hangUpLocal":true,"failCause":"NormalCallClearingError"}
Flags: needinfo?(sku)

Comment 16

3 years ago
Hi  shawn,
I can't repo the issue on my side. It only happen in our CTS test which mean in the customer environment. From the MTK point of view, they doubt that it maybe relate to local operator but still cannot figure out. I wonder which part can affect the dudu... sound.

Comment 17

3 years ago
(In reply to zhihai.luo.hz from comment #16)
> Hi  shawn,
> I can't repo the issue on my side. It only happen in our CTS test which mean
> in the customer environment. From the MTK point of view, they doubt that it
> maybe relate to local operator but still cannot figure out. I wonder which
> part can affect the dudu... sound.

Then we should have someone to monitor the in-band traffic, I suspect it was caused by testing machine did not send out in-band tone to device that cause this issue.

Audio team should have ability to record pcm data, if there is anyone who can instruct how to use the tool. it will do some great help!!

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1145040
You need to log in before you can comment on or make changes to this bug.