If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

FireFox Nightly 39 (non-e10s mode/64 bit) fails to restore listed recently closed window

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: User Dderss, Unassigned)

Tracking

39 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(e10s-)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8570390 [details]
FireFox Nightly 39 fails to restore recently closed window.png

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150226030225

Steps to reproduce:

I needed to manually restart FireFox. But since it takes forever to close, and I clicked on FireFox icon too early, and the damn thing has opened me a blank window with empty tab before actually unloading (can we prevent this? It annoys me for years). 

So, the next stage is to check if the useful window was yanked for good (as sometimes happens), or it still recoverable, so I go to "History" menu and "Recently close windows" submenu.

Luckily, as see that my windows still exists, and nothing is greyed out, so I supposedly can click on the item (or use keyboard combination) to restore useful window -- see the attached screenshot of this moment -- and then try to close the darn thing again and wait until it actually unloads to then finally open FireFox anew again.


Actual results:

Instead of all of this, nothing happens. You can click on the item with the listed closed window, you can use keyboard, you can restart Nightly -- it will not work. Console does not show a thing. The restoring function worked just fine after I loaded the session with release version of FireFox, so it is not the issue with session itself, it did not get corrupted.


Expected results:

Nightly should just restore the closed window as it was.
(Reporter)

Updated

3 years ago
Component: Untriaged → Session Restore
Hardware: x86 → x86_64

Updated

3 years ago
tracking-e10s: --- → -
(In reply to User Dderss from comment #0)
> Steps to reproduce:
> 
> I needed to manually restart FireFox. But since it takes forever to close,
> and I clicked on FireFox icon too early, and the damn thing has opened me a
> blank window with empty tab before actually unloading (can we prevent this?
> It annoys me for years). 

Letting the shutdown begin and then killing it is asking for trouble. You'd be far better off just killing the program outright with task manager. I've been doing that for years.

That said, session restore files were redone such that if the sessoin file is detect as corrupt on startup, then it uses a backup file.  Apparently your killing firefox during shutdown doesn't cause a corrupt file, so it just starts.
 
> So, the next stage is to check if the useful window was yanked for good (as
> sometimes happens), or it still recoverable, so I go to "History" menu and
> "Recently close windows" submenu.

Can you reproduce this issue with newer Firefox started in safe mode?
If not, please close by setting status to RESOLVED and resolution to WORKSFORME
Flags: needinfo?(zxspectrum3579)
(Reporter)

Comment 2

2 years ago
The issue is not reproducible now, though I am not sure that it was ever reproducible in the first place. It could be a result of a weird case of corruption of session data.

For the time being it should be RESOLVED/WORKSFORME; thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(zxspectrum3579)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.