Memory leak in WebGL with webgl.disable-angle

RESOLVED DUPLICATE of bug 1137251

Status

()

RESOLVED DUPLICATE of bug 1137251
4 years ago
4 years ago

People

(Reporter: neithy.cz, Unassigned)

Tracking

36 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8570464 [details]
View of GPU-Z to monitor resources

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150222232811

Steps to reproduce:

Open any WebGL applications in Firefox 36 with option "webgl.disable-angle"

For example http://threejs.org/examples/webgl_geometry_colors.html


Actual results:

Memory usage of GPU keeps rising untill it reaches maximum.
Application freezes.


Expected results:

Memory usage should be constant. Application should run normaly.

Comment 1

4 years ago
I'm not able to reproduce the issue with webgl.disable-angle=false with FF36 or 39.

It could be a dupe of bug 1137251.
Component: Untriaged → Canvas: WebGL
Product: Firefox → Core
(Reporter)

Comment 2

4 years ago
(In reply to Loic from comment #1)
> I'm not able to reproduce the issue with webgl.disable-angle=false with FF36
> or 39.
> 
> It could be a dupe of bug 1137251.

To clarify myself. Bug appears with "webgl.disable-angle=true" in version 36.0. Tested on two different computers.
(Reporter)

Comment 3

4 years ago
And yes, probably same as bug 1137251.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1137251
You need to log in before you can comment on or make changes to this bug.