Closed Bug 1137689 Opened 5 years ago Closed 5 years ago

Mozreview should let me specify reviewers when I push

Categories

(MozReview Graveyard :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1142251

People

(Reporter: ted, Unassigned)

Details

Right now publishing a review through Mozreview is always a two-step process:
1) hg push review
2) Load review URL, pick reviewer, publish

One thing I miss from my bzexport workflow is that I could pass reviewer names on the commandline so I didn't have to load a webapp at all to get a review submmitted. bzexport supports "--review=:user" and also "--review=auto" which will look in the changeset description for "r[?=]user" and use that.

It would be great if we could support this workflow for Mozreview so that I didn't have to load the webapp to set reviewers and publish.
This may be on file already. I know we've definitely talked about this.

The plan is to leverage automatic reviewer selection from in-tree metadata based on the set of files that a commit changes. We also want to recycle old reviewers from already-submitted reviews. This requires refactoring submission to involve multiple round trips. That work is ongoing and we should have something to show for it within the next month. This should become a low-hanging fruit after some core changes are made.
That sounds nice, but for my workflow 99% of the time I have a specific reviewer in mind and I'd just like to specify who.
We'll fix this by adding support for r=... in the commit message.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1142251
Product: Developer Services → MozReview
You need to log in before you can comment on or make changes to this bug.