[camera] capture interaction via volume key needs to be optional for manufacturers

RESOLVED FIXED

Status

Firefox OS
Gaia::Camera
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: tif, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: interaction-design)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Since we have no control over hardware, the feature to snap photos or record videos in the camera app via the volume key needs the ability to be disabled by the manufacturer.
(Reporter)

Updated

3 years ago
Whiteboard: interaction-design
Created attachment 8571351 [details] [review]
[gaia] wilsonpage:1137918 > mozilla-b2g:master
Created attachment 8571352 [details] [review]
pull-request (master)
Attachment #8571352 - Flags: review?(jdarcangelo)
This patch implements a new config.js object that defines what app `keydown:*` event should fire when a specific hardware key is pressed. This means partners can easily switch-off/change default functionality.
Attachment #8571352 - Attachment is obsolete: true
Attachment #8571352 - Flags: review?(jdarcangelo)
Attachment #8571351 - Flags: review?(jdarcangelo)
Comment on attachment 8571351 [details] [review]
[gaia] wilsonpage:1137918 > mozilla-b2g:master

LGTM
Attachment #8571351 - Flags: review?(jdarcangelo) → review+
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Blocks: 1135789
Depends on: 1133965
Depends on: 1137013
Created attachment 8582373 [details] [review]
[gaia] wilsonpage:1137918-v2.2 > mozilla-b2g:v2.2
Comment on attachment 8582373 [details] [review]
[gaia] wilsonpage:1137918-v2.2 > mozilla-b2g:v2.2

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Volume rocker will toggle volume and not capture
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky): New feature, moderate risk.
[String changes made]: None
Attachment #8582373 - Flags: approval-gaia-v2.2?
Comment on attachment 8582373 [details] [review]
[gaia] wilsonpage:1137918-v2.2 > mozilla-b2g:v2.2

Layered on top of v2.2 patch for bug 1137013
(In reply to Wilson Page [:wilsonpage] from comment #7)
> Comment on attachment 8582373 [details] [review]
> [gaia] wilsonpage:1137918-v2.2 > mozilla-b2g:v2.2
> 
> [Approval Request Comment]
> [Bug caused by] (feature/regressing bug #):
> [User impact] if declined: Volume rocker will toggle volume and not capture
> [Testing completed]:
> [Risk to taking this patch] (and alternatives if risky): New feature,
> moderate risk.
> [String changes made]: None

I am not sure why we are requesting to uplift new feature's to 2.2 at this point. This will get fixed on our release. Not sure if I am missing any information or a product requirement so please reach to me to discuss in that case.

Updated

3 years ago
Attachment #8582373 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2-
(In reply to bhavana bajaj [:bajaj] from comment #9)
> (In reply to Wilson Page [:wilsonpage] from comment #7)
> > Comment on attachment 8582373 [details] [review]
> > [gaia] wilsonpage:1137918-v2.2 > mozilla-b2g:v2.2
> > 
> > [Approval Request Comment]
> > [Bug caused by] (feature/regressing bug #):
> > [User impact] if declined: Volume rocker will toggle volume and not capture
> > [Testing completed]:
> > [Risk to taking this patch] (and alternatives if risky): New feature,
> > moderate risk.
> > [String changes made]: None
> 
> I am not sure why we are requesting to uplift new feature's to 2.2 at this
> point. This will get fixed on our release. Not sure if I am missing any
> information or a product requirement so please reach to me to discuss in
> that case.

Discussions here from UX: https://bugzilla.mozilla.org/show_bug.cgi?id=1135789#c25. I'm not sure if they are aware that this does impose instability risks for v2.2.

Comment 11

3 years ago
No, we were not aware that this creates instability risks.

Comment 12

3 years ago
I want to make sure we're on the same page about the history of this feature. This did not come from UX. We did not ask for this. Wilson was working on it, we found about about it after it landed, and we offered some options for how it should behave, because a few things were buggy and we got flagged on behavior questions. That's when we said "it's optional, the volume controls only the shutter while in viewfinder," etc.

We said that, if these things were fixed, Wilson could land it. He fixed those things, but if it introduces instability, it's not fixed enough. 

As far as UX concerned, this is a totally optional feature. If it introduces instability, we should leave it out.
You need to log in before you can comment on or make changes to this bug.