mozilla crash while showing simple tables

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
16 years ago
4 years ago

People

(Reporter: Calvin Liu, Assigned: asa)

Tracking

({crash, perf})

Trunk
Sun
Solaris
crash, perf

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6) Gecko/20011120
BuildID:    2001112114



Reproducible: Always
Steps to Reproduce:
reproduction:
1. start mozilla 0.9.6 on solaris 8/sparc
2. select menu item [Debug]->[Viewer Demos]->[#4 Simple Tables]


Actual Results:  then mozilla crash
(Reporter)

Comment 1

16 years ago
Created attachment 60617 [details]
mozilla test sample

Comment 2

16 years ago
Is it Solaris-specific ? I do not crash using build 2001120504 on Win2k.
Keywords: crash

Comment 3

16 years ago
WFM. Build ID: 2001 12 05 16. Windows 2000.

Comment 4

16 years ago
Works for me with Solaris milestone 0.9.6 and Solaris nightly build 2001120522
under Sparc Solaris 7.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

16 years ago
could you try it again on solaris8?

Comment 6

16 years ago
Unfortunately I don't have access to a Solaris 8 box.  If you can find someone
who can confirm this, then it can be re-opened.  Have you tried it with a
recently nightly build? Also, could you try get a back trace of the core?
(Reporter)

Updated

16 years ago
Keywords: perf
Product: Browser → Seamonkey

Comment 7

12 years ago
Created attachment 221380 [details]
same attached file (mozilla_test_sample), but stripped down to one tbody tag. (others removed).

This will cause mozilla 1.7.5 and mozilla 1.7.12 on sparc/solaris2.8 to crash. with the following X Error:


X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  12 (X_ConfigureWindow)
  Value in failed request:  0x0
  Serial number of failed request:  5482
  Current serial number in output stream:  5494

Comment 8

12 years ago
Created attachment 221381 [details]
added a width parameter to the tbody style - mozilla shows the table without crashing

opened this file using mozilla 1.7.5 and 1.7.12 on sparc/solaris 2.8.  The table displays without crashing.

Comment 9

12 years ago
For the two files attached, one is stripped down to one tbody tag with everything else removed, and it crashes.  The other has a width parameter added to that stripped down file, and when opened, mozilla does not crash.  This was tested using mozilla 1.7.5 and 1.7.12.  Both on Sparc/Solaris2.8, and j2sdk1.4.2_06 (if that helps).  

Comment 10

12 years ago
(In reply to comment #9)
> For the two files attached, one is stripped down to one tbody tag with
> everything else removed, and it crashes.  The other has a width parameter added
> to that stripped down file, and when opened, mozilla does not crash.  This was
> tested using mozilla 1.7.5 and 1.7.12.  Both on Sparc/Solaris2.8, and
> j2sdk1.4.2_06 (if that helps).  


Forgot to mention - the steps I used were:
1) opening the mozilla browser.  
2) Selecting Open File from the File Menu, and 
3) opening the html files.

Comment 11

12 years ago
well erm, is someone from sun planning on maintaining the 1.7 branch? there's a patch in another bug to try to handle general x/gtk errors....

if you want to do something, you should build debug w/ that patch and run w/ --sync (as the instructions from the exit indicate...).
Whiteboard: DUPEME

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.