With fcitx input method enabled, browsing open file dialog crashes firefox

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: weichen302, Unassigned)

Tracking

({crash})

31 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
The problem might have something to do with xfce4 file manager, however, firefox 24 works perfect fine, firefox 31 and 37 on the other hand, crashes every time. It also happens to thunderbird 31 but not to thunderbird 24. My guess is component shared by firefox and thunderbird that changed between version 24 and 31 causes the problem.

Bring up open file dialog by click on File->Open File, then click the shortcuts on right side of dialog few times to choose several different shortcuts. This operation will crash firefox and thunderbird every time.

PS. The shortcuts of xfce4 file manager is similar to folder or favorite in windows explorer.
(Reporter)

Comment 1

4 years ago
I did more tests. The problem appears started on version 29, became worse on version 30.


Version 28: Only crashed once after tried dozens of times


Version 29 and 29.0.1:  Hard to crash with empty firefox window. Crash easily after open several websites in tabs

Version 28 and 29.x all print out following error on terminal while clicking on different shortcuts of xfce4 file manager window, firefox is otherwise running normal.

(firefox:25268): GLib-GObject-WARNING **: instance with invalid (NULL) class pointer
(firefox:25268): GLib-GObject-CRITICAL **: g_signal_emit_valist: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed


Version 30: Crashes every time even with empty firefox window.
The above Glib-xxx error message is not seen on version 30 while clicking on different shortcuts. When firefox crashes, it prints out "Bus error" on terminal.

Comment 2

4 years ago
Thanks for taking the time to report this!
Please follow the steps on http://support.mozilla.com/kb/Firefox%20crashes and report back here. Thanks!
Flags: needinfo?(weichen302)
(Reporter)

Comment 3

4 years ago
Firefox still crash when starts in safe mode with a brand new profile.


crash id: bp-efa2a5b2-43a3-4cb8-a64b-2963f2150228
Flags: needinfo?(weichen302)
Version: 37 Branch → 31 Branch

Comment 4

4 years ago
That crash id mentions fcitx-libs. 
Does the problem still happen when disabling or uninstalling that input method?

Which operating system or distribution is this about?
Flags: needinfo?(weichen302)
(Reporter)

Comment 5

4 years ago
Interesting. Disable fcitx fixed the problem, both firefox 31 and thunderbird 31 stopped crashing.

The OS is Debian Wheezy. Fcitx is from Debian repository.
Flags: needinfo?(weichen302)

Updated

4 years ago
Summary: browsing open file dialog crashes firefox → With fcitx input method enabled, browsing open file dialog crashes firefox

Comment 6

2 years ago
(In reply to Chen Wei from comment #3)
> Firefox still crash when starts in safe mode with a brand new profile.
> 
> 
> crash id: bp-efa2a5b2-43a3-4cb8-a64b-2963f2150228

unfortunately this crashID has aged off the system without us getting the crash signature.

Can you still reproduce the problem?
Flags: needinfo?(weichen302)
Keywords: crash
(Reporter)

Comment 7

2 years ago
On firefox 45.0.2, the crash has disappeared. I have not tested it on newer thunderbird since I am still using 24.8.1.
Flags: needinfo?(weichen302)

Comment 8

2 years ago
Thanks for the update.
Please reopen the bug if it happens to Thunderbird when you test or update to 45 or newer.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.