bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Unexpected failure on Orientation test

RESOLVED WONTFIX

Status

Firefox OS
MCTS Waiver Request
RESOLVED WONTFIX
3 years ago
5 months ago

People

(Reporter: Viga, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
fxos-MCTS-2.0/2.7env/lib/python2.7/site-packages/fxos_certsuite-2.0.1-py2.7.egg/webapi_tests/orientation/test_device_orientation.py", line 79, in test_device_changes
    self.assertTrue(self.get_window_value('alpha'), "expected alpha")
AssertionError: expected alpha

Updated

3 years ago
Summary: Orientation test → Unexpected failure on Orientation test

Comment 1

3 years ago
Per check with Weijia offline, Weijia will help to double check the test again and make sure if they still receive the same assertion error.

Comment 2

3 years ago
Created attachment 8571160 [details]
w3c device orientation usage

the link is a reference for the orientation change
fxos-certsuite/webapi_tests/orientation/test_device_orientation.py Line 73~Line 81

Comment 3

3 years ago
put it back as a unconfirmed bug. Please put it back to new if you still encounter the same situation after retry, Weijia. :p
Status: NEW → UNCONFIRMED
Ever confirmed: false

Updated

3 years ago
Blocks: 1133434

Comment 4

3 years ago
Per checking offline, there's no alpha value return from event.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

3 years ago
(In reply to Al Tsai [:atsai] from comment #4)
> Per checking offline, there's no alpha value return from event.

For more investigation, the cause is that no E-compass for the device(onetouch).
So request a waiver.
Status: RESOLVED → REOPENED
Component: Certification Suite → MCTS Waiver Request
Ever confirmed: true
Resolution: INVALID → ---

Comment 6

3 years ago
remove the blocker since it's no longer a tool bug.
No longer blocks: 1133434

Comment 7

5 months ago
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.