[Flame][Settings]The "Cannot Create Account" prompt page can't pop up again after you tap "Next" again.

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Settings
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Lance(leave from Mozilla), Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.1S unaffected, b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8570881 [details]
logcat_1621.txt

[1.Description]:
[Flame 2.2 & 3.0][Settings]The "Cannot Create Account" prompt page can't pop up again after you tap "Next" again.
Found time:16:21
See attachment: 1621.mp4 and logcat_1621.txt

[2.Testing Steps]: 
1.Launch Settings.
2.Tap "Firefox Accounts" -> "Create Account or Sign In".
3.Input an email address which has not been registered.
4.Tap "Next" -> "Year of Birth", select any year after 2002, then tap "OK".
5.Tap "Next", after the "Cannot Create Account" pop up, tap "OK".
6.Tap "Next" again.

[3.Expected Result]: 
6.The "Cannot Create Account" page should pop up again.

[4.Actual Result]: 
6.The "Cannot Create Account" page can't pop up again.

[5.Reproduction build]: 
Flame 2.2 version:
Build ID               20150227002521
Gaia Revision          eb6a5ac9081d3962198e0f4520b0743d716d7a27
Gaia Date              2015-02-26 17:25:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c8a38dcfbebc
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150227.035943
Firmware Date          Fri Feb 27 03:59:54 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 version:
Build ID               20150227010229
Gaia Revision          7512026a377271a0cade12d70846557f0bc7781c
Gaia Date              2015-02-26 19:06:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c7968255c1ea
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150227.044026
Firmware Date          Fri Feb 27 04:40:36 EST 2015
Bootloader             L1TC000118D0
[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8570882 [details]
1621.MP4

Comment 2

3 years ago
Hi, Lance,

May I have your help?
Can it be reproduced on v2.1 and v2.1s?
Flags: needinfo?(liuke)
(Reporter)

Comment 3

3 years ago
The bug does not exist in latest Flame 2.1 and 2.1s(512m) build.

Steps:
1.Launch Settings.
2.Tap "Firefox Accounts" -> "Create Account or Sign In".
3.Input an email address which has not been registered.
4.Tap "Next" -> "Year of Birth", select any year after 2002, then tap "OK".
5.Tap "Next", after the "Cannot Create Account" pop up, tap "OK".
6.Tap "Next" again.

Actual Result:
6.The "Cannot Create Account" page will pop up again.

Fail rate:0/5

Flame 2.1 version:
Build ID               20150302001220
Gaia Revision          5d3479fdd438412adee4452720856b6b771fe5cd
Gaia Date              2015-02-25 18:20:09
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/9bf4c663241f
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150302.035532
Firmware Date          Mon Mar  2 03:55:42 EST 2015
Bootloader             L1TC000118D0

2.1s(512m) version:
Build ID               20150302001206
Gaia Revision          a43d64ae01ef108aa4dcc971c770fecd8416a764
Gaia Date              2015-02-26 09:24:39
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/2437280c634f
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  122
Firmware Date          Thu Feb  5 12:42:58 CST 2015
QA Whiteboard: [MGSEI-Triage+]
status-b2g-v2.1: --- → unaffected
status-b2g-v2.1S: --- → unaffected
Flags: needinfo?(liuke)
I cannot reproduce this with today's v2.2 Flame-KK, hi Lance, could you help to verify again, thank you.
Flags: needinfo?(liuke)
Keywords: regression
(Reporter)

Comment 5

3 years ago
The problem is verified not happen on latest Flame 2.2 and 3.0 build.

Steps:
1.Launch Settings.
2.Tap "Firefox Accounts" -> "Create Account or Sign In".
3.Input an email address which has not been registered.
4.Tap "Next" -> "Year of Birth", select any year after 2002, then tap "OK".
5.Tap "Next", after the "Cannot Create Account" pop up, tap "OK".
6.Tap "Next" again.

Actual Result:
6.The "Cannot Create Account" page will pop up again.

Fail rate:0/5

Flame 2.2 version:
Build ID               20150311002522
Gaia Revision          3f032238a52f08e4c2f68a47ad065a96eb22d470
Gaia Date              2015-03-11 00:28:07
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/004fa1cb1dd4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150311.040546
Firmware Date          Wed Mar 11 04:05:57 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 version:
Build ID               20150311010231
Gaia Revision          943c8b4039f59b08ba100390e164a076a20c892e
Gaia Date              2015-03-10 20:35:07
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/fd8e079d6335
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150311.043838
Firmware Date          Wed Mar 11 04:38:50 EDT 2015
Bootloader             L1TC000118D0
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(liuke)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.