Special characters in anchors (link) - cross software bug?

UNCONFIRMED
Unassigned

Status

Thunderbird
Message Reader UI
UNCONFIRMED
3 years ago
3 years ago

People

(Reporter: Marco, Unassigned)

Tracking

31 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

94.61 KB, image/png
Details
(Reporter)

Description

3 years ago
Created attachment 8570944 [details]
bug.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150224134236

Steps to reproduce:

write a simple message to yourself or to other people and include a non punycode translatet link. Example: www.bürando.de (notice the german 'ü') and hit the link.





Actual results:

Firefox will start and tries to open the page, but fail.

Error Message)
German:
(Error: Der Server unter www.b%c3%bcrando.de konnte nicht gefunden werden.)
English:
(Error: The server isnt available within the address www.b%c3%bcrando.de)

firefox also shows the correct translatet name (www.bürando.de), but the Page doenst load. If i move my courser to the adress-bar, click in it (without changing anything) and hit the enter button, all is working fine. 


Expected results:

Maybe firefox and or thunderbird should convert the link correctly.
Thunderbird could rewrite the link (if the user click on it) with the punycode code
www.xn--brando-3ya.de and / or firefox handle the b%c3%bcrando.de input.

(OS: Ubuntu 14.04, Firefox 36, Thunderbird: 31.04)
You need to log in before you can comment on or make changes to this bug.