Simplify the resume info printed at the end of a mozregression run

RESOLVED WONTFIX

Status

Testing
mozregression
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: parkouss, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
We are trying pretty hard to give a good "how to resume" information when an user type "e" to exit or when some network exception / CTRL-C appears.
When I end a run with CTRL-C for example, it will print something like:

> 7:28.30 LOG: Dummy-115 Bisector INFO To resume, run:
> 7:28.30 LOG: Dummy-115 Bisector INFO mozregression --inbound --good-rev=d381f2e0d417 --bad-rev=84c309df6d24 --app=firefox  --bits=64

Problem is that the piece of code that does that (https://github.com/parkouss/mozregression/blob/9a99d82071f383147b14899b64c96bad467e6bd6/mozregression/bisector.py#L421) is not maintenable. It is really hard to keep this up to date and to provide the real command line that will really do the job of resuming (with the exact list of options provided by user).

- I remember it was already broken in the past (we missed some command line changes...)
- it is currently broken (not all options are handled in this, meaning this is not a complete resume command)
- it will break in future even if we fix it now (yeah, the question is only when)

Instead of trying to provide the complete command line to resume, I suggest that we only provide what is useful: the --good/--bad or --good-rev/--bad-rev options.

This will then looks like:

> 7:28.30 LOG: Dummy-115 Bisector INFO To resume, use --good-rev=d381f2e0d417 --bad-rev=84c309df6d24 in the last executed command.

(Note that I intentionnaly removed the --inbound flag, because it will disappear with bug 1106804)

I don't think it is the exact command line that user wants here. I think it is sufficient to indicate how the run could be resumed.

Will, what do you think ?
(Reporter)

Updated

2 years ago
See Also: → bug 1176033
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.