Clang plugin causes segfault in LLVM 3.6

RESOLVED DUPLICATE of bug 1180549

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 1180549
3 years ago
2 years ago

People

(Reporter: Alex Xu, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8571023 [details]
TestNANTestingExprC-76513e.c

#0 0x2b368fe904c2 llvm::sys::PrintStackTrace(_IO_FILE*) (/usr/bin/../lib/libLLVM-3.6.so+0x77c4c2)
#1 0x2b368fe8eb21 (/usr/bin/../lib/libLLVM-3.6.so+0x77ab21)
#2 0x2b3690d30150 (/lib64/libpthread.so.0+0x10150)
#3 0x2b36918e30a2 clang::ast_matchers::MatchFinder::newASTConsumer() (../../../build/clang-plugin/libclang-plugin.so+0x1020a2)
#4 0x2b3691833cd2 (anonymous namespace)::DiagnosticsMatcher::makeASTConsumer() (../../../build/clang-plugin/libclang-plugin.so+0x52cd2)
#5 0x2b36918330e2 (anonymous namespace)::MozChecker::getOtherConsumer() (../../../build/clang-plugin/libclang-plugin.so+0x520e2)
#6 0x2b3691832d58 (anonymous namespace)::MozCheckAction::CreateASTConsumer(clang::CompilerInstance&, llvm::StringRef) (../../../build/clang-plugin/libclang-plugin.so+0x51d58)
#7 0x7188c3 clang::FrontendAction::CreateWrappedASTConsumer(clang::CompilerInstance&, llvm::StringRef) (/usr/bin/x86_64-pc-linux-gnu-clang-3.6.0+0x7188c3)
#8 0x719739 clang::FrontendAction::BeginSourceFile(clang::CompilerInstance&, clang::FrontendInputFile const&) (/usr/bin/x86_64-pc-linux-gnu-clang-3.6.0+0x719739)
#9 0x6f45d1 clang::CompilerInstance::ExecuteAction(clang::FrontendAction&) (/usr/bin/x86_64-pc-linux-gnu-clang-3.6.0+0x6f45d1)
#10 0x6dc6c3 clang::ExecuteCompilerInvocation(clang::CompilerInstance*) (/usr/bin/x86_64-pc-linux-gnu-clang-3.6.0+0x6dc6c3)
#11 0x6d6c48 cc1_main(llvm::ArrayRef<char const*>, char const*, void*) (/usr/bin/x86_64-pc-linux-gnu-clang-3.6.0+0x6d6c48)
#12 0x6d6306 main (/usr/bin/x86_64-pc-linux-gnu-clang-3.6.0+0x6d6306)
#13 0x2b3691463fa0 __libc_start_main (/lib64/libc.so.6+0x1ffa0)
#14 0x6d6375 _start (/usr/bin/x86_64-pc-linux-gnu-clang-3.6.0+0x6d6375)
Stack dump:
0.      Program arguments: /usr/bin/x86_64-pc-linux-gnu-clang-3.6.0 -cc1 -triple x86_64-pc-linux-gnu -fsyntax-only -disable-free -disable-llvm-verifier -main-file-name TestNANTestingExprC.c -mrelocation-model pic -pic-level 2 -mthread-model posix -relaxed-aliasing -masm-verbose -mconstructor-aliases -munwind-tables -fuse-init-array -target-cpu corei7 -target-linker-version 2.25 -momit-leaf-frame-pointer -g -dwarf-column-info -resource-dir /usr/bin/../lib/clang/3.6.0 -include ../../../mozilla-config.h -D MOZ_GLUE_IN_PROGRAM -D AB_CD=en-US -D NO_NSPR_10_SUPPORT -D MOZILLA_CLIENT -D NDEBUG -D TRIMMED -I /home/alex/gecko-dev/build/clang-plugin/tests -I . -I ../../../dist/include -I /usr/include/nspr -I /home/alex/gecko-dev/obj-x86_64-unknown-linux-gnu/dist/include/nss -I /usr/include/pixman-1 -internal-isystem /usr/local/include -internal-isystem /usr/bin/../lib/clang/3.6.0/include -internal-externc-isystem /include -internal-externc-isystem /usr/include -O2 -std=gnu99 -fdebug-compilation-dir /home/alex/gecko-dev/obj-x86_64-unknown-linux-gnu/build/clang-plugin/tests -ferror-limit 0 -fmessage-length 0 -pthread -mstackrealign -fgnu89-inline -fobjc-runtime=gcc -fdiagnostics-show-option -vectorize-loops -vectorize-slp -verify -load ../../../build/clang-plugin/libclang-plugin.so -add-plugin moz-check -x c /home/alex/gecko-dev/build/clang-plugin/tests/TestNANTestingExprC.c
x86_64-pc-linux-gnu-clang-3.6.0: error: unable to execute command: Segmentation fault (core dumped)
x86_64-pc-linux-gnu-clang-3.6.0: error: clang frontend command failed due to signal (use -v to see invocation)
clang version 3.6.0 (tags/RELEASE_360/final)
Target: x86_64-pc-linux-gnu
Thread model: posix
x86_64-pc-linux-gnu-clang-3.6.0: note: diagnostic msg: PLEASE submit a bug report to http://llvm.org/bugs/ and include the crash backtrace, preprocessed source, and associated run script.
x86_64-pc-linux-gnu-clang-3.6.0: note: diagnostic msg:
********************

PLEASE ATTACH THE FOLLOWING FILES TO THE BUG REPORT:
Preprocessed source(s) and associated run script(s) are located at:
x86_64-pc-linux-gnu-clang-3.6.0: note: diagnostic msg: /tmp/TestNANTestingExprC-76513e.c
x86_64-pc-linux-gnu-clang-3.6.0: note: diagnostic msg: /tmp/TestNANTestingExprC-76513e.sh
x86_64-pc-linux-gnu-clang-3.6.0: note: diagnostic msg:

********************

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1180549
You need to log in before you can comment on or make changes to this bug.