Three strings about SMTP errors tell user to change connection/password/authentication method in Account settings > Server settings, but should be in Outgoing server (SMTP)

RESOLVED FIXED in Thunderbird 39.0

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: aryx, Assigned: aceman)

Tracking

Trunk
Thunderbird 39.0
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.36 fixed)

Details

Attachments

(2 attachments)

Three strings about SMTP errors tell user to change connection/password/authentication method in Account settings > Server settings, but should be in Outgoing server (SMTP)

smtpAuthChangeEncryptToPlainNoSsl=The Outgoing server (SMTP) %S does not seem to support encrypted passwords. If you just set up the account, try changing the 'Authentication method' in 'Account Settings | Server settings' to 'Password, transmitted insecurely'. If it used to work but now doesn't, you may be susceptible to getting your password stolen.
smtpAuthChangeEncryptToPlainSsl=The Outgoing server (SMTP) %S does not seem to support encrypted passwords. If you just set up the account, try changing the 'Authentication method' in 'Account settings | Server settings' to 'Normal password'.
smtpAuthChangePlainToEncrypt=The Outgoing server (SMTP) %S does not allow plaintext passwords. Please try changing the 'Authentication method' in 'Account Settings | Server settings' to 'Encrypted password'.
And I called it out in bug 952493 comment #45 too...
Well, considering the comment:
>>+# LOCALIZATION NOTE (smtpAuthChangeEncryptToPlainSsl): %S is the server hostname
>>+smtpAuthChangeEncryptToPlainSsl=The SMTP server %S does not seem to support encrypted passwords. If you just >+# LOCALIZATION NOTE (smtpAuthChangePlainToEncrypt): %S is the server hostname
>>+smtpAuthChangePlainToEncrypt=The SMTP server %S does not allow plaintext passwords. Please try changing the 'Authentication method' in 'Account Settings | Server settings' to 'Encrypted password'.
>>+# LOCALIZATION NOTE (smtpAuthFailure): %S is the server hostname
>>+smtpAuthFailure=Unable to authenticate to SMTP server %S. Please check the password, and verify the 'Authentication method' in 'Account Settings | Outgoing server (SMTP)'.

>Huh, shouldn't these all say Outgoing server (SMTP)?

You see Suyash changed the string, but he changed the leading "SMTP server" to "Outgoing server (SMTP)", going by the "SMTP" keyword.
The comment was probably too short or ambiguous to understand you mean to rewrite the whole path to Account manager pane instead :)

Now that seems to be clear, I'll do it.
Assignee: nobody → acelists
Status: NEW → ASSIGNED
Attachment #8571529 - Flags: review?(neil)
Attachment #8571529 - Flags: review?(mkmelin+mozilla)
(In reply to aceman from comment #2)
> The comment was probably too short or ambiguous to understand you mean to
> rewrite the whole path to Account manager pane instead :)

Oops. Sorry, Suyash.
Bah, these have reached Aurora and 11 localisers have already translated them.
Comment on attachment 8571529 [details] [diff] [review]
patch [checked in]

(Huh, when did Thunderbird drop the "please" from their two strings?)
Attachment #8571529 - Flags: review?(neil) → review+
Is this something that we will need for TB 38?
If you r+ it for /mail it could go into TB38. But it is no regression (the bug was in the strings even before Suyash touched them recently), just a bug fix. So you can decide.
Flags: needinfo?(rkent)
If this was not a regression, then we should not try to push it into TB 38.
Flags: needinfo?(rkent)
Comment on attachment 8571529 [details] [diff] [review]
patch [checked in]

Review of attachment 8571529 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM!
Attachment #8571529 - Flags: review?(mkmelin+mozilla) → review+
Thanks.
Keywords: checkin-needed
Comment on attachment 8571529 [details] [diff] [review]
patch [checked in]

a=me for SeaMonkey CLOSED TREE
Pushed to comm-central:
http://hg.mozilla.org/comm-central/rev/30f695264e00
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 39.0
Nit: the asociated loc notes need to be adjusted as well, the entity names do not match with actual entities now.
Argh, thanks for noticing.
Attachment #8574859 - Flags: review?(mkmelin+mozilla)
Attachment #8574859 - Flags: review?(mkmelin+mozilla) → review+
Attachment #8571529 - Attachment description: patch → patch [checked in]
Keywords: checkin-needed
Whiteboard: [check in only the remaining patch]
Comment on attachment 8574859 [details] [diff] [review]
patch fix notes

a=me for SeaMonkey CLOSED TREE
Pushed localization comment fixes as https://hg.mozilla.org/comm-central/rev/ad7600eae938
Keywords: checkin-needed
Whiteboard: [check in only the remaining patch]
You need to log in before you can comment on or make changes to this bug.