Closed Bug 1138247 Opened 6 years ago Closed 5 years ago

Window decorations (close, minimize, and maximize buttons) are missing with lwtheming

Categories

(SeaMonkey :: Themes, defect)

x86_64
macOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.42

People

(Reporter: mnyromyr, Assigned: stefanh)

References

Details

Attachments

(1 file, 1 obsolete file)

The red/yellow/green buttons of the window title bar (for close/minimize/maximize) are missing when:
- fullscreen mode (shift-cmd-f) is active, or
- lwtheming is active

WIth lwtheming, even the window title text is missing.
Attached patch WIP (obsolete) — Splinter Review
This is a wip - it doesn't get us any window title. I don't think we should display any window controls in full screen, but we should probably get rid of that extra space at the top.
Window controls (maximize, unmaximize, minimize and close) need to be displayed. It may be considered stylish not to have them, but darned if I want to click on a box in the open-window list at the bottom or top of the screen to do those actions. Some window managers make access to windows gawdawfully difficult. They need to be in the top left corner of the window.
However, I wouldn't call this a major bug with the open-window list accessible. An operation there to maximize, unmaximize or minimize the window will cause it to be re-displayed with the desired widgets or decorations if you prefer. On a decent desktop, that's an easy work-around.
The entire trend against window decorations, combined with the lack of clickable open-window icons or boxes at the top/bottom/side of the screen, means that these window managers and programs are going back to the one-window-at-a-time displays like MS-DOS used to have. This is crazy. There are reasons to have multiple windows open and accessible and fad stylists are ignoring it as if they were born yesterday. Sorry for the rant, but this is a very bad trend that needs to be nipped in the bud.
Comment on attachment 8577772 [details] [diff] [review]
WIP

>+#titlebar-buttonbox-container:-moz-locale-dir(ltr) {
>+  -moz-box-align: start;
>+}
>+
>+#titlebar-buttonbox-container:-moz-locale-dir(rtl) {
>+  -moz-box-align: end;
>+}
(Huh, left is deprecated? Otherwise <hbox id="titlebar-buttonbox-container" align="left">)
Hm, I agree with Comment 1, I (WIN7) do not want the window-min-max-close buttons in full screen mode, what at least seems to be more or less common sense in the WINDOWS world.

Also see "Bug 1185329 - Toggling fullscreen mode with F11 broken"

@reporter: why (according to what standards, specifications, RFC, ...) do you consider the complained behavior a bug?
Flags: needinfo?(mnyromyr)
Note that this is a Mac bug (see the platform fields). The WIP I've attached is mac-only.
I'm not seeing this in Mozilla/5.0 (X11; Linux i686; rv:36.0) Gecko/20100101 Firefox/36.0 SeaMonkey/2.33.1 after upgrading from 32-bit Mageia 4.1 to 32-bit Mageia 5.0. I would suggest that the missing decorations or buttons were due to a runtime library bug corrected in the newer Mageia.
PLease note that this is a Mac bug and the problem you see on windows/linux is probably of different origin.
Duplicate of this bug: 1201942
I haven't fixed the fullscreen stuff, it feels like a different beast (a new bug would be nice).

I have only tested this on Yosemite and I notice that our maximize buttons doesn't looks exactly like the ones in Firefox/Safari et al. In lwtheming, the window control ornaments ("x", "-" etc), doesn't paint 100% properly either, but that is the same in Firefox (probably my hardware, since mstange doesn't see it).
Assignee: nobody → stefanh
Attachment #8577772 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Flags: needinfo?(mnyromyr)
Attachment #8660495 - Flags: review?
Comment on attachment 8660495 [details] [diff] [review]
Restore window controls in lwtheming

Oops, the requestee wasn't set... Karsten, se my previous comment.
Attachment #8660495 - Flags: review? → review?(mnyromyr)
Comment on attachment 8660495 [details] [diff] [review]
Restore window controls in lwtheming

(In reply to Stefan [:stefanh] from comment #11)
> I haven't fixed the fullscreen stuff, it feels like a different beast

Fullscreen still being not fully fullscreen, it's probably not that important anyway.

> I have only tested this on Yosemite

10.10.5 here.

> and I notice that our maximize buttons
> doesn't looks exactly like the ones in Firefox/Safari et al. In lwtheming,
> the window control ornaments ("x", "-" etc), doesn't paint 100% properly
> either, but that is the same in Firefox (probably my hardware, since mstange
> doesn't see it).

Current visuals seem to be (x)(-)(/), the patch restores the old(?) (x)(-)(+) set. But I guess that's a different bug as well.
Attachment #8660495 - Flags: review?(mnyromyr) → review+
FWIW, I upgraded to 10.11.1 tonight and now the buttons are correctly drawn as (x)(-)(/).
I removed the fullscreen part in the bug description so nobody thinks that was addressed here.

http://hg.mozilla.org/comm-central/rev/00227c828c07
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Summary: Window decorations (close, minimize, and maximize buttons) are missing with lwtheming and fullscreen → Window decorations (close, minimize, and maximize buttons) are missing with lwtheming
Target Milestone: --- → seamonkey2.41
Target Milestone: seamonkey2.41 → seamonkey2.42
They still haven't fixed the problem with the red, green and orange buttons not appearing with picture backgrounds either. Firefox allows it, and I don't understand why Seamonkey 2.38 for Mac Still doesn't. I reported this several weeks ago, and two seamonkey revisions have come out since after a very long hiatus.Only the default background shows these buttons.
(In reply to Robert from comment #16)
> They still haven't fixed the problem with the red, green and orange buttons
> not appearing with picture backgrounds either. Firefox allows it, and I
> don't understand why Seamonkey 2.38 for Mac Still doesn't.

If you by picture background mean a theme that applies a background-image to the whole toolbar (including the title bar), it was fixed today (it's what this bug was about) so it'll be in 2.42.
(In reply to Stefan [:stefanh] from comment #17)
> (In reply to Robert from comment #16)
> > They still haven't fixed the problem with the red, green and orange buttons
> > not appearing with picture backgrounds either. Firefox allows it, and I
> > don't understand why Seamonkey 2.38 for Mac Still doesn't.
> 
> If you by picture background mean a theme that applies a background-image to
> the whole toolbar (including the title bar), it was fixed today (it's what
> this bug was about) so it'll be in 2.42.

Thanks for the info. I'll be on the lookout for 2.42
You need to log in before you can comment on or make changes to this bug.