[Status Bar][Nexus 5] Roaming icon is displayed on Statusbar instead of Cellular signal icon

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
8 months ago

People

(Reporter: hcheng, Unassigned)

Tracking

unspecified
x86_64
Linux

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: [2.2-nexus-5-l][ft:devices])

Attachments

(3 attachments, 1 obsolete attachment)

Created attachment 8571149 [details]
roaming icon

* Cellular signal icon does not display on Nexus5, but roaming icon does when no roaming.

* Env info
Build ID               20150301162504
Gaia Revision          77609916ca5ab721150fab2b7bc5c37f43ee3a5a
Gaia Date              2015-02-27 16:35:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/27ab8aa34201
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150301.195523
Firmware Date          Sun Mar  1 19:55:38 EST 2015
Bootloader             HHZ12d
blocking-b2g: --- → 2.2?
Hi Alive, could you take a look?
Flags: needinfo?(alive)
Whiteboard: [systemsfe]
Duplicate of this bug: 1138861
Is this reproduced on flame?
Flags: needinfo?(alive)
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #3)
> Is this reproduced on flame?

No, Nexus-5 only issue.

Comment 5

4 years ago
Hi! Evelyn,

Could your team help on this case? Thanks

--
Keven
Flags: needinfo?(ehung)

Comment 6

4 years ago
Sean, could you take a look? Thanks!
Flags: needinfo?(ehung) → needinfo?(selee)
Whiteboard: [systemsfe]
Whiteboard: [2.2-nexus-5-l]
Whiteboard: [2.2-nexus-5-l] → [2.2-nexus-5-l][ft:devices]
Hi Evelyn, I will take a look this issue. Thanks.
Flags: needinfo?(selee)
Created attachment 8574549 [details]
Nexus5

Hi Hermes,

This issue can not reproduce in the following build. Could you help to try to update the image again? Thank you.

Gaia-Rev        77609916ca5ab721150fab2b7bc5c37f43ee3a5a
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e9d29a3b94e5
Build-ID        20150305162505
Version         37.0
Device-Name     hammerhead
FW-Release      5.0
FW-Incremental  eng.cltbld.20150305.201911
FW-Date         Thu Mar  5 20:19:27 EST 2015
Bootloader      HHZ12d
Flags: needinfo?(hcheng)
Created attachment 8575026 [details]
screenshot (build id = 20150309162503)

I use pvt engineer build as below, and this issue still exists.

* Env info
Build ID               20150309162503
Gaia Revision          166491b92278dc9e648f8d49ab02d9ca00d74421
Gaia Date              2015-03-06 18:26:27
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9ae4bcc9b5f2
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150309.195940
Firmware Date          Mon Mar  9 19:59:53 EDT 2015
Bootloader             HHZ12d
Flags: needinfo?(hcheng)
Created attachment 8575029 [details]
screenshot (build id = 20150309162503)

update the screenshot
Attachment #8575026 - Attachment is obsolete: true
Hi Evelyn,

This issue is caused by DPPX.
After flashing the same build with Hermes's, Gaia DPPX is @2.25.
( apps/system/style/statusbar/images/icons@2.25x.png )

If Gaia is built with other DPPX, the icon looks good.
EX: GAIA_DPPX=1.5 make
Flags: needinfo?(ehung)
Flags: needinfo?(ehung)
In addition, I found DPPX=2 provides better image quality and correctness.
Flags: needinfo?(ehung)
I am not certain we need to block on this as N-5 is not the final shipping device and it looks like this is a one time build related change per comment #11 ? Please correct me if I misunderstood.
blocking-b2g: 2.2? → -

Comment 14

4 years ago
I think this is a polish issue, not 2.2 blocker.

--
Keven

Updated

4 years ago
Flags: needinfo?(ehung)

Comment 15

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.