[v2.2][Clock] After running test_clock_create_new_alarm.py, it should set the alarm time to 1 min more than the current time

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: cynthiatang, Assigned: ashiue)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master unaffected)

Details

(URL)

Attachments

(2 attachments, 2 obsolete attachments)

2.72 MB, text/html
Details
46 bytes, text/x-github-pull-request
martijn.martijn
: review+
Details | Review | Splinter Review
(Reporter)

Description

4 years ago
Created attachment 8571161 [details]
Smoketest report

[Description]
test_clock_create_new_alarm.py fails

[Steps to Reproduce]
Run the test_clock_create_new_alarm.py 

[Expected Results]
1. Set the alarm time to 1 min more than the current time.  
2. The new alarm will be triggered in 1 minutes

*** Actual Results
Set the alarm time to 10 mins more than the current time.

*** Reproduction Frequency
100% 5/5

Traceback (most recent call last):
  File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.8.6-py2.7.egg/marionette/marionette_test.py", line 268, in run
    testMethod()
  File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.smoketest/tests/python/gaia-ui-tests/gaiatest/tests/functional/clock/test_clock_create_new_alarm.py", line 92, in test_clock_create_new_alarm
    self.alarm_alert.wait_for_alarm_to_trigger()
  File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.smoketest/tests/python/gaia-ui-tests/gaiatest/apps/clock/regions/alarm_alert.py", line 19, in wait_for_alarm_to_trigger
    expected.element_present(*self._alarm_frame_locator))
  File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.8.6-py2.7.egg/marionette/wait.py", line 143, in until
    cause=last_exc)
TimeoutException: TimeoutException: Timed out after 60.3 seconds

[Build info]
Device firmware (base) L1TC100118D0 
Device firmware (date) 01 Mar 2015 17:00:53 
Device firmware (incremental) eng.cltbld.20150301.040042 
Device firmware (release) 4.4.2 
Device identifier flame 
Gaia date 28 Feb 2015 00:35:06 
Gaia revision 77609916ca5a 
Gecko build 20150301002505 
Gecko revision 27ab8aa34201 
Gecko version 37.0 

[Attachments]
Smoketest report
(Reporter)

Updated

4 years ago
Summary: [Clock] The script should set the alarm time to 1 min more than the current time → [Clock] After running test_clock_create_new_alarm.py, it should set the alarm time to 1 min more than the current time
Per the smoketest report (attachment 8571161 [details])
status-b2g-v2.2: --- → affected
This issues is not reproducible (0/3) on master with a device at [1] and the test at revision 1e2f3de0a8080f78d95029dd921206555aabb99e

[1] Build ID               20150301160222
Gaia Revision          f34ce82a840ad3c0aed3bfff18517b3f6a0eb37f
Gaia Date              2015-02-27 15:48:31
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/eea6188b9b05
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150301.193134
Firmware Date          Sun Mar  1 19:31:45 EST 2015
Bootloader             L1TC000118D0
status-b2g-master: --- → unaffected
Hi Edward, Could you also investigate the cause of this, thank you.
Flags: needinfo?(edchen)
This looks similar to bug 1128952. I guess that bug hasn't landed on v2.2 yet, the v2.2 test_clock_create_new_alarm.py looks quite different from trunk.

Comment 5

3 years ago
I will figure out it on v2.2
Flags: needinfo?(edchen)
Flags: needinfo?(ashiue)
Created attachment 8589445 [details] [review]
[gaia] alison-shiue:bug1138278 > mozilla-b2g:v2.2
(Assignee)

Comment 7

3 years ago
Hi Johan, could you please review this patch. Thanks!
Flags: needinfo?(ashiue) → needinfo?(jlorenzo)
Comment on attachment 8589445 [details] [review]
[gaia] alison-shiue:bug1138278 > mozilla-b2g:v2.2

The patch looks mostly good to me. One big issue I have though: it's really intermittent on my device (it passed 4/10 times). This ratio is too low to accept the merge.

I think one way to solve it is to make the changes in the test as done here: https://github.com/mozilla-b2g/gaia/commit/59f71e42d4137f194ca50709497f6e3706dad10a#diff-95439f0aec21bc9c9f84f44e9a361af9R26

After that, the test doesn't look intermittent anymore (passed 5/5 times).
Flags: needinfo?(jlorenzo)
Attachment #8589445 - Flags: review-
(Assignee)

Comment 9

3 years ago
Created attachment 8590074 [details] [review]
PR 29387

Hi Johan,

I updated the code according to your suggestion. 
I tried run this patch on my device and got all passed result (20/20).
Could you please review again? Thanks!
Attachment #8590074 - Flags: review?(jlorenzo)
Comment on attachment 8590074 [details] [review]
PR 29387

LGTM!
Attachment #8590074 - Flags: review?(martijn.martijn)
Attachment #8590074 - Flags: review?(jlorenzo)
Attachment #8590074 - Flags: review+
This pull request also suffers from the fact that it doesn't have a good Treeherder Try run, just like in bug 1149886 (and another bug, which I don't know the bug number for).
Summary: [Clock] After running test_clock_create_new_alarm.py, it should set the alarm time to 1 min more than the current time → [v2.2][Clock] After running test_clock_create_new_alarm.py, it should set the alarm time to 1 min more than the current time
Assignee: nobody → ashiue
Attachment #8590074 - Flags: review?(martijn.martijn) → review+
Flags: needinfo?(hcheng)
@Alison, please rebase your commit and send the PR again.
Flags: needinfo?(hcheng) → needinfo?(ashiue)
Flags: needinfo?(ashiue) → needinfo?(liuke)
Created attachment 8609242 [details] [review]
[gaia] Lance-k:1138278 > mozilla-b2g:v2.2
Comment on attachment 8609242 [details] [review]
[gaia] Lance-k:1138278 > mozilla-b2g:v2.2

Hi Martijn, could you please review this patch. Thanks!
Flags: needinfo?(liuke)
Attachment #8609242 - Flags: review?(martijn.martijn)
Comment on attachment 8609242 [details] [review]
[gaia] Lance-k:1138278 > mozilla-b2g:v2.2

I've compared it to the trunk patch and it looks the same. Treeherder try is also green.
I assume you've run it yourself succesfully too.
Attachment #8609242 - Flags: review?(martijn.martijn) → review+
(In reply to Martijn Wargers [:mwargers] (QA) from comment #15)
> Comment on attachment 8609242 [details] [review]
> [gaia] Lance-k:1138278 > mozilla-b2g:v2.2
> 
> I've compared it to the trunk patch and it looks the same. Treeherder try is
> also green.
> I assume you've run it yourself succesfully too.

Hi Martijn,

I have run it, and it still passes(20/20).
Martijn, could you help merge the patch?
(In reply to Hermes Cheng[:hermescheng] from comment #17)
> Martijn, could you help merge the patch?

Done: https://github.com/mozilla-b2g/gaia/commit/b4582cc394e0919623263997c0cdb0b4751a1403
Attachment #8589445 - Attachment is obsolete: true
Attachment #8590074 - Attachment is obsolete: true
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.