Tooltip preference does not take effect until Mozilla restart

VERIFIED FIXED in mozilla0.9.9

Status

()

P3
minor
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: lkolesza, Assigned: samir_bugzilla)

Tracking

Trunk
mozilla0.9.9
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.6+) Gecko/20011206
BuildID:    2001120603



Reproducible: Always
Steps to Reproduce:
1. Hover over back button to determine tooltip status
2. Go to Preferences dialog
2. Go to Appearance tab
3. Check or uncheck "Show Tooltips"
4. Press Ok to apply changes
5. Hover over back button

Actual Results:  Tooltip status did not change

Expected Results:  Tooltip status changes to that selected in Preferences dialog

In 0.9.6, I get a popup after hitting ok saying "Prefered languages changes will
take effect when you restart Mozilla", but the Tooltip change takes effect
immediately.  In 2001120603, I don't get any popup.
terri, d'you see this?
Summary: Tooltip preference does not take effect until Mozilla restart → Tooltip preference does not take effect until Mozilla restart

Comment 2

17 years ago
Yes, I do see this with Win ME build 2001120603, if you shut down moz and 
restart, the change in tooltip preferences does take effect
(Assignee)

Comment 3

17 years ago
The pref is being set correctly.  

-> hewitt
Assignee: sgehani → hewitt
Component: Preferences → XP Toolkit/Widgets
QA Contact: sairuh → tpreston
*** Bug 116009 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.9
(Assignee)

Comment 5

17 years ago
*** Bug 116989 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

17 years ago
Created attachment 62798 [details] [diff] [review]
Remove attempt to cast data to self since we |RegisterCallback()| with |nsnull|, not |(void*) this|.
(Assignee)

Comment 7

17 years ago
Created attachment 62799 [details] [diff] [review]
Same patch as above but diff -w for reviewers' benefit.
(Assignee)

Comment 8

17 years ago
morse, please r.
alecf, please sr.
Assignee: hewitt → sgehani
Status: ASSIGNED → NEW
Priority: -- → P3
Target Milestone: mozilla0.9.9 → mozilla0.9.8

Comment 9

17 years ago
Comment on attachment 62799 [details] [diff] [review]
Same patch as above but diff -w for reviewers' benefit.

r=morse
Attachment #62799 - Flags: review+
(Assignee)

Updated

17 years ago
Keywords: patch, review

Comment 10

17 years ago
Comment on attachment 62799 [details] [diff] [review]
Same patch as above but diff -w for reviewers' benefit.

sr=hewitt
Attachment #62799 - Flags: superreview+
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: review
Whiteboard: [ready to checkin]
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9
(Assignee)

Comment 11

17 years ago
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Whiteboard: [ready to checkin]

Comment 12

17 years ago
Verified Fixed Win ME build 2002022808
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.