[Download Manager] "Unable to open" message when closing vcf file preview

VERIFIED FIXED in 2.2 S8 (20mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: noemi, Assigned: aus)

Tracking

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(6 attachments)

(Reporter)

Description

4 years ago
STRs:
1. E-mail with .vcf file is received in FxOS device
2. Click on the received vcard attachment to download the corresponding .vcf file
3. After completing the Download, go to Settings->Downloads
4. Click on the .vcf file, the vcard is opened
5. Close the contact preview by clicking on "x"

Actual Result: Unable to open message appears (see "Unable_To_Open_vcf_file.png" image attached)

Expected Result: the user returns to the downloads list (Settings->Downloads)


Environmental Variables:
Device: Flame Master
Build ID: 20150302073244    
Gaia: cf3b761
Gecko: 75fc721
Platform Version: 39.0a1 (Master)
Firmware Version: v18D
(Reporter)

Updated

4 years ago
Depends on: 825318
See Also: 825318
(Reporter)

Updated

4 years ago
(Reporter)

Comment 1

4 years ago
Hi,

Just adding that closing the preview of a pdf file returns to the downloads list (Settings->Downloads) as expected.

Gregor, could you (or someone familiar with Download Manager implementation) please take a look at this issue?. Your feedback would be much appreciated. Thanks!
Flags: needinfo?(anygregor)
Aus, any idea whats going on here?
Flags: needinfo?(anygregor) → needinfo?(aus)
(Assignee)

Comment 3

4 years ago
Weird, maybe it has a bad content type associated with it and therefor isn't routed to any application. I'll check it out.
Flags: needinfo?(aus)
(Reporter)

Comment 4

4 years ago
Hi,

Bug 825318 has just been approved to be in 2.2 so that branch will be also affected for this issue. Because of this, nominating it to 2.2 and setting blocking-b2g-v2.2 flag as affected.
blocking-b2g: --- → 2.2?
Is this a regression?
Keywords: qawanted
QA Contact: ychung
(Reporter)

Comment 6

4 years ago
(In reply to Gregor Wagner [:gwagner] from comment #5)
> Is this a regression?

Hi,

This bug raised once Bug 825318 landed, before that, vcf files downloaded via E-mail app were not accessible (handled) via DM.
I was able to reproduce this issue on Flame Master, but as it's mentioned on Comment 6, vcf files cannot be downloaded via email on Flame 2.1 as bug 825318 is still affected on 2.1. Therefore, this bug is NOT a regression.

Environmental Variables:
Device: Flame 2.1
Build ID: 20150309232119
Gaia: 9f2f64bbc9f29edb36f8cbf57d4e0c3f4dee3124
Gecko: c78eec29e8c1
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Contact: ychung
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Assignee)

Updated

4 years ago
Blocks: 1141798
(Reporter)

Updated

4 years ago
See Also: → 1142185
This issue should get the 2.2+ flag. It could be a certification blocker.
(Assignee)

Comment 9

4 years ago
I tried this with latest mozilla-central + master build today and this works fine. This was originally reported against master as well and not the 2.2 specific branch (mozilla-b2g37_v2.2). I'm going to mark this WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Keywords: verifyme
(Assignee)

Comment 10

4 years ago
Assigning to myself in case this gets reopened.
Assignee: nobody → aus
Posted file vcard.vcf
I was able to reproduce this issue on the latest Flame Master and 2.2. Attached file is the vcf file I tested with.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150312040625
Gaia: 228f77fd32e5df0285b2e6ee6bd7a853c00e5b45
Gecko: 0190a1d17294
Version: 39.0a1 (3.0) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150312122853
Gaia: 572d60e0a440ee4af50bc6b6adad8876eadbdb4d
Gecko: b9c4d7f2994b
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Keywords: verifyme
Status: RESOLVED → REOPENED
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Resolution: WORKSFORME → ---

Comment 12

4 years ago
There is a message of "Not enabled yet" when opening vcf file and an "Unable to open" message when closing preview. 

Details on bug 825318.
Error message
https://bugzilla.mozilla.org/attachment.cgi?id=8577144

VCF file 
https://bugzilla.mozilla.org/attachment.cgi?id=8577149

Environmental Variables:
Gaia-Rev        572d60e0a440ee4af50bc6b6adad8876eadbdb4d
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3db27b3c9298
Build-ID        20150312162502
Version         37.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150312.200118
FW-Date         Thu Mar 12 20:01:31 EDT 2015
Bootloader      L1TC000118D0
(Reporter)

Comment 13

4 years ago
(In reply to Teri Wen [:twen] from comment #12)
> There is a message of "Not enabled yet" when opening vcf file and an "Unable
> to open" message when closing preview. 
> 
> Details on bug 825318.
> Error message
> https://bugzilla.mozilla.org/attachment.cgi?id=8577144
> 
> VCF file 
> https://bugzilla.mozilla.org/attachment.cgi?id=8577149
> 
> Environmental Variables:
> Gaia-Rev        572d60e0a440ee4af50bc6b6adad8876eadbdb4d
> Gecko-Rev      
> https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3db27b3c9298
> Build-ID        20150312162502
> Version         37.0
> Device-Name     flame
> FW-Release      4.4.2
> FW-Incremental  eng.cltbld.20150312.200118
> FW-Date         Thu Mar 12 20:01:31 EDT 2015
> Bootloader      L1TC000118D0

Hi Teri,

"not enable yet" message appears in case of vcard with multiple contacts due to Bug 849729 which implements that support has not been uplifted to 2.2 branch (the same as commented in https://bugzilla.mozilla.org/show_bug.cgi?id=825318#c146). This bug is focused on avoiding "unable to open" message when closing contact preview. Thanks!
(Assignee)

Comment 14

4 years ago
Could we please re-verify with a vcard that has only one contact please? As noted by Noemi it's not expected that multi-contact vcards will work in 2.2. I am tentatively settings this back to WFM.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Keywords: verifyme
Resolution: --- → WORKSFORME
(Reporter)

Comment 15

4 years ago
(In reply to Ghislain Aus Lacroix [:aus] from comment #14)
> Could we please re-verify with a vcard that has only one contact please? As
> noted by Noemi it's not expected that multi-contact vcards will work in 2.2.
> I am tentatively settings this back to WFM.

Hi,

This issue was detected while checking single contact vcard scenario. 
STRs:
1. E-mail with .vcf file (including only a contact) is received in FxOS device
2. Click on the received vcard attachment to download the corresponding .vcf file
3. After completing the Download, go to Settings->Downloads
4. Click on the .vcf entry within the list, contacts app is opened showing all the contact details, as expected
5. Close the contact preview by clicking on "x"

Actual Result: Unable to open message appears (see "Unable_To_Open_vcf_file.png" image attached)

Expected Result: the user returns to the downloads list (Settings->Downloads)

In comment 13 I was just referring to "not enable yet" message when talking about multi-contact scenario not supported, that message appears when trying to open a multi-contact vcard. Notice that "unable to open" message appears when closing the contact view.
I've just checked with today's (3/13) master build and still reproducible. Environmental variables:
Flame master
Gecko: ee67ad0
Gaia: 891a722
Build Id: 20150313083510
Platform version: 39.0a1

because of this, reopening it again. I attach "Test Case.vcf" file used for testing.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 17

4 years ago
Single contact scenario also tested on today's (3/13) v2.2 build with the same results explained in comment 15, "unable to open" message appears when closing the contact view. Environmental variables:
2.2 Flame device
Build Id: 20150313061811
Gecko: 2063fab
Gaia: 4aefc3f
Platform version: 37.0
Keywords: verifyme
(In reply to Ghislain Aus Lacroix [:aus] from comment #9)
> I tried this with latest mozilla-central + master build today and this works
> fine. This was originally reported against master as well and not the 2.2
> specific branch (mozilla-b2g37_v2.2). I'm going to mark this WORKSFORME.

Looks like it happens on a single contact and is a cert blocker, so blocking on this.
blocking-b2g: 2.2? → 2.2+
(Assignee)

Comment 20

4 years ago
Attachment #8578867 - Flags: review?(bugmail)
Attachment #8578867 - Flags: review?(bugmail) → review+
(Assignee)

Comment 21

4 years ago
Comment on attachment 8578867 [details] [review]
Pull Request - Handle canceled activities.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):Pre-existing condition
[User impact] if declined: Error message as reported in bug report.
[Testing completed]: On device, flame kk central, aurora, gaia master, v2.2.
[Risk to taking this patch] (and alternatives if risky): Low, isolated fix.
[String changes made]: None.
Attachment #8578867 - Flags: approval-gaia-v2.2?
(Assignee)

Comment 22

4 years ago
Commit (master): https://github.com/mozilla-b2g/gaia/commit/2a1ffb7e6bfab392cfdd450b334a2f7b1bb5b980

Fixed.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Attachment #8578867 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Duplicate of this bug: 1142185
Target Milestone: --- → 2.2 S8 (20mar)
(Assignee)

Updated

4 years ago
Keywords: verifyme
This problem is verified pass on latest build of Flame 3.0. I also verified the single contact scenario (with the vcf attachment in comment 16) and the multi-contact scenario, after tapping “x” icon, device will go back to Settings->Downloads view.
See attachment: Flame3.0_verify_video.MP4
Rate: 0/10

Flame 3.0 build: (Pass)
Build ID               20150319160212
Gaia Revision          c39e15f631de80c69467fda0d4ea0bcda9e194ca
Gaia Date              2015-03-18 19:30:04
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cbd0efcd976c
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150319.193329
Firmware Date          Thu Mar 19 19:33:42 EDT 2015
Bootloader             L1TC000118D0

Leaving verifyme for 2.2 build reached.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Tested with Flame v2.2( Gecko-c768752.Gaia-c8136ef), from Settings ->Downloads, the vcard files are properly open. I cannot see again the:"unable to open" message.
Thanks a lot for fixing this bug.
Per comment 26 and I also verified pass with single contact vcf file on latest build of Flame 2.2. So I clear verifyme keyword.

Device: Flame 2.2 build (pass)
Build ID               20150323162503
Gaia Revision          e54c4ed1cc188f70ddf1156534d364005dc45490
Gaia Date              2015-03-23 19:09:26
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/7ba1778d237b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150323.200543
Firmware Date          Mon Mar 23 20:05:54 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.