Search bar forgets non-default engine selection on search

RESOLVED DUPLICATE of bug 1109851

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 1109851
3 years ago
3 years ago

People

(Reporter: Bruno Prémont, Unassigned)

Tracking

36 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150301125210

Steps to reproduce:

I entered a search term and did choose a search engine from the search bar popup that is not the default engine.

Later while not having changed the text in the search bar I click "search" (or hit enter).


Actual results:

Firefox is using the default search engine for the second search.


Expected results:

Firefox should be using the previously used search engine to perform the repeated search.


In older Firefox releases (prior to search bar menu redesign) it was possible to select a search engine from the drop-down menu to select the active search engine an then perform all changes using that engine by just hitting enter in the search bar.
Firefox then also displayed the icon of the active search engine in the search bar which is no more the case.
(Reporter)

Updated

3 years ago
Component: Untriaged → Search
This intentional behavior - designed specifically to allow performing "one-off" searches that don't change your default search engine. You can achieve similar behavior as the previous UI by using Ctrl/Cmd+Up/Down to select a new default engine from within the search popup.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

3 years ago
> This intentional behavior - designed specifically to allow performing
> "one-off" searches that don't change your default search engine.

Ok for that part.

> You can achieve similar behavior as the previous UI by using Ctrl/Cmd+Up/Down to
> select a new default engine from within the search popup.

This is not really intuitive and has a few glitches (might need to be split into distinct bugs):

- using Ctrl/Cmd+UP/Down iterates through all search engines installed, not only those displayed
- selection on one firefox window should not affect other windows, so not affect global default but just local default
- selection should be limited to the searchbox for which it was done and thus only apply there for the lifetime of that searchbox (be it linked to window or tab remains to be debated in other bugs)
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(In reply to Bruno Prémont from comment #2)
> - using Ctrl/Cmd+UP/Down iterates through all search engines installed, not
> only those displayed

Also intentional: see bug 1110678 comment 2.

> - selection on one firefox window should not affect other windows, so not
> affect global default but just local default
> - selection should be limited to the searchbox for which it was done and
> thus only apply there for the lifetime of that searchbox (be it linked to
> window or tab remains to be debated in other bugs)

This is a request for different behavior than we've ever had (the old UI was not better here).

It sounds like what you're after is bug 1109851.
(Reporter)

Comment 4

3 years ago
(In reply to :Gavin Sharp [email: gavin@gavinsharp.com] from comment #3)
> (In reply to Bruno Prémont from comment #2)
> > - using Ctrl/Cmd+UP/Down iterates through all search engines installed, not
> > only those displayed
> 
> Also intentional: see bug 1110678 comment 2.

Ok, with the inconvenience that it's hard to tell where in the list of search engines one is at while iterating when also iterating through hidden engines.

Having the two modes suggested in bug 1109851 (CTRL+Up/Down for global default, SHIFT+Up/Down for local default) would be a win.

> > - selection on one firefox window should not affect other windows, so not
> > affect global default but just local default
> > - selection should be limited to the searchbox for which it was done and
> > thus only apply there for the lifetime of that searchbox (be it linked to
> > window or tab remains to be debated in other bugs)
> 
> This is a request for different behavior than we've ever had (the old UI was
> not better here).
> 
> It sounds like what you're after is bug 1109851.

There is quite some overlapping with the aim of bug 1109851.

I also like the more visual presentation of current and default search engines as proposed in attachment 8535274 [details] (it's more explicit than presentation in FF36 except for displaying the default/current search engine's name).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1109851
You need to log in before you can comment on or make changes to this bug.