Closed Bug 1138468 Opened 5 years ago Closed 3 years ago

Intermittent Android 4.0 debug mochitest-5 "No tests run or test summary not found" due to a crash during test_audioBufferSourceNodeNeutered.html

Categories

(Core :: Web Audio, defect)

ARM
Android
defect
Not set
35

Tracking

()

RESOLVED INCOMPLETE
Tracking Status
firefox38 --- disabled
firefox39 --- disabled

People

(Reporter: RyanVM, Unassigned)

References

Details

(Keywords: crash, Whiteboard: [test disabled on android debug])

Attachments

(1 file)

Attached file logcat output
These have been going on for at least a week or so now, per the stars in bug 689856. Looking at the full log, it appears we're crashing mid-run in a way that the harness isn't able to catch properly.

17:53:39     INFO -  1606 INFO TEST-START | dom/media/webaudio/test/test_audioBufferSourceNodeNeutered.html
17:53:39     INFO -  INFO | automation.py | Application ran for: 0:33:14.650661
17:53:39     INFO -  INFO | zombiecheck | Reading PID log: /tmp/tmpn7lU7rpidlog
17:53:40     INFO -  Contents of /data/anr/traces.txt:
17:53:40     INFO -  /data/tombstones does not exist; tombstone check skipped
17:53:41     INFO -  Stopping web server
17:53:41     INFO -  Stopping web socket server
17:53:41     INFO -  Stopping ssltunnel
17:53:41     INFO -  WARNING | leakcheck | refcount logging is off, so leaks can't be detected!
17:53:41     INFO -  runtests.py | Running tests: end.

17:53:46     INFO -  1607 INFO TEST-PASS | dom/media/webaudio/test/test_audioBufferSourceNodeNeutered.html | Correct number of channels for expected buffer 0
17:53:46     INFO -  1608 INFO TEST-PASS | dom/media/webaudio/test/test_audioBufferSourceNodeNeutered.html | maxDifference: 0, first bad index: -1 with test-data offset 0 and expected-data offset 0; corresponding values undefined and undefined --- differences
17:53:46     INFO -  1609 INFO TEST-PASS | dom/media/webaudio/test/test_audioBufferSourceNodeNeutered.html | Correct number of channels for expected buffer 0
17:53:46     INFO -  1610 INFO TEST-PASS | dom/media/webaudio/test/test_audioBufferSourceNodeNeutered.html | Correct number of input buffer channels
17:53:46     INFO -  1611 INFO TEST-PASS | dom/media/webaudio/test/test_audioBufferSourceNodeNeutered.html | maxDifference: 0, first bad index: -1 with test-data offset 0 and expected-data offset 0; corresponding values undefined and undefined --- differences
17:53:46     INFO -  1612 INFO TEST-PASS | dom/media/webaudio/test/test_audioBufferSourceNodeNeutered.html | Correct number of channels for expected buffer 0
See Also: → 1127845
Try run with test_audioBufferSourceNodeNeutered.html skipped: https://treeherder.mozilla.org/#/jobs?repo=try&revision=1cb1747029fb

The first retry is a "No tests run or test summary not found" failure and might be related.
(In reply to Geoff Brown [:gbrown] from comment #14)
> Try run with test_audioBufferSourceNodeNeutered.html skipped:
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=1cb1747029fb
> 
> The first retry is a "No tests run or test summary not found" failure and
> might be related.

Even so, the job failure rate without test_audioBufferSourceNodeNeutered.html is much better than with it. 

Any objections to skipping this test on Android Debug?
Disabled on Android Debug:

https://hg.mozilla.org/integration/mozilla-inbound/rev/34abac57a60d
Keywords: leave-open
Whiteboard: [test disabled on android debug]
Comment 152 - Comment 159 are different issues; none of them are related to test_audioBufferSourceNodeNeutered or even Debug mochitest-5. They seem to be reported here because they contain "No tests run or test summary not found."
Priority: -- → P3
Rank: 35
Android 4.0 is no longer supported.
Status: NEW → RESOLVED
Closed: 3 years ago
Priority: P3 → --
Resolution: --- → INCOMPLETE
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.