Closed Bug 1138576 Opened 5 years ago Closed 1 year ago

Intermittent browser_wa_reset-01.js | A promise chain failed to handle a rejection: - at resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/protocol.js:1115 - Error: Connection closed, pending request to conn30.chi

Categories

(DevTools Graveyard :: Web Audio Editor, defect, P3)

x86
Linux
defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: RyanVM, Unassigned)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Attached file test log
Possible regression from bug 1128027? See the attached log and comment 1 for more details.
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #0)
> Created attachment 8571480 [details]
> test log
> 
> Possible regression from bug 1128027? See the attached log and comment 1 for
> more details.

Looks like it.  Jordan, can you take a look at this?  It may be similar to the fixes Ryan did (and you reviewed) in https://reviewboard.mozilla.org/r/4301.
Blocks: 1128027
Flags: needinfo?(jsantell)
Yeah this looks like the same issue. I'll grab it
Assignee: nobody → jsantell
Status: NEW → ASSIGNED
Flags: needinfo?(jsantell)
It's possible that any tests that previously had:

thisTestLeaksUncaughtRejectionsAndShouldBeFixed("Error: Connection closed");

we are forced to now fix for real because the error no longer contains a consistent message that can be whitelisted like it was previously.

For Web Audio, this means:

browser/devtools/webaudioeditor/test/browser_wa_first-run.js
browser/devtools/webaudioeditor/test/browser_wa_reset-01.js
browser/devtools/webaudioeditor/test/browser_wa_reset-04.js
The fix in bug 1141261 should fix the reset-01 error (as the change caused it to trigger consistently). I'll check out the others
Either way, you should be able to remove the

thisTestLeaksUncaughtRejectionsAndShouldBeFixed("Error: Connection closed");

line from all of them, as it does not really serve a purpose anymore, since it can't match on that text.  (Maybe I should have done that...)
Assignee: jsantell → nobody
Status: ASSIGNED → NEW
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
Product: Firefox → DevTools
The code behind DevTools:Web Audio Editor has gone away. Closing this bug as INVALID
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.