[Smart Collection] Title of collection is not translated on Edit collection

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Everything.me
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: YeojinC, Unassigned)

Tracking

({polish})

unspecified
ARM
Gonk (Firefox OS)
polish

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8571531 [details]
logcat_20150302_EditCollection.txt

Description:
The title of smart collections is translated properly on the homescreen. (ex. French, Italian, German, Arabic, Turkish, Korean, Russian, and Dutch). But on the "Edit collection" screen, the English title appear on the input field across all languages.

Repro Steps:
1) Update a Flame to 20150302010223.
2) Go to Settings > Language > Set the device language as French.
3) Press the home button return to the homescreen.
4) Observe "Game" collection is titled "Jeux".
5) Long press any icon to enter edit mode, and tap "Jeux" to enter the Edit collection screen".

Actual:
"Game" appears as the title in the input field.

Expected:
"Jeux" appears as the title in the input field.

Note: 
This issue reproduces in French, Italian, German, Arabic, Turkish, Korean, Russian, and Dutch. The titles are all translated on the homescreen, but not on Edit collection screen.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150302010223
Gaia: f34ce82a840ad3c0aed3bfff18517b3f6a0eb37f
Gecko: eea6188b9b05
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 8/8
See attached: screenshot, logcat
(Reporter)

Comment 1

3 years ago
Created attachment 8571532 [details]
EditScreen.png

This issue also reproduces on Flame 2.2 and 2.1.

Result: The title appears in English on Edit collection screen.

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150302002504
Gaia: 77609916ca5ab721150fab2b7bc5c37f43ee3a5a
Gecko: 27ab8aa34201
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1  (KK, 319mb, full flash)
Build ID: 20150302001220
Gaia: 5d3479fdd438412adee4452720856b6b771fe5cd
Gecko: 9bf4c663241f
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Flags: needinfo?(ktucker)
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Component: Gaia::Homescreen → Gaia::Everything.me
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Naoki, you might want to know this bug.
Flags: needinfo?(nhirata.bugzilla)
Oops.  This is a good catch: 
Code in view has a localization https://github.com/mozilla-b2g/gaia/blob/master/apps/collection/js/view_collection.js#L16
Whereas code in update doesn't seem to:
https://github.com/mozilla-b2g/gaia/blob/master/apps/collection/js/update_collection.js

For l10n/ux I think this might be a blocker.
blocking-b2g: --- → 2.2?
Flags: needinfo?(nhirata.bugzilla)
Not a regression.
blocking-b2g: 2.2? → ---
Keywords: polish
I'll take an initial look at this.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Ok, I took a quick 2 second look. I suppose what happens is that we can't just use the localizedName because then it wouldn't be the "user input" name which we will display and show on an edit action. I suppose one way to fix this is to mark whether or not we've ever saved the collection with a custom name, and if not, show the localized name.

I'm going to unassign this from myself for now as I have much bigger polish bugs I want to fix in 2.2 and this is not blocking. If I get my other polish bugs done I'll try to take another look here.
Assignee: kgrandon → nobody
Status: ASSIGNED → NEW
Mass update: Resolve/Wontfix all existing collections bugs as this feature is now removed.

Please re-open or file a new bug if you feel that this bug still exists in master.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.