Flame: in camera preview mode, volume control changes two different types of volumes

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: njpark, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
STR:
Open camera, and record the video with sound
Tap the preview icon to enter the preview mode.  When the video is not playing, change the volume

Actual:
It changes the notification volume
Expected:
It should change the app volume

Start the video playback, and change the volume during the playback. Notice it is changing the app volume correctly, instead of notification volume

Version Info:
Gaia-Rev        f34ce82a840ad3c0aed3bfff18517b3f6a0eb37f
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/eea6188b9b05
Build-ID        20150302010223
Version         39.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150302.043726
FW-Date         Mon Mar  2 04:37:37 EST 2015
Bootloader      L1TC000118D0

This is also reproducible in 2.2
Gaia-Rev        77609916ca5ab721150fab2b7bc5c37f43ee3a5a
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/27ab8aa34201
Build-ID        20150302002504
Version         37.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150302.042723
FW-Date         Mon Mar  2 04:27:34 EST 2015
Bootloader      L1TC000118D0
(Reporter)

Updated

4 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Dominic: Do you have any suggestions?
Flags: needinfo?(dkuo)

Comment 2

4 years ago
(In reply to Wilson Page [:wilsonpage] (PTO until 16th) from comment #1)
> Dominic: Do you have any suggestions?

Wilson and No-Jun, I think this was probably expected because the default volume we want the user to adjust was the notification(the volume that shutter sound uses), but now the camera app captures the volume keys as hardware shutter, which means the user is unable to adjust the notification volume by pressing the volume keys while the live camera window is active.

And if adjusting the shutter sound volume(notification volume) is no more a feature in camera app, then the volume keys should just mapping to adjust the media volume(the volume the preview mode uses), and simply we can just change the camera's default volume from notification to media.

The patch should just remove the code for calling |mozAudioChannelManager.volumeControlChannel| in camera app because for all the gaia apps, media volume is the default. I will send a patch later cause the code was added by me :)

Jenny/Tif, am I right on the volume description in camera app? thanks~
Flags: needinfo?(tshakespeare)
Flags: needinfo?(jelee)
Flags: needinfo?(dkuo)
Created attachment 8577127 [details] [review]
[gaia] dominickuo:bug-1138682 > mozilla-b2g:master

Updated

4 years ago
Attachment #8577127 - Flags: review?(wilsonpage)
Comment on attachment 8577127 [details] [review]
[gaia] dominickuo:bug-1138682 > mozilla-b2g:master

patch looks good! thanks!!
Flags: needinfo?(tshakespeare)
Attachment #8577127 - Flags: ui-review+
Attachment #8577127 - Flags: review?(jelee)
Comment on attachment 8577127 [details] [review]
[gaia] dominickuo:bug-1138682 > mozilla-b2g:master

whoops - wrong review flag
Attachment #8577127 - Flags: review?(jelee) → ui-review?(jelee)

Comment 6

4 years ago
Makes sense =) Thanks Dominic!

(In reply to Dominic Kuo [:dkuo] from comment #2)

> And if adjusting the shutter sound volume(notification volume) is no more a
> feature in camera app, then the volume keys should just mapping to adjust
> the media volume(the volume the preview mode uses), and simply we can just
> change the camera's default volume from notification to media.
> 
> The patch should just remove the code for calling
> |mozAudioChannelManager.volumeControlChannel| in camera app because for all
> the gaia apps, media volume is the default. I will send a patch later cause
> the code was added by me :)
> 
> Jenny/Tif, am I right on the volume description in camera app? thanks~
Flags: needinfo?(jelee)

Comment 7

4 years ago
Comment on attachment 8577127 [details] [review]
[gaia] dominickuo:bug-1138682 > mozilla-b2g:master

Looks good!!
Attachment #8577127 - Flags: ui-review?(jelee)
Attachment #8577127 - Flags: ui-review+
Attachment #8577127 - Flags: review?(wilsonpage) → review+
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.

Comment 9

4 years ago
Pull request has landed in master: https://github.com/mozilla-b2g/gaia/commit/a8256b632f571b2ed45129213490e14a86e15c7f
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
status-b2g-master: affected → fixed
This bug has been verified as "pass" on latest nightly build of Flame master and Nexus5 master by the STR in comment 0.

Actual results: In camera preview mode, volume control changes one type volume (the media volume) as expected.
See attachment: verified_Flame_master.3gp
Reproduce rate: 0/10


Device: Flame master (Pass)
Build ID               20150721160205
Gaia Revision          84c3bf622e211046d905803b34de5d331761f22d
Gaia Date              2015-07-21 16:28:35
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1875a5584e5f
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150721.194129
Firmware Date          Tue Jul 21 19:41:42 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus5 master (Pass)
Build ID               20150721160205
Gaia Revision          84c3bf622e211046d905803b34de5d331761f22d
Gaia Date              2015-07-21 16:28:35
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1875a5584e5f
Gecko Version          42.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150721.211608
Firmware Date          Tue Jul 21 21:16:23 EDT 2015
Bootloader             HHZ12f
status-b2g-master: fixed → verified
Created attachment 8637063 [details]
verified_Flame_master.3gp
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.