Grant ajones higher socorro access permissions

RESOLVED FIXED

Status

Socorro
General
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: kentuckyfriedtakahe, Assigned: rhelmer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I need to view crash stats that contain the youtube.com URL because that is strongly correlated with media playback issues, especially MSE.

Comment 1

3 years ago
Ni? to lonnen as he usually handles those requests.
Flags: needinfo?(chris.lonnen)
(Assignee)

Comment 2

3 years ago
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #1)
> Ni? to lonnen as he usually handles those requests.

Thanks kairo! I just started handling these for lonnen.
Assignee: nobody → rhelmer
Status: NEW → ASSIGNED
Flags: needinfo?(chris.lonnen)
(Assignee)

Comment 3

3 years ago
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #0)
> I need to view crash stats that contain the youtube.com URL because that is
> strongly correlated with media playback issues, especially MSE.

Personally identifiable info in the crash (such as the URL) as well as the minidumps themselves are currently granted by the same permission, so I need you and your manager to ack the following here in this bug:

First -- I need jet's ack (:needinfo'd) that you need access to this for your job.

Second -- I need you (ajones) to ack and agree to the following:

* Crash dumps contain memory contents, and may contain private user data.

* Only access dumps as necessary.

* Keep them securely on Mozilla hardware.

* When finished with a dump, delete it (within 30 days)

* Do not share personal data from the dump publicly (on bugzilla, irc, etc)

* Do not share personal data with non-employees, including partner organizations, without consultation and explicit permission from Lonnen (lonnen@mozilla.com). A signed NDA and other arrangements will be required of the other organization.

* It is fine to share stack traces, analysis, and other non-personal data

* Access is conditional on employment and will be revoked upon departure from Mozilla
Flags: needinfo?(bugs)
Flags: needinfo?(ajones)

Comment 4

3 years ago
(In reply to Robert Helmer [:rhelmer] from comment #3)
> (In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #0)
> > I need to view crash stats that contain the youtube.com URL because that is
> > strongly correlated with media playback issues, especially MSE.
>
> First -- I need jet's ack (:needinfo'd) that you need access to this for your job.
> 

ack. Yes, we need a way to see crashes that occur on youtube as we develop the MSE features. This is especially important over the next 90 days as we test exclusively on targeted web sites.
Flags: needinfo?(bugs)
(In reply to Robert Helmer [:rhelmer] from comment #3)
> Second -- I need you (ajones) to ack and agree to the following:
> 
> * Crash dumps contain memory contents, and may contain private user data.
> 
> * Only access dumps as necessary.
> 
> * Keep them securely on Mozilla hardware.
> 
> * When finished with a dump, delete it (within 30 days)
> 
> * Do not share personal data from the dump publicly (on bugzilla, irc, etc)
> 
> * Do not share personal data with non-employees, including partner
> organizations, without consultation and explicit permission from Lonnen
> (lonnen@mozilla.com). A signed NDA and other arrangements will be required
> of the other organization.
> 
> * It is fine to share stack traces, analysis, and other non-personal data
> 
> * Access is conditional on employment and will be revoked upon departure
> from Mozilla

ack. I agree to adhere to the above policies.
Flags: needinfo?(ajones)
(Assignee)

Comment 6

3 years ago
Thanks!

Granted access to ajones@mozilla.com and confirmed that it's working.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.