Bare HTML short link on SUMO

RESOLVED FIXED in 2015Q1

Status

support.mozilla.org
Knowledge Base Software
P1
normal
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: luke@faraone.cc, Assigned: rrosario)

Tracking

unspecified
2015Q1

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=users c=wiki p=1 s=2015.3)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.35 Safari/537.36

Steps to reproduce:

1) Visit https://support.mozilla.org/en-US/kb/which-browsers-will-work-firefox-hello-video-chat
2) Scroll to the bottom, see "Share this article text"


Actual results:

mzl.la link appears HTML-escaped, as "<a href="http://mzl.la/1tDO7wj">http://mzl.la/1tDO7wj</a>"


Expected results:

A hyperlink should appear.
(Reporter)

Comment 1

3 years ago
Created attachment 8571727 [details]
Screenshot of issue
(Reporter)

Comment 2

3 years ago
This appears on every SUMO page I've viewed, but for context the original URI was https://support.mozilla.org/en-US/kb/which-browsers-will-work-firefox-hello-video-chat
Thanks for the bug report! We saw this earlier today, and just haven't deployed the fix yet.

This has been fixed in this PR: https://github.com/mozilla/kitsune/pull/2399. I just pushed that change out to production, so the problem should go away shortly.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

3 years ago
This is fixed.
https://github.com/mozilla/kitsune/commit/ccd86c4637846bef68dd0ae68e26678ec946c927
Assignee: nobody → rrosario
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Priority: -- → P1
Resolution: --- → FIXED
Whiteboard: u=users c=wiki p=1 s=2015.3
Target Milestone: --- → 2015Q1

Updated

3 years ago
See Also: → bug 1141436

Updated

2 years ago
See Also: → bug 1215168
You need to log in before you can comment on or make changes to this bug.