test_marketplace_packaged_app.py can't locate the search box

RESOLVED WONTFIX

Status

Firefox OS
Gaia
RESOLVED WONTFIX
3 years ago
3 months ago

People

(Reporter: shinglyu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8571797 [details]
smoketest.html

*** Description
test_marketplace_packaged_app.py timed out in `marketplace.search()`


*** Steps to Reproduce
Run test_marketplace_packaged_app.py 

*** Expected Results
The test passes

*** Actual Results
Failed:

Traceback (most recent call last):
File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.8.6-py2.7.egg/marionette/marionette_test.py", line 268, in run
testMethod()
File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.smoketest/tests/python/gaia-ui-tests/gaiatest/tests/functional/marketplace/test_marketplace_packaged_app.py", line 28, in test_search_and_install_app
marketplace.search(self.app_search)
File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.smoketest/tests/python/gaia-ui-tests/gaiatest/apps/marketplace/app.py", line 46, in search
Wait(self.marionette).until(expected.element_displayed(search_box))
File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.8.6-py2.7.egg/marionette/wait.py", line 143, in until
cause=last_exc)
TimeoutException: TimeoutException: Timed out after 30.0 second


*** Other Notes
Can't reproduce manually. It seems like the search_box selector timed out sometimes.

*** Reproduction Frequency
3/5

*** Build
Device firmware (base) 	L1TC100118D0
Device firmware (date) 	02 Mar 2015 17:27:34
Device firmware (incremental) 	eng.cltbld.20150302.042723
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	28 Feb 2015 00:35:06
Gaia revision 	77609916ca5a
Gecko build 	20150302002504
Gecko revision 	27ab8aa34201
Gecko version 	37.0
I think this was fixed on trunk by bug 1136791.
Depends on: 1136791

Comment 2

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.