[Nexus 5][Settings]The PIN code screen can't pop up after you turn off the airplane mode.

VERIFIED FIXED

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: liuke, Assigned: viralwang)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(6 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[Nexus 5][Settings]After you turn off the airplane mode, the PIN code page can't pop up.
Found time:16:52
See attachment:1652.mp4 and logcat_1652.txt

[2.Testing Steps]: 
1.Insert CU/CMCC card into device.
2.Turn on device.
3.Launch Settings, turn on the SIM PIN code.
4.Turn on airplane mode, then turn off it.

Note: The bug does not exist in Flame 2.2.

[3.Expected Result]: 
4.The PIN code screen should pop up immediately.

[4.Actual Result]: 
4.The PIN code screen can't display.

[5.Reproduction build]: 
Build ID               20150302162504
Gaia Revision          062d395273e70b8688a91b5a2b34c0cc7afc679f
Gaia Date              2015-03-02 22:12:55
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5a7cb3b9f78e
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150302.194900
Firmware Date          Mon Mar  2 19:49:17 EST 2015
Bootloader             HHZ12d

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
The bug does not exist in Flame 2.2.
(Reporter)

Comment 1

4 years ago
Posted file logcat_1652.txt
(Reporter)

Comment 2

4 years ago
Posted video 1652.MP4
Nominate this for breaking existing functionality.
But we need to know this is L related or Nexus-5 specific.
blocking-b2g: --- → 2.2?
Keywords: regression
See Also: → 1132397
Whiteboard: [2.2-nexus-5-l]

Comment 4

4 years ago
Should be Gecko passing no event to Gaia. qawanted to check if this happens in Nexus 5 Lollipop v3.0?
Component: Gaia::Settings → RIL
Keywords: qawanted
Posted file logcat_N5v3.0
This problem can be repro on latest build of N5 v3.0.
See attachment: logcat_N5v3.0_0833.txt
Occurrence time: 08:33
Fail rate: 3/3

N5 v3.0 build:
Build ID               20150308160204
Gaia Revision          fea83511df9ccba64259346bc02ebf2c417a12c2
Gaia Date              2015-03-08 06:36:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/eab4a81e4457
Gecko Version          39.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150308.192431
Firmware Date          Sun Mar  8 19:24:47 EDT 2015
Bootloader             HHZ12d
QA Whiteboard: [MGSEI-Triage+]
Keywords: qawanted
Hi all,
According to different h/w modem behaviour, it's not necessarily true that turning on/off airplane mode triggers SIM card state change. That is, it could happen that the pin code screen doesn't pop up after turning off airplane mode. I believe Nexus 5 is one case.

After turning off airplane mode in nexus 5, even without entering sim pin code, I could use telephony features (voice call, sms,...) without problems. So this looks to me a Nexus-5 behaviour issue but not a regression.

I add 'qawanted' again to ask for verifying if any telephony feature is broken due to not entering pin code in this case. If NO, then I believe we could close this bug as invalid. Thanks.
Keywords: regressionqawanted
More information: Per https://bugzilla.mozilla.org/show_bug.cgi?id=1071210#c25  there's a config controlling the behaviour. And Nexus 5 has |persist.radio.apm_sim_not_pwdn| set to 1 that meets the current behaviour.
Looks like a DUP of https://bugzilla.mozilla.org/show_bug.cgi?id=1133465 ? We are waiting for more info on that bug.
Just had an offline talk with Hsin-yi,
1. There might be other cases that need to investigate if we hit that, e.g. SIM manager test cases.. but we can save the time.
2. We are not shipping images for Nexus 5 officially.
3. Changing the persist.radio.apm_sim_not_pwdn settings, so the behavior is the same as Flame is a quick and easy solution for now, although current Nexus behavior seems to be much logical.
4. Note: This is a build time setting.

Suggest to fix, NI Wesley for comment.

(In reply to Hsin-Yi Tsai [:hsinyi] from comment #7)
> More information: Per
> https://bugzilla.mozilla.org/show_bug.cgi?id=1071210#c25  there's a config
> controlling the behaviour. And Nexus 5 has |persist.radio.apm_sim_not_pwdn|
> set to 1 that meets the current behaviour.
Flags: needinfo?(whuang)
triage:
Root cause is that current config for Nexus5 is different from Flame's.
We would like to align the behaviors to smooth QA testing. So this is sort of testing blocker.
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(whuang)
Hi Viral,
As you are the person who fixed bug 1071210, do you mind taking this bug that the solution is the same as that for 1071210? Thank you.
Component: RIL → GonkIntegration
Flags: needinfo?(vwang)
(Assignee)

Comment 12

4 years ago
Hi Hsinyi,

I think it should be good after we set persist.radio.apm_sim_not_pwdn=0
Assignee: nobody → vwang
Flags: needinfo?(vwang)
Attachment #8576509 - Flags: review?(kli)
Attachment #8576509 - Flags: feedback?(htsai)
Comment on attachment 8576509 [details] [review]
set persist.radio.apm_sim_not_pwdn=0

Yup, we verified that setting the property to 0 made SIM Pin dialogue work as expected. Thank you, Viral :D
Attachment #8576509 - Flags: feedback?(htsai) → feedback+
Attachment #8576509 - Flags: review?(kli) → review+
See Also: → 1141973
(Reporter)

Comment 15

4 years ago
After you turn off airplane mode, you must launch Phone/Message/Contacts app or lock screen then unlock, the SIM PIN dialogue will pop up. If you launch other app, the dialogue still can't pop up. So, this question the same with bug 1133465, please see bug 1133465, thanks.
Flags: needinfo?(echang)
(In reply to Lance from comment #15)
> After you turn off airplane mode, you must launch Phone/Message/Contacts app
> or lock screen then unlock, the SIM PIN dialogue will pop up. If you launch
> other app, the dialogue still can't pop up. So, this question the same with
> bug 1133465, please see bug 1133465, thanks.

Please note that this is not the same issue as bug 1133465.

This bug was talking about even we launched phone apps, NO SIM PIN dialogue popped out eventually. However, that didn't affect any telephony features. That is, even without entering SIM PIN, we still could dial out voice calls, etc.
Removing qawanted due to the question has been answered on comment 7 and comment 10.
QA Whiteboard: [MGSEI-Triage+] → [MGSEI-Triage+][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
Lance, can you verify this please?
QA Whiteboard: [MGSEI-Triage+][QAnalyst-Triage?] → [MGSEI-Triage+][QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(liuke)
Keywords: verifyme
Flags: needinfo?(echang)
(Reporter)

Comment 19

4 years ago
Hi KTucker,

Now, after you turn off airplane mode, the device can't recognise the SIM card, you must launch Phone/Message/Contacts app or lock screen then unlock, the SIM PIN dialogue will pop up. If you launch other app, the dialogue still can't pop up.

Steps:
1.Insert CMCC card into device.
2.Turn on device.
3.Launch Settings, turn on the SIM PIN code.
4.Turn on airplane mode, then turn off it.

Expected Result: 
4.The PIN code screen should pop up immediately.

Actual Result: 
4.The PIN code screen can't display, unless you launch Phone/Message/Contacts app or lock screen then unlock.

Fail rate:3/3
See attachment:1435.mp4

Nexus 5_2.2 version:
Build ID               20150315162500
Gaia Revision          a6b2d3f8478ec250beb49950fecbb8a16465ff6f
Gaia Date              2015-03-15 14:33:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/18619f8f6c5c
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150315.195744
Firmware Date          Sun Mar 15 19:57:59 EDT 2015
Bootloader             HHZ12d
Flags: needinfo?(liuke) → needinfo?(ktucker)
(Reporter)

Comment 20

4 years ago
Posted video 1435.MP4
Please see Comment 19. Is this the expected behavior now Eric?
Flags: needinfo?(ktucker) → needinfo?(echang)
AFAIK, this is expeced, but ni UX Jenny for confirmation.
Flags: needinfo?(echang) → needinfo?(jelee)

Comment 23

4 years ago
Hello Eric,

Behavior described in comment 19 is expected. It makes more sense to ask user for PIN only when he's trying to use SIM card required app, asking for PIN right after airplane mode is turned off seems out of context. Thanks!
Flags: needinfo?(jelee)
According to comment 19 & 23, I believe we can close this bug.
Status: RESOLVED → VERIFIED
I think this is as described in #c23
Turn airplane mode ON -> open app (except comms apps) -> no sim pin request -> open comms apps -> sim pin request pops up

But in #c19, we explicitly turn airplane mode off in step 4, we should expect sim pin request every time we do that.
Status: VERIFIED → RESOLVED
Last Resolved: 4 years ago4 years ago

Comment 26

4 years ago
This issue has been verified successfully on Nexus 5_2.2&3.0. The STR is same as Comment 0.It will pop PIN code page autimatically after turnning airplane mode off.
Reproduce rate:0/5
Attachmen:Verify.MP4
Device Nexus 5_2.2 build(Pass)
Build ID               20150419002502
Gaia Revision          c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gaia Date              2015-04-17 17:49:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cc02ee38b252
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150419.041307
Firmware Date          Sun Apr 19 04:13:23 EDT 2015
Bootloader             HHZ12f

Device Nexus 5_3.0 build(Pass)
Build ID               20150419160202
Gaia Revision          c6b04efa0f31a584e6ee0a46dd2b64c1e3c29adc
Gaia Date              2015-04-17 21:10:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a32e3b93c8d8
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150419.193737
Firmware Date          Sun Apr 19 19:37:53 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED

Comment 27

4 years ago
Posted video Verify.MP4

Updated

4 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.