Daily and SM busted due bug 951695

RESOLVED FIXED in Thunderbird 39.0

Status

defect
--
blocker
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

({dogfood, regression})

Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird38 unaffected, thunderbird39 fixed, seamonkey2.35 unaffected, seamonkey2.36 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

4 years ago
Daily's main window is busted due the entity changes in charsetMenu.dtd in bug 951695.
(Assignee)

Updated

4 years ago
Keywords: regression
(Assignee)

Comment 1

4 years ago
Posted patch charsetEncFix.patch (obsolete) — Splinter Review
The attached patch should fix it, but I'm looking in also changing the other strings in /mail with 'Character Encoding' to 'Text Encoding'.
(Assignee)

Comment 2

4 years ago
Posted patch proposed fix (obsolete) — Splinter Review
This fixes TB and should also fix SM. I also changed all 'Character Encoding' to 'Text Encoding' in c-c. But I haven't touched the help files in suite.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8572131 - Flags: review?(neil)
Attachment #8572131 - Flags: review?(mkmelin+mozilla)
(Assignee)

Updated

4 years ago
Attachment #8571985 - Attachment is obsolete: true
Comment on attachment 8572131 [details] [diff] [review]
proposed fix

Review of attachment 8572131 [details] [diff] [review]:
-----------------------------------------------------------------

rs=mkmelin
Attachment #8572131 - Flags: review?(mkmelin+mozilla) → review+
Keywords: dogfood

Updated

4 years ago
Severity: normal → blocker

Comment 4

4 years ago
Thanks for throughly fixing all the occurrences.
Version: unspecified → Trunk

Comment 5

4 years ago
Comment on attachment 8572131 [details] [diff] [review]
proposed fix

I think you might get a faster review from IanN
Attachment #8572131 - Flags: review?(iann_bugzilla)

Comment 6

4 years ago
FYI if you're doing a lot of whitespace changes, please put these in a separate patch, or use diff -w to generate a patch for review. Thanks!

Comment 7

4 years ago
(In reply to Richard Marti (:Paenglab) from comment #2)
> This fixes TB and should also fix SM. I also changed all 'Character Encoding'
> to 'Text Encoding' in c-c. But I haven't touched the help files in suite.

Thanks, I had already opened bug 1139004 to cover suite/ and will retarget it to update Help only.
Blocks: 1139004

Updated

4 years ago
Component: General → Internationalization
Product: Thunderbird → MailNews Core
(Assignee)

Updated

4 years ago
Summary: Daily busted due bug 951695 → Daily and SM busted due bug 951695

Comment 8

4 years ago
Moved to MailNews Core so that we can track it for SeaMonkey.
(uhm, there is a "status-thunderbird_esr39" flag?)
(In reply to Richard Marti from comment #2)
> This fixes TB and should also fix SM. I also changed all 'Character
> Encoding' to 'Text Encoding' in c-c. But I haven't touched the help files in
> suite.
Or the preferences window. (But rsx11m might help out there too.)
(There's also the Page Info change...)
Comment on attachment 8572131 [details] [diff] [review]
proposed fix

Huh, actually you did change the entry in the preferences tree, just not the pane itself, nor the other pane that mentions encoding. Anyway (except for the annoying whitespace changes) the changes that you did make look fine, so r+
Attachment #8572131 - Flags: review?(neil) → review+

Comment 12

4 years ago
Neil, if there is anything else that needs to be done in the prefpanes, I can take care of those in bug 1139004 as needed. No problem, just let me know.
(Assignee)

Comment 13

4 years ago
I have added the missing strings. Please check if the accesskeys are still working. I have no SM build.
Attachment #8572131 - Attachment is obsolete: true
Attachment #8572131 - Flags: review?(iann_bugzilla)
Attachment #8572618 - Flags: review?(neil)
Comment on attachment 8572618 [details] [diff] [review]
proposed fix v2

Thanks, the prefpanes look fine.
Attachment #8572618 - Flags: review?(neil) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Duplicate of this bug: 1139436
Pushed as https://hg.mozilla.org/comm-central/rev/ecc95ada09d1
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 39.0

Updated

4 years ago
Blocks: 1140204
You need to log in before you can comment on or make changes to this bug.