Intermittent browser_markupview_events.js,browser_markupview_navigation.js,browser_toolbar_basic.js,browser_toolbar_tooltip.js | A promise chain failed to handle a rejection: - Protocol error (noSuchActor): No such actor for ID ...

RESOLVED FIXED in Firefox 40

Status

defect
RESOLVED FIXED
4 years ago
Last year

People

(Reporter: cbook, Assigned: sjakthol)

Tracking

({intermittent-failure})

unspecified
Firefox 41
x86
Linux
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox39 wontfix, firefox40 fixed, firefox41 fixed, firefox-esr31 unaffected, firefox-esr38 unaffected)

Details

()

Attachments

(1 attachment)

Ubuntu VM 12.04 mozilla-inbound opt test mochitest-e10s-devtools-chrome

https://treeherder.mozilla.org/logviewer.html#?job_id=7140217&repo=mozilla-inbound

04:20:13 INFO - 2493 INFO TEST-UNEXPECTED-FAIL | browser/devtools/markupview/test/browser_markupview_navigation.js | A promise chain failed to handle a rejection: - Protocol error (noSuchActor): No such actor for ID: conn17.child2/highlighter26
04:20:13 INFO - Stack trace:
04:20:13 INFO - JS frame :: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js :: PendingErrors.register :: line 162
04:20:13 INFO - JS frame :: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js :: this.PromiseWalker.completePromise :: line 675
04:20:13 INFO - JS frame :: resource://gre/modules/Task.jsm :: TaskImpl_handleException :: line 448
04:20:13 INFO - JS frame :: resource://gre/modules/Task.jsm :: TaskImpl_run :: line 326
04:20:13 INFO - JS frame :: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js :: Handler.prototype.process :: line 870
04:20:13 INFO - JS frame :: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js :: this.PromiseWalker.walkerLoop :: line 746
04:20:13 INFO - JS frame :: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js :: this.PromiseWalker.scheduleWalkerLoop/< :: line 688
04:20:13 INFO - native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
04:20:15 INFO - 2494 INFO Console message: [JavaScript Error: "couldn't look up addon: fx-devtools" {file: "jar:file:///builds/slave/test/build/application/firefox/browser/omni.ja!/components/nsBrowserGlue.js" line: 585}]
Duplicate of this bug: 1149188
Summary: Intermittent browser_markupview_navigation.js | A promise chain failed to handle a rejection: - Protocol error (noSuchActor): No such actor for ID: conn17.child2/highlighter26 → Intermittent browser_markupview_navigation.js,browser_toolbar_basic.js,browser_toolbar_tooltip.js | A promise chain failed to handle a rejection: - Protocol error (noSuchActor): No such actor for ID ...
Summary: Intermittent browser_markupview_navigation.js,browser_toolbar_basic.js,browser_toolbar_tooltip.js | A promise chain failed to handle a rejection: - Protocol error (noSuchActor): No such actor for ID ... → Intermittent browser_markupview_events.js,browser_markupview_navigation.js,browser_toolbar_basic.js,browser_toolbar_tooltip.js | A promise chain failed to handle a rejection: - Protocol error (noSuchActor): No such actor for ID ...
Mike, this is one of the top oranges we're seeing right now. Is there any chance you could look into this soon or skip the test for the time-being?
Flags: needinfo?(mratcliffe)
This patch should fix browser_markupview_events.js which has been the most frequent lately.

When the test closes the tab, devtools teardown starts from both ends of the connection at the same time. When markup-view is destroyed, it tells the server to hide the highlighter but if the server has already destroyed the highlighter actor the request fails. As markup-view intentionally ignores any response coming from the server [1], the rejection is left uncaught.

Since head.js already contains the code [2] that tears the tools down gracefully, the test(s) might as well use it.

Try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=f033d4ee9c06

[1] https://dxr.mozilla.org/mozilla-central/source/browser/devtools/markupview/markup-view.js#1444
[2] https://dxr.mozilla.org/mozilla-central/source/browser/devtools/markupview/test/head.js#43
Assignee: nobody → sjakthol
Status: NEW → ASSIGNED
Flags: needinfo?(mratcliffe)
Attachment #8625065 - Flags: review?(pbrosset)
Comment on attachment 8625065 [details] [diff] [review]
bug-1138976-markup-view-intermittent.patch

Review of attachment 8625065 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry for the delay Sami, especially for such a small patch.
Thanks for this, looks good.
Attachment #8625065 - Flags: review?(pbrosset) → review+
The patch landed on MC this morning but didn't get marked here.
https://hg.mozilla.org/mozilla-central/rev/a55da7f74011
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.