Trunk crash [@ nsCSSRendering::PaintBackground]

RESOLVED WORKSFORME

Status

()

Core
Layout
--
critical
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: jay, Assigned: Marc Attinasi)

Tracking

({crash, topcrash})

Trunk
x86
All
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

16 years ago
There are quite a few of these crashes with recent MozillaTrunk builds. It looks
like only a few people are crashing, but they are crashing consistantly at the
same URLs.  Here is the latest from Talkback:

nsCSSRendering::PaintBackground   21
		 97226 	 RESO 	 FIXE 	 dbaron@fas.harvard.edu mozilla0.9.4 	 2001-09-28 
BBID range: 69155 - 105855
Min/Max Seconds since last crash: 13 - 46521
Min/Max Runtime: 15628 - 89949
Crash data range: 2001-12-05 to 2001-12-05
Build ID range: 2001120111 to 2001120309
Keyword List : 
Stack Trace: 

	 nsCSSRendering::PaintBackground
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSRendering.cpp  line 2210]
	 nsCSSRendering::PaintOutline
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSRendering.cpp  line 1911]
	 nsImageFrame::DisplayAltFeedback
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsImageFrame.cpp  line 1176]
	 nsImageFrame::TriggerLink
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsImageFrame.cpp  line 1426]
	 nsContainerFrame::ReplaceFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp  line 338]
	 nsContainerFrame::GetFrameForPointUsing
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp  line 295]
	 nsHTMLContainerFrame::ReparentFrameView
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLContainerFrame.cpp  line
329]
	 nsContainerFrame::ReplaceFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp  line 338]
	 nsBlockFrame::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp  line 5606]
	 nsBlockFrame::GetClosestLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp  line 5526]
	 nsContainerFrame::ReplaceFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp  line 338]
	 nsContainerFrame::GetFrameForPointUsing
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp  line 295]
	 nsTableCellFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableCellFrame.cpp  line 925]
	 nsTableRowFrame::ReflowChildren
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowFrame.cpp  line 1088]
	 nsTableRowFrame::ReflowChildren
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowFrame.cpp  line 1047]
	 nsTableRowGroupFrame::CalculateRowHeights
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp 
line 711]
	 nsTableRowGroupFrame::CalculateRowHeights
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp 
line 672]
	 nsContainerFrame::ReplaceFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp  line 338]
	 nsContainerFrame::GetFrameForPointUsing
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp  line 295]
	 nsTableFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp  line 2055]
	 nsContainerFrame::ReplaceFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp  line 338]
	 nsTableOuterFrame::GetInnerOrigin
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp  line 862]
	 nsContainerFrame::ReplaceFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp  line 338]
	 nsBlockFrame::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp  line 5606]
	 nsBlockFrame::GetClosestLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp  line 5526]
	 nsContainerFrame::ReplaceFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp  line 338]
	 nsContainerFrame::GetFrameForPointUsing
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp  line 295]
	 nsTableCellFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableCellFrame.cpp  line 925]
	 nsTableRowFrame::ReflowChildren
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowFrame.cpp  line 1088]
	 nsTableRowFrame::ReflowChildren
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowFrame.cpp  line 1047]
	 nsTableRowGroupFrame::CalculateRowHeights
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp 
line 711]
	 nsTableRowGroupFrame::CalculateRowHeights
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp 
line 672]
	 nsContainerFrame::ReplaceFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp  line 338]
	 nsContainerFrame::GetFrameForPointUsing
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp  line 295]
	 nsTableFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp  line 2055]
	 nsContainerFrame::ReplaceFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp  line 338]
	 nsTableOuterFrame::GetInnerOrigin
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp  line 862]
	 nsContainerFrame::ReplaceFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp  line 338]
	 nsBlockFrame::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp  line 5606]
	 nsBlockFrame::GetClosestLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp  line 5526]
	 nsContainerFrame::ReplaceFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp  line 338]
	 nsBlockFrame::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp  line 5606]
	 nsBlockFrame::GetClosestLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp  line 5526]
	 nsContainerFrame::ReplaceFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp  line 338]
	 nsBlockFrame::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp  line 5606]
	 nsBlockFrame::GetClosestLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp  line 5526]
	 nsContainerFrame::ReplaceFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp  line 338]
	 nsContainerFrame::GetFrameForPointUsing
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp  line 295]
	 nsHTMLContainerFrame::ReparentFrameView
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLContainerFrame.cpp  line
329]
	 CanvasFrame::Paint
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLFrame.cpp  line 471]
	 PresShell::PushCurrentEventInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 5638]
	 nsView::Paint
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp  line 272]
	 nsViewManager::RenderDisplayListElement
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp  line 1231]
	 nsViewManager::RenderViews
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp  line 1155]
	 nsViewManager::Refresh
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp  line 693]
	 nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp  line 1780]
	 nsView::SetZIndex
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp  line 926]
	 nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 849]
	 nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 871]
	 nsWindow::OnPaint
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 4231]
	 nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 3188]
	 nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 1114]
	 USER32.DLL + 0x2e98 (0x77e12e98)
	 USER32.DLL + 0x39a3 (0x77e139a3)
 
 	Source File :
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/style/src/nsCSSRendering.cpp
line : 2210
     (91375)	URL:
http://uptime.netcraft.com/up/graph?mode_u=off&mode_w=on&site=direct.where2getit.com&submit=Examine
(91356)
URL:
http://uptime.netcraft.com/up/graph?mode_u=off&mode_w=on&site=direct.where2getit.com&submit=Examine
(91336)
URL:
http://uptime.netcraft.com/up/graph?mode_u=off&mode_w=on&site=direct.where2getit.com&submit=Examine
(91334)
URL:
http://uptime.netcraft.com/up/graph?mode_u=off&mode_w=on&site=direct.where2getit.com&submit=Examine
(91331)
URL:
http://uptime.netcraft.com/up/graph?mode_u=off&mode_w=on&site=direct.where2getit.com&submit=Examine
(80570)
URL: http://radio-canada.ca/nouvelles
(78679)
URL: http://radio-canada.ca/nouvelles
(78544)
URL: http://radio-canada.ca/nouvelles

And here is another URL reported on crashes from today (12/6):
 www.rzeczpospolita.pl/Pl-iso/dodatki/komputer_011206/index.html

It looks like the last build to crash was 2001120309 (so this might not be
crashing anymore), but we should wait a few days to verify that, since we've had
Talkback server issues the last few days.

Comment 1

16 years ago
This is still happening, WinNT 2001120504.  I am crashing on the original url
and also http://www.sassysilver.com.   Same trace.   This happens on Linux and
Mac for me too so changing OS to All.
OS: Windows 2000 → All
(Reporter)

Comment 2

16 years ago
Tever:  do you have the talkback incidents for your crashes?  looking at the
talkback data, i don't see any incidents with this stack signature after 12/3.

I'm going to mark this worksforme based on the talkback data i see.  If we know
of a checkin that fixed this, you can resolve it fixed...or if anyone can
reproduce this with a more recent MozillaTrunk build, feel free to reopen.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: crash, topcrash
Resolution: --- → WORKSFORME
Crash Signature: [@ nsCSSRendering::PaintBackground]
You need to log in before you can comment on or make changes to this bug.