Remove new Mozilla wordmark from tab on Firefox family navigation

RESOLVED FIXED

Status

www.mozilla.org
Pages & Content
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: malexis, Assigned: agibson)

Tracking

Development/Staging
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1679831], URL)

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Looks like the new Mozilla wordmark isn't ready for prime time. Need to remove and replace with the older version. 

Alex can you make this change today?
(Assignee)

Comment 1

3 years ago
By wordmark, do we mean the tabzilla tab in the Firefox Family navigation?

https://github.com/mozilla/bedrock/blob/master/media/img/firefox/family/nav-sprite-high-res.png

Do we have a replacement graphic we can revert to?
Flags: needinfo?(malexis)
Let's hold on this one for half a day while Matej and I regroup with MEM.

But in the meantime, it would be great if Ty could provide a new file.
Nevermind on holding.  Ty will provide an image.  Let's get this out today.
(Assignee)

Comment 4

3 years ago
Just to be clear, this request will remove the wordmark on all pages where the new family nav is used.
Whiteboard: [kb=1679831]
(Assignee)

Updated

3 years ago
Summary: Remove new Mozilla wordmark from tab on Firefox OS page → Remove new Mozilla wordmark from tab on Firefox family navigation
(In reply to Alex Gibson [:agibson] from comment #4)
> Just to be clear, this request will remove the wordmark on all pages where
> the new family nav is used.

Correct. 

It needs to be updated on 4 pages:
/mwc
/firefox/os
/firefox/os/devices
/firefox/partners

Comment 6

3 years ago
Created attachment 8572059 [details]
nav-sprite_updated.png

Here is an updated sprite PNG we can use to replace the newest tabzilla sprite image.
(Assignee)

Comment 7

3 years ago
Ty, could you please update the high-res version? https://github.com/mozilla/bedrock/blob/master/media/img/firefox/family/nav-sprite-high-res.png

Many thanks
Flags: needinfo?(tflanagan)
(Assignee)

Updated

3 years ago
Flags: needinfo?(malexis)

Comment 8

3 years ago
Created attachment 8572065 [details]
nav-sprite-hi-res_updated.png

And here is the hi-res version
(Assignee)

Updated

3 years ago
Flags: needinfo?(tflanagan)
(Assignee)

Comment 9

3 years ago
Created attachment 8572072 [details] [review]
GitHub pull request

Comment 10

3 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/c368d3472c324ce324fa6d51267db34e411587cd
[fix bug 1139003] Remove new Mozilla wordmark from tab on Firefox family navigation

https://github.com/mozilla/bedrock/commit/8bcb3c5b7cf03ed614a5d50fdf5badd28a4eae5c
Merge pull request #2811 from alexgibson/bug-1139003-remove-tabzilla-wordmark-family-nav

[fix bug 1139003] Remove new Mozilla wordmark from tab on Firefox family nav

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

3 years ago
The mystery continues as to why the wordmark did not update. Still seeing the wrong one. Obviously not a cache issue as it's been 24 hours. Any ideas?

If we can't resolve the issue soon, we need to remove the tab entirely until resolved.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I believe I know what's up. The image was updated and when it deployed it had a new name "nav-sprite-high-res.547f151cf8b8.png". The one agibson linked above has a slightly different name "nav-sprite-high-res.a4d086593854.png" which is what we want for cache busting.

The problem is that the reference to this file is in CSS, and that file did not change. The deployment system compiles all of the LESS into CSS, then concatenates and compresses the CSS into bundles, then copies that bundle into a file with the md5 hash of the file contents in the name (like the above). The problem I think is that this file content check is done before the sweep by the deployment system that updates references to images and fonts and whatnot in the CSS to the unique file names with the md5 hashes in them. So, the CSS file with the same name as the old CSS file will be deployed, but because the CDN already has a file by that name it won't be loaded because it's been cached, and the cached version still refers to the old image file.

The temporary fix is to make any tiny change to the LESS file that refers to these images and push that. That will change the file name of the CSS and thus bust the cache. Fixing this so that it doesn't happen again will be slightly more trouble, but I'll file a bug now for it and start seeing what I can do.

Comment 14

3 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/632122edf4ff49638267a829c83ffb46289c5064
[fix bug 1139003] Cache bust tabzilla tab image sprite

https://github.com/mozilla/bedrock/commit/515b955df8d2fb4dbe4d088511d8f67cb6f7914c
Merge pull request #2814 from alexgibson/bug-1139003-bust-tabzilla-image

[fix bug 1139003] Cache bust tabzilla tab image sprite

Updated

3 years ago
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.