[Homescreen][Header] When opening smart collections and returning home, the header where Rocketbar is will be blank

VERIFIED FIXED in 2.2 S7 (6mar)

Status

()

defect
VERIFIED FIXED
4 years ago
4 months ago

People

(Reporter: dharris, Assigned: handyman)

Tracking

({regression, smoketest})

39 Branch
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, e10sm5+, b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], )

Attachments

(2 attachments)

Posted file Header Logcat
Description:
The user will experience blank or blurred headers on the home screen, and within smart collections by transitioning between these two areas. If the user begins entering a Rocketbar search, the search icons at the top of the page will appear to be cut off


Repro Steps:
1) Update a Flame to 20150303010233
2) Open any smart collection
3) Observe header
4) Return to Homescreen
5) Scroll to the top and observe header


Actual:
There is a black bar in the header of the smart collection, and on the homscreen there is a blank space


Expected:
All headers are fully and properly displayed

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150303010233
Gaia: c8ed1085a67490a1ecd7f275e5de9487e1b93b1d
Gecko: 0b3c520002ad
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 5/5
See attached: Logcat, Video - http://youtu.be/qWlD5tALbXI
This issue does NOT occur on Flame 2.2

All headers are fully and properly displayed

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150303002527
Gaia: 3d188c414e30acc392253d5389a42352fcfbc183
Gecko: c89aad487aa5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Regression that fails smoke tests.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: jmercado
This occurs in some apps as well, not just the Homescreen.
Most likely this was caused by the backout of bug 1137203 yesterday. It has since re-landed on inbound. Probably worth confirming that though.
Bug 1075670 seems to have caused this issue.

Mozilla-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150227113729
Gaia: f34ce82a840ad3c0aed3bfff18517b3f6a0eb37f
Gecko: 20d0b5cb2071
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Broken 
Device: Flame 3.0
BuildID: 20150227115524
Gaia: f34ce82a840ad3c0aed3bfff18517b3f6a0eb37f
Gecko: 3bb518882815
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Last Working gaia / First Broken gecko - 
Gaia: f34ce82a840ad3c0aed3bfff18517b3f6a0eb37f
Gecko: 3bb518882815

First Broken gaia / Last Working gecko - 
Gaia: f34ce82a840ad3c0aed3bfff18517b3f6a0eb37f
Gecko: 20d0b5cb2071

Gecko Pushlog: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=20d0b5cb2071&tochange=3bb518882815
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
David, can you take a look at this please? Looks like this is possibly caused by the landings for bug 1075670.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(davidp99)
Flags: needinfo?(ktucker)
There's another issue probably caused by the same bug. The screen reader selection area is off downwards than the actual area. (See the attached screenshot.) 

This issue has the same regression window as Comment 5.
Assignee: nobody → davidp99
Bug 1075670 backed out per nhirata's IRC request. Hopefully it gets some on-device testing before even getting a sniff at landing again.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(davidp99)
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S7 (6mar)
with the latest build, the back out does fix things.
blocking-b2g: 3.0? → 3.0+
Component: Gaia::System::Window Mgmt → DOM
Product: Firefox OS → Core
Version: unspecified → 39 Branch
This issue is verified fixed on the latest Master build.
Headers in Smart Collections and Homescreen are fully and properly displayed.

Environmental Variables:
Device: Flame 3.0
Build ID: 20150304010324
Gaia: 3fc0ac309f5fb0c1fe82c12223b955a4efce27e6
Gecko: c5b90c003be8
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.