Crash with Direct2D on AMD/ATI cards on big images [@ atidxx32.dll@0x509dc3 ]

RESOLVED WONTFIX

Status

()

Core
Graphics
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: mkdante381, Unassigned)

Tracking

36 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox36- wontfix, firefox37+ unaffected, firefox38+ unaffected, firefox39+ unaffected)

Details

(Whiteboard: [gfx-noted], crash signature)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150222232811

Steps to reproduce:

1. Direct2d enabled in Firefox 36
2. Go to site with high resolution image for example:
http://gfx.gexe.pl/upl/1181/2012/9/19200824.png
3. FF crash with 
signature [@ atidxx32.dll@0x509dc3 ] 
and 
Crash Reason: EXCEPTION_ACCESS_VIOLATION_WRITE

My Crash report:
https://crash-stats.mozilla.com/report/index/85050ec7-6002-463f-9631-618662150303


Actual results:

Firefox crash on site with high resolution images, with Direct2D enabled on AMD/ATI graphic cards:
gfx.direct2d.disabled;false



Expected results:

2 solutions for resolved this problem:
-Direct2D off in Firefox:
gfx.direct2d.disabled;true
0 crash on high resolution images
or
-Enabled Direct2D 1.1 in FF 36
gfx.direct2d.use1_1;true
gfx.canvas.azure.backends;direct2d1.1,direct2d,skia,cairo
gfx.content.azure.backends;direct2d1.1,direct2d,cairo
gfx.direct2d.disabled;false
gfx.direct2d.force-enabled;false
0 crash on high resolution images
Component: Untriaged → Graphics
Product: Firefox → Core
Seems like d2d 1 (and not d2d 1.1 and not non-d2d) have a problem with very large images. Bas, is this known?
Flags: needinfo?(bas)
Whiteboard: [gfx-noted]
(Reporter)

Comment 2

3 years ago
FF with D2D enabled, crash on my Gigabyte AMD R9 270X. This problem is on all Catalyst drivers. FF with D2D enabled don't crash on Nvidia cards.
(Reporter)

Updated

3 years ago
Depends on: 805406
(Reporter)

Updated

3 years ago
Depends on: 720991
(Reporter)

Comment 3

3 years ago
[Tracking Requested - why for this release]:
tracking-firefox36: --- → ?
tracking-firefox37: --- → ?
tracking-firefox38: --- → ?
tracking-firefox39: --- → ?
(Reporter)

Comment 4

3 years ago
This problem is on all Firefox versions. 
3rd solution is:
-Enabled Direct2D 1.1 in FF 36. FF use D2d1.1 from Windows?
gfx.direct2d.use1_1;true
gfx.canvas.azure.backends;direct2d,skia,cairo
gfx.content.azure.backends;direct2d,cairo
gfx.direct2d.disabled;false
gfx.direct2d.force-enabled;false

0 crash on high resolution images
kats - This looks somewhat bad although it looks like it did ship in 36. Is anyone available to debug this crash today?
status-firefox36: --- → wontfix
status-firefox37: --- → affected
status-firefox38: --- → affected
status-firefox39: --- → affected
tracking-firefox36: ? → -
tracking-firefox37: ? → +
tracking-firefox38: ? → +
tracking-firefox39: ? → +
Flags: needinfo?(bugmail.mozilla)
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #5)
> kats - This looks somewhat bad although it looks like it did ship in 36. Is
> anyone available to debug this crash today?

37 has d2d1.1 which does not exhibit this issue according to comment 0, would we ship a fix in the release for this crash?
Agree with nical, it looks like direct2d1.1 is enabled by default in 37 and up, so this crash shouldn't happen in a default configuration in 37 and up. I'm not familiar with the D2D code - do we fall back to D2D1.0 in some scenarios, and is the percentage of time that happens high enough to warrant jumping on this fix right away?
Flags: needinfo?(bugmail.mozilla)
Thank you both. I missed that this shouldn't impact 37 and indeed there are no crashes reported on 37. I suggest that we mark this as wontfix.

Note that there is one crash reported on 38. Perhaps that is a user who has changed the default prefs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
status-firefox37: affected → unaffected
status-firefox38: affected → unaffected
status-firefox39: affected → unaffected
Resolution: --- → WONTFIX
(Reporter)

Comment 9

3 years ago
Probably problem is on 36-39 FF version. FF crash for me on 36(.01) stable release and 39.01a(Nightly) with D2D enabled on site with High resolution images and D2D1.1 enabled (only random crash FF). 
 I have AMD R9 270X and I do not know how it is in other graphics cards AMD. I did write to AMD support. This error is practically from the beginning, as soon as my video card appeared on the market. Its both fault: Mozilla and AMD. This problem not applicable Nvidia. Nvidia cares about their products...
(In reply to mkdante381 from comment #9)
> Probably problem is on 36-39 FF version. FF crash for me on 36(.01) stable
> release and 39.01a(Nightly) with D2D enabled on site with High resolution
> images and D2D1.1 enabled (only random crash FF). 

Can you clarify? You said in comment 0 that enabling D2D1.1 in FF36 did NOT result in crashing, but here you are saying it does result in crashing?
(Reporter)

Comment 11

3 years ago
On(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #10)
> (In reply to mkdante381 from comment #9)
> > Probably problem is on 36-39 FF version. FF crash for me on 36(.01) stable
> > release and 39.01a(Nightly) with D2D enabled on site with High resolution
> > images and D2D1.1 enabled (only random crash FF). 
> 
> Can you clarify? You said in comment 0 that enabling D2D1.1 in FF36 did NOT
> result in crashing, but here you are saying it does result in crashing?

Today I discovered that the previous crashes were also the D2D 1.1. 
On FF with D2D 1.1 enabled, FF don't crash on high res images, but there is random crash. 
On FF with D2D enabled, on site with high res images, FF stop responding or FF crash. 
Now I have disabled Direct2D in FF and its ok. This is problem AMD and Mozilla. Much less AMD :-)
Can you file a new bug for these random crashes and include reports to crash URLs from about:crashes? Thanks.
(Reporter)

Comment 13

3 years ago
nsBaseContentList::cycleCollection::CanSkipReal(void*, bool) 
https://crash-stats.mozilla.com/report/index/717f93b5-1184-4be2-b776-184cd2150318

nsTArray_Impl<nsCOMPtr<nsIContent>, nsTArrayInfallibleAllocator>::Clear()
https://crash-stats.mozilla.com/report/index/d9e599c4-edbd-4111-af0d-033ac2150318

nsDOMCSSAttributeDeclaration::GetCSSDeclaration(bool) 
https://crash-stats.mozilla.com/report/index/44afa29b-8690-4334-a71f-d0df22150316

mozilla::dom::FragmentOrElement::CanSkip(nsINode*, bool)
https://bugzilla.mozilla.org/show_bug.cgi?id=791437
https://crash-stats.mozilla.com/report/index/a32aab58-8e92-4b25-b64a-69b0f2150301

CycleCollectionNoteChild<nsPIDOMWindow>(nsCycleCollectionTraversalCallback&, nsPIDOMWindow*, char const*, unsigned int) 
https://crash-stats.mozilla.com/report/index/f7ce7c57-46c1-49d9-8b77-312542150316

CCGraphBuilder::NoteXPCOMChild(nsISupports*)
https://crash-stats.mozilla.com/report/index/ebc0a598-68f4-438e-a54a-b6d682150316
Thanks for the links. None of these seem to be D2D1.1-specific, and in fact seem to have a variety of different root causes. If you are able to reproduce any of these it would help to file a bug specifically for it with steps to reproduce. Otherwise there's not very much we can do about it.
Flags: needinfo?(bas)
(Reporter)

Comment 15

3 years ago
To me it looks like a problem with the GPU acceleration. I'll enable D2D 1.1 in FF and wait for crash. The first crash report I will add here.
(In reply to mkdante381 from comment #15)
> To me it looks like a problem with the GPU acceleration.

What makes you say that?

> I'll enable D2D 1.1
> in FF and wait for crash. The first crash report I will add here.

As I said before, there's not much we can do with simple crash report URLs unless we also have steps to reproduce. Feel free to post what you like but don't expect anything to happen.
(Reporter)

Comment 17

3 years ago
I wrote in https://bugzilla.mozilla.org/show_bug.cgi?id=1139018#c0 This crash is with D2D enabled. Image contains errors, FF stop responding and FF crash.

I'm waiting for the crash FF with D2D 1.1.
(Reporter)

Comment 18

3 years ago
1-st crash after enabled D2D1.1:
https://crash-stats.mozilla.com/report/index/c4e85a10-7cf0-42f2-9356-5abe02150318
https://bugzilla.mozilla.org/show_bug.cgi?id=1144935
(Reporter)

Comment 19

3 years ago
All my upload bugs are related with my cpu oc. Now I change to 3.37GHz(from 3.44GHz) and I don't have crash any more(with "gfx.direct2d.use1_1;true"). I have FF 39 beta 2. The problem still is when I turn on Direct2D acceleration(from "gfx.direct2d.use1_1;true" to "gfx.direct2d.use1_1;false"). No crash with enabled Direct2d1.1(gfx.direct2d.use1_1;true)
MY crash report https://crash-stats.mozilla.com/report/index/ec76c728-4c18-4604-aeea-4e4112150603
(Reporter)

Updated

3 years ago
Crash Signature: atidxx32.dll@0x55c8b3
(Reporter)

Updated

3 years ago
Crash Signature: atidxx32.dll@0x55c8b3 → atidxx32.dll@0x55c8b3 atidxx32.dll@0x509dc3
(Reporter)

Updated

3 years ago
Crash Signature: atidxx32.dll@0x55c8b3 atidxx32.dll@0x509dc3 → atidxx32.dll@0x55c8b3 atidxx32.dll@0x509dc3
(Reporter)

Updated

3 years ago
Crash Signature: atidxx32.dll@0x55c8b3 atidxx32.dll@0x509dc3 → atidxx32.dll@0x55c8b3 atidxx32.dll@0x509dc3
You need to log in before you can comment on or make changes to this bug.