Latest Nightly won't launch on Mac OS X 10.10.3 Beta

VERIFIED FIXED in Firefox 39

Status

()

Core
Memory Allocator
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: verdi, Assigned: glandium)

Tracking

({regression})

39 Branch
mozilla39
x86
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox39 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Yesterday I was using Mac OS X 10.10.2 and the Nightly from 3-2-15 without issue. Last night my system updated to 10.10.3 beta and Nightly updated to the build from 3-3-15. When I tried to launch Nightly, the icon just bounces in the doc forever. Release Firefox seems to work just fine. I reinstalled the Nightly from 3-2-15 and it also works fine.
I can confirm. I'm also running 10.10.3 Beta.

We need a regression range.
I got https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=60a37ae57d9c&tochange=a1a89ff4ee31 , I'm going to double-check it.
Last working build: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-macosx64/1425249208/firefox-39.0a1.en-US.mac.dmg
First broken build: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-macosx64/1425249390/firefox-39.0a1.en-US.mac.dmg

Regression range: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6470d649e1bb&tochange=a1a89ff4ee31

-> bug 762449

> mstange:~$ lldb
> (lldb) attach -p 9171
> Process 9171 stopped
> Executable module set to "/Volumes/Nightly 1/Nightly.app/Contents/MacOS/firefox".
> Architecture set to: x86_64-apple-macosx.
> (lldb) bt all
> * thread #1: tid = 0x5c8cb, 0x00007fff8d2d151a libsystem_kernel.dylib`semaphore_wait_trap + 10, queue = 'com.apple.main-thread', stop reason = signal SIGSTOP
>   * frame #0: 0x00007fff8d2d151a libsystem_kernel.dylib`semaphore_wait_trap + 10
>     frame #1: 0x00007fff83c90b9c libdispatch.dylib`_dispatch_group_wait_slow + 218
>     frame #2: 0x00007fff8cc6febc CoreFoundation`-[CFPrefsSearchListSource generationCountFromListOfSources:count:allowFetching:] + 284
>     frame #3: 0x00007fff8cb2c5a5 CoreFoundation`-[CFPrefsSearchListSource alreadylocked_copyDictionary] + 133
>     frame #4: 0x00007fff8cb274ba CoreFoundation`-[CFPrefsSearchListSource alreadylocked_copyValueForKey:] + 42
>     frame #5: 0x00007fff8cca12dc CoreFoundation`___CFPreferencesCopyAppValueWithContainer_block_invoke + 60
>     frame #6: 0x00007fff8cc6ee49 CoreFoundation`+[CFPrefsSearchListSource withSearchListForIdentifier:container:perform:] + 729
>     frame #7: 0x00007fff8cca1257 CoreFoundation`_CFPreferencesCopyAppValueWithContainer + 183
>     frame #8: 0x00007fff8cca136d CoreFoundation`_CFPreferencesGetAppBooleanValueWithContainer + 29
>     frame #9: 0x00007fff85de3a5b QuickLook`_QLAppPreferencesBooleanValueForKey + 42
>     frame #10: 0x00007fff860e12a2 QuickLookUI`_GLOBAL__I_a + 18
>     frame #11: 0x00007fff647f0ceb dyld`ImageLoaderMachO::doModInitFunctions(ImageLoader::LinkContext const&) + 265
>     frame #12: 0x00007fff647f0e78 dyld`ImageLoaderMachO::doInitialization(ImageLoader::LinkContext const&) + 40
>     frame #13: 0x00007fff647ed871 dyld`ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 305
>     frame #14: 0x00007fff647ed806 dyld`ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 198
>     frame #15: 0x00007fff647ed806 dyld`ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 198
>     frame #16: 0x00007fff647ed6f8 dyld`ImageLoader::processInitializers(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 138
>     frame #17: 0x00007fff647ed969 dyld`ImageLoader::runInitializers(ImageLoader::LinkContext const&, ImageLoader::InitializerTimingList&) + 75
>     frame #18: 0x00007fff647e3063 dyld`dyld::runInitializers(ImageLoader*) + 89
>     frame #19: 0x00007fff647e89ea dyld`addImage(void*, char const*, bool, bool, bool, bool) + 305
>     frame #20: 0x00007fff83b9c9ab libdyld.dylib`NSAddImage + 72
>     frame #21: 0x0000000100003a71 firefox`XPCOMGlueStartup + 673
>     frame #22: 0x0000000100001839 firefox`main + 665
>     frame #23: 0x0000000100001244 firefox`start + 52
> 
>   thread #2: tid = 0x5c8ee, 0x00007fff8d2d6166 libsystem_kernel.dylib`__psynch_mutexwait + 10, queue = 'com.apple.root.libdispatch-manager'
>     frame #0: 0x00007fff8d2d6166 libsystem_kernel.dylib`__psynch_mutexwait + 10
>     frame #1: 0x00007fff8d62278a libsystem_pthread.dylib`_pthread_mutex_lock + 480
>     frame #2: 0x00007fff83b9c250 libdyld.dylib`dyldGlobalLockAcquire() + 16
>     frame #3: 0x00007fff647f7fc6 dyld`ImageLoaderMachOCompressed::doBindFastLazySymbol(unsigned int, ImageLoader::LinkContext const&, void (*)(), void (*)()) + 54
>     frame #4: 0x00007fff647e21e7 dyld`dyld::fastBindLazySymbol(ImageLoader**, unsigned long) + 90
>     frame #5: 0x00007fff83b9c3ba libdyld.dylib`dyld_stub_binder + 282
>     frame #6: 0x00000001000610d0 libmozglue.dylib`double_conversion::kCachedPowers + 29248
>     frame #7: 0x0000000100011cb4 libmozglue.dylib`zone_memalign + 52
> 
>   thread #3: tid = 0x5c8ef, 0x00007fff8d2d6166 libsystem_kernel.dylib`__psynch_mutexwait + 10, queue = 'com.apple.root.default-qos.overcommit'
>     frame #0: 0x00007fff8d2d6166 libsystem_kernel.dylib`__psynch_mutexwait + 10
>     frame #1: 0x00007fff8d62278a libsystem_pthread.dylib`_pthread_mutex_lock + 480
>     frame #2: 0x00007fff83b9c250 libdyld.dylib`dyldGlobalLockAcquire() + 16
>     frame #3: 0x00007fff647f7fc6 dyld`ImageLoaderMachOCompressed::doBindFastLazySymbol(unsigned int, ImageLoader::LinkContext const&, void (*)(), void (*)()) + 54
>     frame #4: 0x00007fff647e21e7 dyld`dyld::fastBindLazySymbol(ImageLoader**, unsigned long) + 90
>     frame #5: 0x00007fff83b9c3ba libdyld.dylib`dyld_stub_binder + 282
>     frame #6: 0x00000001000610d0 libmozglue.dylib`double_conversion::kCachedPowers + 29248
>     frame #7: 0x0000000100011cb4 libmozglue.dylib`zone_memalign + 52
> (lldb) up 9
> frame #9: 0x00007fff85de3a5b QuickLook`_QLAppPreferencesBooleanValueForKey + 42
> QuickLook`_QLAppPreferencesBooleanValueForKey + 42:
> -> 0x7fff85de3a5b:  cmpb   $0x0, -0x19(%rbp)
>    0x7fff85de3a5f:  je     0x7fff85de3a66            ; _QLAppPreferencesBooleanValueForKey + 53
>    0x7fff85de3a61:  movzbl %al, %eax
>    0x7fff85de3a64:  jmp    0x7fff85de3a88            ; _QLAppPreferencesBooleanValueForKey + 87
> (lldb) po $r15
> QLAlternateAnimationCurve
>
Component: General → Memory Allocator
Keywords: regression
Product: Firefox → Core
Blocks: 762449
(Assignee)

Comment 4

3 years ago
At least, 10.10.2 is not affected (tested, since I happened to install 10.10.2 before installing 10.10.3)
(Assignee)

Comment 5

3 years ago
Created attachment 8572567 [details] [diff] [review]
Bind all symbols from libmozglue.dylib when it is loaded
Assignee: nobody → mh+mozilla
Attachment #8572567 - Flags: review?(ted)
Attachment #8572567 - Flags: review?(ted) → review+
(Assignee)

Comment 6

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/cf2a5c5edfdf
https://hg.mozilla.org/mozilla-central/rev/cf2a5c5edfdf
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
(Reporter)

Comment 8

3 years ago
Thanks! 39.0a1 (2015-03-05) launches on 101.10.3 for me.

Updated

3 years ago
Duplicate of this bug: 1139936
Status: RESOLVED → VERIFIED

Updated

3 years ago
Duplicate of this bug: 1139962
Duplicate of this bug: 1140015
You need to log in before you can comment on or make changes to this bug.