[RTL][Dialer] 2 SIMs, receiving a call from a contact with a long name will overlap SIM label text

RESOLVED DUPLICATE of bug 1011066

Status

Firefox OS
Gaia::Dialer
P2
normal
RESOLVED DUPLICATE of bug 1011066
3 years ago
3 years ago

People

(Reporter: oliverthor, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8572226 [details]
2015-03-03-17-34-43.png

Description:
When a user receives a call from a contact with a long name, and has 2 SIMs in their device, the name will overlap with the SIM that was being contacted by the call. 

PreReq:
* contact with a long name
* 2 SIMs in phone
Repro Steps:
1) Update a Flame to 20150303010233
2) Lock device.
3) Receive a call from contact with long name.
4) Observe contact name and position of SIM identifiying text label.

Actual:
Contact name overlaps SIM label text.

Expected:
Contact name truncates before overlapping SIM label text.

Environmental Variables:
--------------------------------------------------
Device: Flame 3.0
Build ID: 20150303010233
Gaia: c8ed1085a67490a1ecd7f275e5de9487e1b93b1d
Gecko: 0b3c520002ad
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
--------------------------------------------------
Device: Flame 2.2
BuildID: 20150303002527
Gaia: 3d188c414e30acc392253d5389a42352fcfbc183
Gecko: c89aad487aa5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
--------------------------------------------------

Repro frequency: 5/5
See attached: 
screenshot
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing]
Blocks: 1064539
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Triage: P2
blocking-b2g: --- → 2.2?
Priority: -- → P2

Updated

3 years ago
Component: Gaia::System::Lockscreen → Gaia::Dialer
Summary: [RTL][Lockscreen] 2 SIMs, receiving a call from a contact with a long name will overlap SIM label text → [RTL][Dialer] 2 SIMs, receiving a call from a contact with a long name will overlap SIM label text
triage: major issue on new feature.
blocking-b2g: 2.2? → 2.2+
Duplicate of this bug: 1139198
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1011066
You need to log in before you can comment on or make changes to this bug.