[RTL] 'Call Log' truncates long contacts' name at the beginning of the name.

VERIFIED FIXED in Firefox OS v2.2

Status

P1
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: onelson, Assigned: azasypkin)

Tracking

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing][planned-sprint c=3])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8572252 [details]
dialer_inconsistent_rtl_formatting.png

Description:
When a user observes their call log from contacts they've registered in their phone, they will observe that the contacts will display in RTL formatting with the beginning of the name cut off and truncated with an ellipsis. The 'Contacts' page on the other hand, displays contacts in LTR with the end of the name cut off and truncated with an ellipse. The phone's language is set as Arabic(RTL), but the contact name is written in English(LTR) text.

PreReq:
* contact with a long name
Repro Steps:
1) Update a Flame to 20150303010233
2) Open the 'Dialer' app.
3) Receive a call from contact with long name.
4) Observe the contact's name as presented in the 'Call Log' page.
5) Observe the contact's name as presented in the 'Contacts' page.

Actual:
Contact name overlaps SIM label text.

Expected:
Contact name truncates before overlapping SIM label text.

Environmental Variables:
--------------------------------------------------
Device: Flame 3.0
Build ID: 20150303010233
Gaia: c8ed1085a67490a1ecd7f275e5de9487e1b93b1d
Gecko: 0b3c520002ad
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
--------------------------------------------------

Issue shows consistent RTL behavior in 2.2
Results: Contacts with long names display in RTL format (beginning cut off, with 

Device: Flame 2.2
BuildID: 20150303002527
Gaia: 3d188c414e30acc392253d5389a42352fcfbc183
Gecko: c89aad487aa5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
--------------------------------------------------

Repro frequency: 5/5
See attached: 
screenshot
(Reporter)

Comment 1

4 years ago
Forgot the rest of my thought train on my 2.2 results, they are displayed in the screenshot as well:
2.2 Results: Contacts with long names display in RTL format (beginning cut off, with an ellipsis showing the truncation).
Blocks: 1071918
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing]
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(pbylenga)
The difference between 3.0 and 2.2 is because bug 1126587 hasn't landed on 2.2 yet. The dialer issue is an new one. Thanks!

[Blocking Requested - why for this release]: Part of the RTL feature.
blocking-b2g: --- → 2.2?
Summary: [RTL][Dialer] 'Call Log' formatting displays contacts in RTL format, while 'Contacts' displays contacts in LTR format (Arabic Language: English Text) → [RTL] 'Call Log' truncates long contacts' name at the beginning of the name.
Priority: -- → P1
triage: major issue on RTL.
blocking-b2g: 2.2? → 2.2+
Can we please get someone assigned to this as this is a blocker? thanks
Assignee: nobody → drs.bugzilla
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][planned-sprint c=3]
Target Milestone: --- → 2.2 S8 (20mar)

Updated

4 years ago
Status: NEW → ASSIGNED
Test case has been added in moztrap:https://moztrap.mozilla.org/manage/case/16004/
Flags: in-moztrap+
Josh, please do not set bugs to ASSIGNED as we use this status to indicate that work has actually begun.
Flags: needinfo?(jocheng)
Status: ASSIGNED → NEW
Oleg, Steve, can either of you take this bug? I think for the most part it's just an issue of putting a <bdi> tag around the primary contact info. Thanks for any help you can provide.
Flags: needinfo?(schung)
Flags: needinfo?(azasypkin)
(Assignee)

Comment 8

4 years ago
I'll try to fix it. 

At the first look (via WebIDE) I see that we already have <bdi>, but ellipsis is done by parent element. Also there is a ".retry-count" element that if not empty should probably be always visible even if contact is truncated.
Assignee: dsherk → azasypkin
Status: NEW → ASSIGNED
Flags: needinfo?(schung)
Flags: needinfo?(azasypkin)

Comment 9

4 years ago
(In reply to Doug Sherk (:drs) (use needinfo?) from comment #6)
> Josh, please do not set bugs to ASSIGNED as we use this status to indicate
> that work has actually begun.

Noted Doug, Sorry for the inconvenience.
Flags: needinfo?(jocheng)
Created attachment 8575908 [details] [review]
[gaia] azasypkin:bug-1139207-dialer-rtl-long-contacts > mozilla-b2g:master
Comment on attachment 8575908 [details] [review]
[gaia] azasypkin:bug-1139207-dialer-rtl-long-contacts > mozilla-b2g:master

Hey Doug,

Here is PR that should fix this issue, I tried to be as less intrusive as possible + left few clarifications comment at GitHub.

Also I'm not sure if you already have "truncation" bug for Call Screen header, but it has the same issue as well.

Thanks!
Attachment #8575908 - Flags: review?(dsherk)
Comment on attachment 8575908 [details] [review]
[gaia] azasypkin:bug-1139207-dialer-rtl-long-contacts > mozilla-b2g:master

Looks great. Thanks for your help here, and for explaining some of your changes in the PR.
Attachment #8575908 - Flags: review?(dsherk) → review+
Comment on attachment 8575908 [details] [review]
[gaia] azasypkin:bug-1139207-dialer-rtl-long-contacts > mozilla-b2g:master

I found a bug with this while testing it.

STR: 
1. Call someone who isn't a contact, hang up.
2. Add them as a contact from the call info view.
3. Call them back again.

Expected: Call log shows their name with (2) retry count.
Actual: Call log shows their phone number (as if they're not a contact) with retry count.

I'm investigating why this is happening now.
Attachment #8575908 - Flags: review+
Comment on attachment 8575908 [details] [review]
[gaia] azasypkin:bug-1139207-dialer-rtl-long-contacts > mozilla-b2g:master

False alarm. It just needed a rebase. The bug was caused by something else that must have been fixed between the time this branch was cut and this patch posted.
Attachment #8575908 - Flags: review+
Treeherder is green, so landed.

Master: https://github.com/mozilla-b2g/gaia/commit/e8cac105a4d416c2cd736f33f24d613b5ffeb83a
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-master: affected → fixed
Resolution: --- → FIXED
Comment on attachment 8575908 [details] [review]
[gaia] azasypkin:bug-1139207-dialer-rtl-long-contacts > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): n/a
[User impact] if declined: Long RTL (LTR) contact names are truncated from the wrong side in LTR (RTL) + retry counter isn't visible if name is too long.
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: n/a
Attachment #8575908 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8575908 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Created attachment 8577844 [details]
Verify_Call log_Flame2.2&3.0.png

This issue has been verified successfully on latest Flame 2.0 and Flame 3.0 version, 'Call Log' truncates long contacts' name at the end of the name(at the right side of the name).

See attachment:Verify_Call log_Flame2.2&3.0.png
Reproducing rate:0/10

Flame 2.2 build(Pass):
Build ID               20150315162500
Gaia Revision          a6b2d3f8478ec250beb49950fecbb8a16465ff6f
Gaia Date              2015-03-15 14:33:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/18619f8f6c5c
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150315.195030
Firmware Date          Sun Mar 15 19:50:42 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build(Pass):
Build ID               20150315160203
Gaia Revision          d4177902b04b8fedcb7df9a30ae6e9677e03d2d4
Gaia Date              2015-03-13 15:58:35
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/af68c9c0e903
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150315.192711
Firmware Date          Sun Mar 15 19:27:22 EDT 2015
Bootloader             L1TC000118D0
Created attachment 8577845 [details]
Verify_Call log_Flame2.2&3.0.png

This issue has been verified successfully on latest Flame 2.0 and Flame 3.0 version, 'Call Log' truncates long contacts' name at the end of the name(at the right side of the name).

See attachment:Verify_Call log_Flame2.2&3.0.png
Reproducing rate:0/10

Flame 2.2 build(Pass):
Build ID               20150315162500
Gaia Revision          a6b2d3f8478ec250beb49950fecbb8a16465ff6f
Gaia Date              2015-03-15 14:33:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/18619f8f6c5c
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150315.195030
Firmware Date          Sun Mar 15 19:50:42 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build(Pass):
Build ID               20150315160203
Gaia Revision          d4177902b04b8fedcb7df9a30ae6e9677e03d2d4
Gaia Date              2015-03-13 15:58:35
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/af68c9c0e903
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150315.192711
Firmware Date          Sun Mar 15 19:27:22 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
You need to log in before you can comment on or make changes to this bug.