[FFOS2.0][Woodduck][Airplane mode]The airplane mode is invalid

RESOLVED FIXED
(Needinfo from 2 people)

Status

P2
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: sync-1, Assigned: GaryChen, NeedInfo)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0M+, b2g-v2.0 affected, b2g-v2.0M fixed, b2g-v2.1 affected, b2g-v2.1S affected, b2g-v2.2 affected, b2g-master fixed)

Details

Attachments

(8 attachments)

(Reporter)

Description

4 years ago
DEFECT DESCRIPTION:
  The airplane mode is invalid 
 
  REPRODUCING PROCEDURES:
   1.Insert SIM2 ,Activate the cell with MCC=001,send some CB(0,65534,919,921)to SIM2
   2.Change the MCC to 730,send some CB(0,65534,919,921)to SIM2
   3.Pull down the notification bar then activate the airplane mode
   4.Redo the sstep 2,3 =>KO
 
  EXPECTED BEHAVIOUR:
 
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

4 years ago
Created attachment 8572348 [details]
adb log
(Reporter)

Comment 2

4 years ago
Created attachment 8572349 [details]
mtklog

Comment 3

4 years ago
Hi Peipei,
Can we reproduce this?
Thanks!
Blocks: 1054172
Flags: needinfo?(pcheng)
(In reply to Josh Cheng [:josh] from comment #3)
> Hi Peipei,
> Can we reproduce this?
> Thanks!

Josh, we cannot test this because we don't have lab environment :(
Flags: needinfo?(pcheng)
(Reporter)

Comment 5

4 years ago
hi mozilla:
    步骤:下拉状态栏,连续点击几次蓝牙开关,之后点击飞行模式图标,接着反复切换点击蓝牙和飞行模式图标,复现问题,概率8/10,附件为对应log.
    
    该问题应该是由于快速多次切换飞行模式后,就会在settings中看到飞行模式的开关与实际情况不符或者一直处于无法设置状态。但是通知栏中还是可以点击的。

Comment 6

4 years ago
Hi Gary,
Can we introduce some delay for frequently on-off bluetooth? Will this be the same as wifi?
Thanks!
Flags: needinfo?(gchen)
Assignee: nobody → gchen
Flags: needinfo?(gchen)
Created attachment 8573054 [details] [review]
[gaia] mpizza:Bug_1139238_v2.0m > mozilla-b2g:v2.0m
Component: Gaia::Settings → Gaia::System
Comment on attachment 8573054 [details] [review]
[gaia] mpizza:Bug_1139238_v2.0m > mozilla-b2g:v2.0m

Hi Tim,
   I add one more condition to avoid user clicks bluetooth and airplane button rapidly.

   Could you help to review this patch and give me some feedback?
   Thanks.
Attachment #8573054 - Flags: review?(timdream)
Comment on attachment 8573054 [details] [review]
[gaia] mpizza:Bug_1139238_v2.0m > mozilla-b2g:v2.0m

I am not sure this is a safe approach.

Also please update the commit message to document the fix, not the bug. Thanks.
Attachment #8573054 - Flags: review?(timdream) → review?(arthur.chen)
Comment on attachment 8573054 [details] [review]
[gaia] mpizza:Bug_1139238_v2.0m > mozilla-b2g:v2.0m

It is sane ignoring the request of toggling bluetooth when airplane mode is in the transition states. Although there are other corner cases to be handled (ex: while bluetooth is enabling/disabling, can users toggle airplane mode?), but we won't have a proper fix until API reporting the hardware status are available. 

I left some comments regarding the implementation in github, please check, thanks.
Attachment #8573054 - Flags: review?(arthur.chen)
Hi Norry,
   Could you help to check all branches?
   Thanks.
Flags: needinfo?(fan.luo)

Updated

4 years ago
Keywords: qawanted

Updated

4 years ago
Blocks: 1080337
Hi Gary,

Due to there is no lab environment, we can't send CB message according to comment 0. But I have tried to repro it according to comment 5, and can't repro on woodduck 2.0M, Flame 2.0/2.1/2.1s/2.2/3.0.
Flags: needinfo?(fan.luo) → needinfo?(gchen)
status-b2g-v2.0: --- → affected
status-b2g-v2.0M: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.1S: --- → affected
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(gchen)

Comment 13

4 years ago
Hi ChenDing,
Could you help to try patch per https://bugzilla.mozilla.org/attachment.cgi?id=8573054?
Thanks!
Flags: needinfo?(chen.ding)

Updated

4 years ago
Status: NEW → ASSIGNED
Created attachment 8574599 [details] [review]
[gaia] mpizza:Bug_1139238_master > mozilla-b2g:master
Component: Gaia::System → Gaia::Settings
Comment on attachment 8574599 [details] [review]
[gaia] mpizza:Bug_1139238_master > mozilla-b2g:master

Hi arthur,
   I've addressed you comment and added some tests.
   Could you help to review this patch?
   Thanks.
Attachment #8574599 - Flags: review?(arthur.chen)
(Reporter)

Comment 16

4 years ago
hi mozilla:
    I test the patch and it don't fixed this PR.
gary, per comment 16, the patch does not fix this problem. Could you please take a look?
Flags: needinfo?(gchen)
(In reply to sync-1 from comment #16)
> hi mozilla:
>     I test the patch and it don't fixed this PR.

Could you provide the STR video recording?
Thanks.
Flags: needinfo?(gchen)
Flags: needinfo?(sync-1)
(Reporter)

Comment 19

4 years ago
Created an attachment (id=1186872)
 video part2
(Reporter)

Comment 20

4 years ago
Created an attachment (id=1186872)
 video part2
(Reporter)

Comment 21

4 years ago
Created attachment 8575065 [details]
video part2

Created an attachment (id=1186872)
 video part2
(Reporter)

Comment 22

4 years ago
Created an attachment (id=1186874)
 video part3
(Reporter)

Comment 23

4 years ago
Created an attachment (id=1186874)
 video part3
(Reporter)

Comment 24

4 years ago
Created attachment 8575066 [details]
video part3

Created an attachment (id=1186874)
 video part3
Comment hidden (typo)
Comment hidden (typo)
(Reporter)

Comment 27

4 years ago
Created attachment 8575067 [details]
video part1

Created an attachment (id=1186871)
 video part1
Comment hidden (typo)
sorry, set to wrong bug. reopen it.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

4 years ago
Status: REOPENED → NEW
Comment on attachment 8574599 [details] [review]
[gaia] mpizza:Bug_1139238_master > mozilla-b2g:master

Looking good to me, thanks.
Attachment #8574599 - Flags: review?(arthur.chen) → review+
Created attachment 8575824 [details] [review]
[gaia] mpizza:bug_1139238_v2.0m_airplanemode_enhance > mozilla-b2g:v2.0m

Comment 32

4 years ago
Hi ChenDing,
Could you help to try patch per https://bugzilla.mozilla.org/attachment.cgi?id=8575824
Thanks!
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
status-b2g-master: affected → fixed
Removing qawanted since this was already been branch checked and is now resolved fixed.
QA Whiteboard: [QAnalyst-Triage+]
Keywords: qawanted
Blocks: 1080481

Comment 35

4 years ago
Hi Gary, 
DO you need 2.0M patch review?
Thanks!
Flags: needinfo?(gchen)
Hi Josh,
   Sorry, I forget set v2.m? flag.
   Thanks for your reminding.
blocking-b2g: --- → 2.0M?
Flags: needinfo?(gchen)

Comment 37

4 years ago
Hi Gary,
2.0M+ Thanks!
blocking-b2g: 2.0M? → 2.0M+

Updated

4 years ago
Flags: needinfo?(gchen)
landed in v2.0m:
https://github.com/mozilla-b2g/gaia/commit/7b6a61871b2dfefe9ec9868da99de5b85e0076e2
status-b2g-v2.0M: affected → fixed
Flags: needinfo?(gchen)
(Reporter)

Comment 39

4 years ago
hi mozilla:
    有一个现象想咨询一下,飞行模式在点击时设置开启或者关闭的耗时太久,有时会长达5分钟左右,是否可以优化或者能否提供一个优化的思路?
You need to log in before you can comment on or make changes to this bug.