[Gaia JS integration test] JavaScript Error: "TypeError: Cannot set property 'contextmenuapp.gaiamobile.org' of undefined"

RESOLVED FIXED

Status

Firefox OS
Gaia::System
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jeremychen, Assigned: jeremychen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

It happens after I pulled the latest gaia code and ran gaia js integration test on b2g desktop this morning. It seems that patches from Bug 1138726 delete a necessary property "apps" from object "opts" in context_menu_test.js.

### Repro Steps:
execute under gaia folder
TEST_FILES=[PATH-TO-context_menu_test.js] make test-integration-test

### Expected:
Run the test as usual.

### Actual:
Test stopped due to JavaScript Error.

### Reproduce rate
always
Assignee: nobody → jeremychen

Comment 1

2 years ago
Created attachment 8572425 [details] [review]
[gaia] chenpighead:bug1139265 > mozilla-b2g:master
Attachment #8572425 - Flags: review?(alive)
Comment on attachment 8572425 [details] [review]
[gaia] chenpighead:bug1139265 > mozilla-b2g:master

Thanks!
Attachment #8572425 - Flags: review?(alive) → review+
Keywords: checkin-needed

Updated

2 years ago
Keywords: checkin-needed

Comment 3

2 years ago
Pull request has landed in master: https://github.com/mozilla-b2g/gaia/commit/9c2d4b4ebdca5ebd7dcbb70debabcaac1a001694

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.