[Nexus 5][Settings]PIN code input page won't disppear in time.

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: huayu.li, Assigned: apastor)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-nexus-5-l] [systemsfe])

Attachments

(7 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Posted file logcat1.txt
[1.Description]:
[Nexus 5][Settings] For the SIM card with a PIN code, when we input the code and tap OK button, this page won't disspear immediately.
Found at:10:41
See attachments:PINcodeinputpage.3gp,logcat1.txt

[2.Testing Steps]: 
1.Insert a SIM card with PIN code and reboot device.
2.Input PIN code and tap OK.

[3.Expected Result]: 
2.After tapping OK, device should go to home page immediately.

[4.Actual Result]: 
2.The PIN code page won't disppear immediately. When we tap ok button again, it will disppear immediately.

[5.Reproduction build]: 
N5:
Build ID               20150303002527
Gaia Revision          3d188c414e30acc392253d5389a42352fcfbc183
Gaia Date              2015-03-03 00:53:42
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c89aad487aa5
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150303.040940
Firmware Date          Tue Mar  3 04:09:55 EST 2015
Bootloader             HHZ12d

Flame 2.2 build:
Build ID               20150303002527
Gaia Revision          3d188c414e30acc392253d5389a42352fcfbc183
Gaia Date              2015-03-03 00:53:42
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c89aad487aa5
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150303.034757
Firmware Date          Tue Mar  3 03:48:06 EST 2015
Bootloader             L1TC000118D0

Flame 3.0:
Build ID               20150303010233
Gaia Revision          c8ed1085a67490a1ecd7f275e5de9487e1b93b1d
Gaia Date              2015-03-02 20:14:21
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0b3c520002ad
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150303.044015
Firmware Date          Tue Mar  3 04:40:27 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Occasionally Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
This issue does not exist on Flame 2.2.
(Reporter)

Comment 1

4 years ago
Posted video PINcodeinputpage.3gp
blocking-b2g: --- → 2.2?
Flags: needinfo?(huayu.li)
Whiteboard: [2.2-nexus-5-l]
(Reporter)

Updated

4 years ago
Flags: needinfo?(huayu.li)

Comment 2

4 years ago
qawanted to check on nexus 5 v3.0
Keywords: qawanted
Posted video N5v3.0 Video
The phenomenon on N5 v3.0 is a little different from N5 v2.2:
N5 v2.2: After you input PIN code and tap “OK” button, the keyboard can't be hiddend, and the PIN code page will display about 2~3 second and then disappear.

N5 v3.0: After you input PIN code and tap “OK” button, the keyboard will be hidden, and the PIN code page will display about 1 second and then disappear.
See attachment: N5_3.0_Video.MP4 & logcat_1453.txt
Rate: 5/5
N5 v3.0 build:
Build ID               20150308160204
Gaia Revision          fea83511df9ccba64259346bc02ebf2c417a12c2
Gaia Date              2015-03-08 06:36:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/eab4a81e4457
Gecko Version          39.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150308.192431
Firmware Date          Sun Mar  8 19:24:47 EDT 2015
Bootloader             HHZ12d
Posted file logcat
QA Whiteboard: [MGSEI-Triage+]
Keywords: qawanted

Updated

4 years ago
Component: Gaia::Settings → Gaia::System
Whiteboard: [2.2-nexus-5-l] → [2.2-nexus-5-l] [systemsfe]
(Assignee)

Updated

4 years ago
Assignee: nobody → apastor
(Assignee)

Comment 5

4 years ago
Hi Alissa,

Is this still happening in the flame 3.0? If so, how many SIM's are you using? In which slot? Is that happening with all the carriers? Sorry for so many questions. I'm not able to repro it so far.

Thanks!
Flags: needinfo?(huayu.li)
(Reporter)

Comment 6

4 years ago
(In reply to Alberto Pastor [:albertopq] from comment #5)
> Hi Alissa,
> 
> Is this still happening in the flame 3.0? If so, how many SIM's are you
> using? In which slot? Is that happening with all the carriers? Sorry for so
> many questions. I'm not able to repro it so far.
> 
> Thanks!

No, this issue doesn't exist on flame3.0, it's Nexus5 issue.
Flags: needinfo?(huayu.li)
(Assignee)

Comment 7

4 years ago
Sorry, I was confused by:

> [8.Note]:
> This issue does not exist on Flame 2.2.

I understood that it doesn't exist on Flame 2.2 but it does on 3.0. I'll try to find a Nexus 5.

Thanks!
(Assignee)

Comment 8

4 years ago
It seems that it takes more time in the Nexus 5 to unlock the SIM. Asking UX input here. Francis, what should we do in the meanwhile the PIN is being checked? Right now we are clearing the input field only (which I agree is a little bit confusing), and closing the dialog when the PIN has been checked as correct.

Note that if is not correct, it will show the error message in the same SIM PIN dialog.
Flags: needinfo?(fdjabri)
(In reply to Alberto Pastor [:albertopq] from comment #8)
> It seems that it takes more time in the Nexus 5 to unlock the SIM. Asking UX
> input here. Francis, what should we do in the meanwhile the PIN is being
> checked? Right now we are clearing the input field only (which I agree is a
> little bit confusing), and closing the dialog when the PIN has been checked
> as correct.
> 
> Note that if is not correct, it will show the error message in the same SIM
> PIN dialog.

Hi Alberto, 

I'd recommend that we don't clear the input field and show an inline activity indicator in the PIN field while the PIN is being checked. You can see an example of the inline activity indicator in the Messages app in conversation bubbles while an SMS is being sent. Let me know if that's enough detail, or if you need some wireframes.
Flags: needinfo?(fdjabri)
(Assignee)

Comment 11

4 years ago
Alissa, could you please check if the patch I just attached helps to solve the problem? You should see the input being disabled (but not cleared) while checking if is correct. Thanks!
Flags: needinfo?(huayu.li)
blocking-b2g: 2.2? → 2.2+
(Assignee)

Comment 12

4 years ago
Shine, as you were also checking this issue, could you try the patch I provided? Thanks!
Flags: needinfo?(yue.xia)
Hi Alberto,
I will check this issue after downloading the patch. Thanks~
(In reply to Alberto Pastor [:albertopq] from comment #12)
> Shine, as you were also checking this issue, could you try the patch I
> provided? Thanks!

Hi Alberto,
This problem cannot be repro with the patch in comment 10. After input passcode and tap "OK" button, the passcode view and keyboard will be hidden immediately.
See attachment: Video_N5v2.2.MP4
Rate: 0/5

N5 v2.2 build:
Build ID               20150319230147
Gaia Revision          c8136ef4094fc5509551ab7b1d5f6141491f00ef
Gaia Date              2015-03-20 01:40:54
Gecko Revision         n/a
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.rose64.20150319.223154
Firmware Date          Thu Mar 19 22:32:41 EDT 2015
Bootloader             HHZ12d
Flags: needinfo?(yue.xia)
Per comment 14, clear NI.
Flags: needinfo?(huayu.li)
(Assignee)

Updated

4 years ago
Attachment #8578612 - Flags: review?(alive)
Comment on attachment 8578612 [details] [review]
[gaia] albertopq:1139308-empty-PIN > mozilla-b2g:master

Overall it's good idea, but enable()/disable() simLockDialog seems to turn on/off the whole dialog to me. Let's use enableInput()/disableInput() instead. Thanks!
Attachment #8578612 - Flags: review?(alive) → review+
(Assignee)

Updated

4 years ago
Attachment #8581347 - Attachment is obsolete: true
(Assignee)

Comment 19

4 years ago
master: https://github.com/mozilla-b2g/gaia/commit/f72d2640f4be3583ac4b476ec07b6cc2bf5e8665
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Please uplift to v2.2, thanks.
Keywords: verifyme
(Assignee)

Comment 21

4 years ago
Comment on attachment 8578612 [details] [review]
[gaia] albertopq:1139308-empty-PIN > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):-
[User impact] if declined: there is no feedback between entering the PIN number, and the pin being verified, so the user will see an empty pin dialog 
[Testing completed]: added unit tests
[Risk to taking this patch] (and alternatives if risky): this is the alternative with lower risk in order to fix the issue. It just consists on disabling the input (without clearing it) before hiding the dialog.
[String changes made]: -
Attachment #8578612 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8578612 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
(Assignee)

Updated

4 years ago
Depends on: 1147944
Posted video video
This problem is verified pass on latest build of N5 v2.2 and v3.0.
Actual result: After input passcode and tap "OK" button, the passcode view and keyboard will be hidden immediately.
See attachment: Verify_video2.MP4
Rate: 0/10

Device: Nexus5 2.2 (Pass)
Build ID               20150327162502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/b358619def45
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150327.195950
Firmware Date          Fri Mar 27 20:00:03 EDT 2015
Bootloader             HHZ12d

Nexus5 3.0 (Pass)
Build ID               20150327160203
Gaia Revision          9cc496cecc37d7a29f9279827cdf6e4891211f67
Gaia Date              2015-03-27 13:55:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/44e454b5e93b
Gecko Version          39.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150327.192727
Firmware Date          Fri Mar 27 19:27:40 EDT 2015
Bootloader             HHZ12d
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.