startup crash in JS::IsProfilingEnabledForRuntime(JSRuntime*), if you have Gecko Profiler Addon installed

RESOLVED DUPLICATE of bug 1139506

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 1139506
3 years ago
3 years ago

People

(Reporter: automatedtester, Unassigned)

Tracking

({crash, regression})

Trunk
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-89e3fda1-f648-480f-805c-d450a2150304.
=============================================================


This is causing a constant crash on startup for me. Most plugins are enabled for me but couldnt get into firefox without going into safe mode so about:support report below shows them disabled when they are enabled for the crash


{
  "application": {
    "name": "Firefox",
    "version": "39.0a1",
    "buildID": "20150304030231",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:39.0) Gecko/20100101 Firefox/39.0",
    "updateChannel": "nightly",
    "supportURL": "https://support.mozilla.org/1/firefox/39.0a1/Darwin/en-US/",
    "numTotalWindows": 1,
    "numRemoteWindows": 0,
    "remoteAutoStart": false
  },
  "crashes": {
    "submitted": [
      {
        "id": "bp-89e3fda1-f648-480f-805c-d450a2150304",
        "date": 1425485453000,
        "pending": false
      },
      {
        "id": "bp-be063e9d-cfbc-4239-b66c-3eedd2150304",
        "date": 1425485253000,
        "pending": false
      },
      {
        "id": "bp-69b7ffed-379a-4359-aef7-fffe22150304",
        "date": 1425485143000,
        "pending": false
      },
      {
        "id": "bp-0f51f4ab-b2e9-4099-8c1f-5c4292150304",
        "date": 1425485106000,
        "pending": false
      },
      {
        "id": "bp-b75cf5db-4779-44ce-80a9-a19992150304",
        "date": 1425485083000,
        "pending": false
      },
      {
        "id": "bp-a19bf83a-0238-499c-b237-6a2d32150303",
        "date": 1425398391000,
        "pending": false
      }
    ],
    "pending": 0
  },
  "modifiedPreferences": {
    "accessibility.typeaheadfind.flashBar": 0,
    "browser.cache.disk.smart_size_cached_value": 358400,
    "browser.cache.disk.smart_size.first_run": false,
    "browser.cache.disk.smart_size.use_old_max": false,
    "browser.cache.disk.capacity": 358400,
    "browser.cache.disk.filesystem_reported": 1,
    "browser.cache.frecency_experiment": 4,
    "browser.download.importedFromSqlite": true,
    "browser.places.smartBookmarksVersion": 7,
    "browser.search.useDBForOrder": true,
    "browser.sessionstore.upgradeBackup.latestBuildID": "20150304030231",
    "browser.startup.homepage_override.mstone": "39.0a1",
    "browser.startup.homepage_override.buildID": "20150304030231",
    "dom.mozApps.runUpdate": false,
    "dom.w3c_touch_events.expose": false,
    "dom.mozApps.maxLocalId": 1001,
    "dom.mozTCPSocket.enabled": true,
    "dom.mozApps.used": true,
    "extensions.lastAppVersion": "39.0a1",
    "media.gmp-gmpopenh264.lastUpdate": 1422567644,
    "media.gmp-gmpopenh264.version": "1.3",
    "media.gmp-manager.lastCheck": 1425417085,
    "media.gmp-gmpopenh264.path": "/Users/dburns/Library/Application Support/Firefox/Profiles/yc217km5.Nightly/gmp-gmpopenh264",
    "network.cookie.prefsMigrated": true,
    "network.predictor.cleaned-up": true,
    "network.http.spdy.enabled.http2draft": false,
    "places.database.lastMaintenance": 1425418537,
    "places.history.expiration.transient_current_max_pages": 104858,
    "plugin.importedState": true,
    "plugin.state.java": 0,
    "plugin.disable_full_page_plugin_for_types": "application/pdf",
    "print.print_plex_name": "",
    "print.print_margin_top": "0.5",
    "print.print_paper_width": "  8.50",
    "print.print_orientation": 0,
    "print.print_paper_name": "",
    "print.print_to_file": false,
    "print.print_scaling": "  1.00",
    "print.print_unwriteable_margin_right": 25,
    "print.print_paper_height": " 11.00",
    "print.print_command": "",
    "print.print_reversed": false,
    "print.print_unwriteable_margin_left": 25,
    "print.print_evenpages": true,
    "print.print_unwriteable_margin_bottom": 57,
    "print.print_resolution_name": "",
    "print.print_duplex": 402653184,
    "print.print_paper_size_unit": 0,
    "print.print_margin_right": "0.5",
    "print.print_oddpages": true,
    "print.print_bgcolor": false,
    "print.print_colorspace": "",
    "print.print_bgimages": false,
    "print.print_downloadfonts": false,
    "print.print_margin_left": "0.5",
    "print.print_shrink_to_fit": true,
    "print.print_unwriteable_margin_top": 25,
    "print.print_margin_bottom": "0.5",
    "print.print_in_color": true,
    "print.print_paper_size_type": 1,
    "print.print_page_delay": 50,
    "print.print_paper_data": 0,
    "print.print_resolution": 0,
    "privacy.sanitize.timeSpan": 0,
    "privacy.cpd.downloads": false,
    "privacy.cpd.cookies": false,
    "privacy.sanitize.migrateFx3Prefs": true,
    "privacy.donottrackheader.enabled": true,
    "privacy.cpd.formdata": false,
    "privacy.cpd.sessions": false,
    "privacy.cpd.history": false,
    "privacy.cpd.offlineApps": true,
    "security.warn_viewing_mixed": false,
    "storage.vacuum.last.places.sqlite": 1423095578,
    "storage.vacuum.last.index": 1
  },
  "lockedPreferences": {},
  "graphics": {
    "numTotalWindows": 1,
    "numAcceleratedWindows": 0,
    "windowLayerManagerType": "Basic",
    "windowLayerManagerRemote": false,
    "numAcceleratedWindowsMessage": [
      ""
    ],
    "adapterDescription": "",
    "adapterVendorID": "0x10de",
    "adapterDeviceID": "0x fd5",
    "adapterRAM": "",
    "adapterDrivers": "",
    "driverVersion": "",
    "driverDate": "",
    "webglRenderer": "NVIDIA Corporation -- NVIDIA GeForce GT 650M OpenGL Engine",
    "info": {
      "AzureCanvasBackend": "quartz",
      "AzureSkiaAccelerated": 0,
      "AzureFallbackCanvasBackend": "none",
      "AzureContentBackend": "quartz"
    }
  },
  "javaScript": {
    "incrementalGCEnabled": true
  },
  "accessibility": {
    "isActive": false,
    "forceDisabled": 0
  },
  "libraryVersions": {
    "NSPR": {
      "minVersion": "4.10.8",
      "version": "4.10.8"
    },
    "NSS": {
      "minVersion": "3.18 Basic ECC Beta",
      "version": "3.18 Basic ECC Beta"
    },
    "NSSUTIL": {
      "minVersion": "3.18 Beta",
      "version": "3.18 Beta"
    },
    "NSSSSL": {
      "minVersion": "3.18 Basic ECC Beta",
      "version": "3.18 Basic ECC Beta"
    },
    "NSSSMIME": {
      "minVersion": "3.18 Basic ECC Beta",
      "version": "3.18 Basic ECC Beta"
    }
  },
  "userJS": {
    "exists": false
  },
  "extensions": [
    {
      "name": "ADB Helper",
      "version": "0.7.4",
      "isActive": false,
      "id": "adbhelper@mozilla.org"
    },
    {
      "name": "Adblock Plus",
      "version": "2.6.7",
      "isActive": false,
      "id": "{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}"
    },
    {
      "name": "Buffer",
      "version": "2.8.3",
      "isActive": false,
      "id": "jid1-zUyU7TGKwejAyA@jetpack"
    },
    {
      "name": "DuckDuckGo Plus",
      "version": "0.4.6",
      "isActive": false,
      "id": "jid1-ZAdIEUB7XOzOJw@jetpack"
    },
    {
      "name": "Evernote Web Clipper",
      "version": "5.9.1",
      "isActive": false,
      "id": "{E0B8C461-F8FB-49b4-8373-FE32E9252800}"
    },
    {
      "name": "Firefox OS Simulator",
      "version": "4.0.2",
      "isActive": false,
      "id": "r2d2b2g@mozilla.org"
    },
    {
      "name": "Gecko Profiler",
      "version": "1.15.7",
      "isActive": false,
      "id": "jid0-edalmuivkozlouyij0lpdx548bc@jetpack"
    },
    {
      "name": "Ghostery",
      "version": "5.4.2",
      "isActive": false,
      "id": "firefox@ghostery.com"
    },
    {
      "name": "Github Tweaks for Bugzilla",
      "version": "1.40",
      "isActive": false,
      "id": "jid0-AWShpy08txla2QGDYvv5bed4sjs@jetpack"
    },
    {
      "name": "Github+Travis",
      "version": "0.2.6",
      "isActive": false,
      "id": "githubtravis@theautomatedtester.co.uk"
    },
    {
      "name": "Greasemonkey",
      "version": "2.3",
      "isActive": false,
      "id": "{e4a8a97b-f2ed-450b-b12d-ee082ba24781}"
    },
    {
      "name": "LastPass",
      "version": "3.1.77",
      "isActive": false,
      "id": "support@lastpass.com"
    },
    {
      "name": "Lightbeam",
      "version": "1.2.1",
      "isActive": false,
      "id": "jid1-F9UJ2thwoAm5gQ@jetpack"
    },
    {
      "name": "Pocket",
      "version": "3.0.6",
      "isActive": false,
      "id": "isreaditlater@ideashower.com"
    },
    {
      "name": "Test Pilot",
      "version": "1.2.3",
      "isActive": false,
      "id": "testpilot@labs.mozilla.com"
    },
    {
      "name": "Whimsy Pro",
      "version": "1.0.8",
      "isActive": false,
      "id": "jid1-6mUPixNFCjAgkg@jetpack"
    }
  ],
  "experiments": []
}
I hit this as well, e.g. bp-943b8ea4-1b4a-499d-ab4b-678382150304

I was able to start Firefox without crashing after I removed the Gecko Profiler addon (in safe mode).
Line 1 of the backtrace is this TableTicker.cpp call to IsProfilingEnabledForRuntime, which was added in the last few days by djvj, for bug 1130367:
http://hg.mozilla.org/mozilla-central/rev/44efa0956b53#l6.14
Blocks: 1130367
Flags: needinfo?(kvijayan)
Keywords: regression
OS: Mac OS X → All
Version: unspecified → Trunk
Summary: crash in JS::IsProfilingEnabledForRuntime(JSRuntime*) → startup crash in JS::IsProfilingEnabledForRuntime(JSRuntime*), if you have Gecko Profiler Addon installed
(Reporter)

Comment 3

3 years ago
yup, got browser working again once I removed GeckoProfiler
This was reported earlier in bug 1139506.  Patch posted, awaiting review.  Marking this one dup.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(kvijayan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1139506
You need to log in before you can comment on or make changes to this bug.