Closed Bug 1139506 Opened 5 years ago Closed 5 years ago

crash in mergeStacksIntoProfile or @ JS::IsProfilingEnabledForRuntime(JSRuntime*), with Gecko Profiler add-on

Categories

(Core :: Gecko Profiler, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla39
Tracking Status
firefox38 --- fixed
firefox39 --- fixed

People

(Reporter: vladan, Assigned: djvj)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-bba378a9-2f68-4d24-ae33-c516b2150304.
=============================================================

Reproducible startup crash on recent Nightlies with Gecko Profiler extension enabled.
Sometimes JS runtime is NULL when profiling.
Attachment #8572751 - Flags: review?(shu)
Duplicate of this bug: 1139459
Attachment #8572751 - Flags: review?(shu) → review+
Adding crash-signature from duplicate bug 1139459
Crash Signature: [@ mergeStacksIntoProfile] → [@ mergeStacksIntoProfile] [@ JS::IsProfilingEnabledForRuntime(JSRuntime*)]
Summary: crash in mergeStacksIntoProfile → crash in mergeStacksIntoProfile or @ JS::IsProfilingEnabledForRuntime(JSRuntime*), with Gecko Profiler add-on
Blocks: 1130367
Keywords: regression
OS: Windows NT → All
Hardware: x86 → All
Version: unspecified → Trunk
https://hg.mozilla.org/mozilla-central/rev/09ef352a8536
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
I just experienced this crash on Developer Edition (38.0a2):

https://crash-stats.mozilla.com/report/index/2811bd5a-c79a-47ae-bf18-c32392150317

Is it possible that this fix needs to get uplifted?
Flags: needinfo?(kvijayan)
Yes, this needs uplift to be pushed up into aurora.  It seemed, since the regressing patch landed on March 02, that this wouldn't be the case, but the problem definitely exists in aurora browsing the code.
Flags: needinfo?(kvijayan)
Comment on attachment 8572751 [details] [diff] [review]
fix-bug-1139506.patch

Approval Request Comment
[Feature/regressing bug #]:
Bug 1130367

[User impact if declined]:
Crashes when starting with gecko profiler plugin turned on and enabled.

[Describe test coverage new/current, TreeHerder]:
In central for few weeks now.

[Risks and why]:
Very low risk.  Just adds a null check and an assert.

[String/UUID change made/needed]:
N/A
Attachment #8572751 - Flags: approval-mozilla-aurora?
Comment on attachment 8572751 [details] [diff] [review]
fix-bug-1139506.patch

Fix a crash, taking it.
Attachment #8572751 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.