meta.wikimedia.org POSTs appearing in other tabs network inspectors

RESOLVED DUPLICATE of bug 1160837

Status

RESOLVED DUPLICATE of bug 1160837
4 years ago
2 months ago

People

(Reporter: heyyou111, Unassigned)

Tracking

38 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8572759 [details]
Same request between the two pages

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150303004530

Steps to reproduce:

1. Open a Wikipedia page (ex: http://en.wikipedia.org/wiki/Sublime_Text)
2. Open the Inspector and select the network tab.
3. Open a new tab (You can load any site, but it will work with about:newtab)
4. Switch back to the Wikipedia page.
5. Do a hard refresh of the page (Ctrl-F5) until there is a POST request made to http://meta.wikimedia.org/w/index.php?title=Special:RecordImpression...
5. Switch back to the new tab.


Actual results:

The POST request to meta.wikimedia.org shows up in the new tabs inspector, despite not having been called by that page. If multiple inspectors are open in multiple tabs, it will show up in all of them regardless.


Expected results:

The POST request should only happen or be visible in the tab that spawned the request.
Component: Untriaged → Developer Tools: Netmonitor
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1160837

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.