Receipts for $0.00 price tier not working

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: andy+bugzilla, Unassigned)

Tracking

2014-Q4
x86
Mac OS X
Points:
---

Details

(Reporter)

Description

4 years ago
Installed: https://marketplace.firefox.com/app/compound-interest/ which is Paid but set to the $0.00 tier. It can be installed for free, it adds in a receipt.

The receipt gets installed successfully, but when checking it throws an error:

[master] receipts $ python fx.py -l -p dev-edition-default -c -e
...
{7679ccad-b858-2445-a9b1-8d20d033d50a}: 1 receipt
    Issued: 04 March 15, expires 02 September 15
Checking 1 receipt(s) for app: {7679ccad-b858-2445-a9b1-8d20d033d50a}
Verifying at: https://receiptcheck.marketplace.firefox.com/verify/
{u'status': u'invalid', u'reason': u'NO_PURCHASE'}
Server returned: invalid

The result is that the verification is failing because of a lack of purchase. Not sure where the issue is here: is that a zero purchase didn't get added (and was meant to), that the receipt check should skip this check for a zero purchase or something else.
(Reporter)

Comment 1

4 years ago
Its hard to remember all this stuff. But basically the problem was I installed it using the same account as the developer who created the app. That means we don't record the transaction and the validation fails. The key point being here:

https://github.com/mozilla/zamboni/blob/master/mkt/receipts/views.py#L246-L248

Where it checks to see if its a developer install or not. Perhaps we should record developer installs? But for the moment, I'm marking as working.

Here's how it looks:

[master] $ receipts -p test-receipts -c
Checking Firefox.
Checking 1 receipt(s) for app: {d2053a7f-b5e6-2847-a896-2d499396f148}
Verifying at: https://receiptcheck.marketplace.firefox.com/verify/
Server returned: ok
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.