downloaded file blocked and deleted after download

VERIFIED DUPLICATE of bug 1137909

Status

()

Firefox
Downloads Panel
--
enhancement
VERIFIED DUPLICATE of bug 1137909
3 years ago
3 years ago

People

(Reporter: vey.quentin, Unassigned)

Tracking

31 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0 Iceweasel/38.0a2
Build ID: 20150227004023

Steps to reproduce:

Download a (quite large) file from uploaded.net with iceweasel 31.5.0


Actual results:

After several hours of download, the download manager marked the file as "Blocked, may contain a virus or a spyware" and the actual file was deleted.


Expected results:

If it was because of a bad reputation of the website/address : the error should have appeared at the beginning of the download, and not after several hours.

If it was because of the result of a scan : give the user the choice delete/quarantine the file (at least on the first appearance of this error).

In any case, having a more verbose error would help a lot the slightly above average user to understand what is happening.
(Reporter)

Updated

3 years ago
Severity: normal → enhancement
The story behind this feature: http://monica-at-mozilla.blogspot.de/2014/07/download-files-more-safely-with-firefox.html

Monica: Is this an expected behavior that a downloaded file get only blocked and deleted after they are downloaded ?
Component: Untriaged → Downloads Panel
Flags: needinfo?(mmc)
Yes, because the hash of the full downloaded file is necessary in some cases to perform the malware check. There will be quarantine behavior that comment 0 requests (instead of straight deletion) in https://bugzilla.mozilla.org/show_bug.cgi?id=1137909.
Flags: needinfo?(mmc)
(Reporter)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1137909
Thank you Monica for your explanation.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.