Non harmful app update xpcshell test error in the mock xmlhttprequest: undefined property 'QueryInterface'

RESOLVED FIXED in Firefox 39

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: rstrong, Assigned: rstrong)

Tracking

unspecified
mozilla39
x86_64
Windows 8.1
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox39 fixed)

Details

Attachments

(1 attachment)

I've seen this in a few of the tests and it is caused by not having a real channel for the mock xmlhttprequest. Simple patch coming up.
Created attachment 8573055 [details] [diff] [review]
patch
Attachment #8573055 - Flags: review?(spohl.mozilla.bugs)
Attachment #8573055 - Flags: review?(spohl.mozilla.bugs) → review+
Pushed to fx-team
https://hg.mozilla.org/integration/fx-team/rev/bfc78edb03a7
Flags: in-testsuite+
Target Milestone: --- → mozilla39
https://hg.mozilla.org/mozilla-central/rev/bfc78edb03a7
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.